summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/torrentinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/torrentinfo')
-rw-r--r--net-p2p/torrentinfo/Manifest1
-rw-r--r--net-p2p/torrentinfo/metadata.xml17
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild26
3 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/torrentinfo/Manifest b/net-p2p/torrentinfo/Manifest
new file mode 100644
index 000000000000..e9683c5a8ff2
--- /dev/null
+++ b/net-p2p/torrentinfo/Manifest
@@ -0,0 +1 @@
+DIST torrentinfo-1.8.6.tar.gz 22232 SHA256 8008d4933ba7e9f75a34318caeaceb58b56d7fd6c7d75fff70acea2716447582 SHA512 7f36f6c80876cbd70ea9e1331195c8a30a6546406f345402d4bec5c58afb9b03a3b60189b8d177a63a7047c3ede7fc18d8fc47ecb1bcbb726dd01b7cb2a6efb2 WHIRLPOOL 9a2acb0a979f518a94e6210cdcf9694b3b9e314d1b3dae0faeabb43fa604b1bfcd3fcc14719342b4e1e2b07f5f66cadfec603f52cf43c88fd8bcd11cee84350d
diff --git a/net-p2p/torrentinfo/metadata.xml b/net-p2p/torrentinfo/metadata.xml
new file mode 100644
index 000000000000..ed25b369cd98
--- /dev/null
+++ b/net-p2p/torrentinfo/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>nikoli@gmx.us</email>
+ <name>Nikoli</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>fuuzetsu@fuuzetsu.co.uk</email>
+ <name>Mateusz Kowalczyk</name>
+ </maintainer>
+ <bugs-to>https://github.com/ShanaTsunTsunLove/torrentinfo/issues</bugs-to>
+ <remote-id type="github">Fuuzetsu/torrentinfo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild
new file mode 100644
index 000000000000..6329cf3b8ed2
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
+SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests -v test/tests.py || die "Tests fail with ${EPYTHON}"
+}