summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-10 07:39:12 +0100
committerSam James <sam@gentoo.org>2022-06-10 07:39:51 +0100
commit67e0872f2e38affd1e12147c7fff5b543fe7769f (patch)
treebe4c8662ad9952c7942bdd5d3b2435e432dfa181 /net-p2p/go-ethereum
parentdev-util/cbindgen: add 0.24.3 (diff)
downloadgentoo-67e0872f2e38affd1e12147c7fff5b543fe7769f.tar.gz
gentoo-67e0872f2e38affd1e12147c7fff5b543fe7769f.tar.bz2
gentoo-67e0872f2e38affd1e12147c7fff5b543fe7769f.zip
net-p2p/go-ethereum: add 1.10.18
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p/go-ethereum')
-rw-r--r--net-p2p/go-ethereum/Manifest2
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.10.18.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index dd48a9026bae..2d73f417d911 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1,2 +1,4 @@
DIST go-ethereum-1.10.17-deps.tar.xz 214301320 BLAKE2B a02260dfc7bf268d8812cc506a40bcbef4ab2c05bc52eb300771f2d07faa7ffcf20d901c65a6193275de720a13eddfd79c9f6f99ac0b69ad0e0a99b39122e4ac SHA512 5f62bf79ed744cdff3bf0e4f06eb8c40c56bfff867fbb83cb39435c5a1692075a510147d1c26cad6953d82264dad73b774c3ab480881f37ce44f5e1fb469380b
DIST go-ethereum-1.10.17.tar.gz 13535265 BLAKE2B 680fe12fa9c72e5e3288939bb04b5940ef48b3bb7e2567f5937ea00f52d5293a53410fbfc57c7a5693c24922d4b3f55047ce62174c46a2578fa2657c26dd14a1 SHA512 2f7089dd652a758eebd2f44e2fb07f663b2496139a36bf255f7e1803c7cb87eeb2dfb6837d898bf8535b52e794654cca89ed18bff66d5430ee82af7daf444238
+DIST go-ethereum-1.10.18-deps.tar.xz 212331228 BLAKE2B c79bd57805eb7f0d0ac29efc76b38bcb2f74803ff4e7dd36b1c1d561fb06346385da53d6e043e9b289af4f916079c5b281eeebb30c02e3f33a77ad918d7b29da SHA512 34df89df46b96cf1157f7b56f50b4e229fdf9640d76ebafc2d9965b28484561c9d3a33f1304d8c0690d5b52117b491432f87a5b0af0db294e0a0d76f469f1f2a
+DIST go-ethereum-1.10.18.tar.gz 13084436 BLAKE2B 4918f13b131796f928c17e6cbd3ab42095d4a52874865a2e9b9c6e8b8e4528af0152055c8d8556c795079bd2bc044e9a0fd028d4a90c66181c0cafddb41cf7ae SHA512 ba2b7091ac4ffd5bf02dbc27769ebd138b82dd9d79fb613e727f56f6cfaf969183f343511478e88fbead627141101e77206a4c2449b0ced9a7a2090b4c77d996
diff --git a/net-p2p/go-ethereum/go-ethereum-1.10.18.ebuild b/net-p2p/go-ethereum/go-ethereum-1.10.18.ebuild
new file mode 100644
index 000000000000..c1f8d530e519
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.10.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools"
+
+# Does all kinds of wonky stuff like connecting to Docker daemon, network activity, ...
+RESTRICT+=" test"
+
+src_compile() {
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+
+ if use devtools; then
+ dobin build/bin/abidump
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/checkpoint-admin
+ dobin build/bin/clef
+ dobin build/bin/devp2p
+ dobin build/bin/ethkey
+ dobin build/bin/evm
+ dobin build/bin/faucet
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ fi
+}