summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-10 05:06:14 +0100
committerSam James <sam@gentoo.org>2023-04-10 05:06:14 +0100
commitcc8c224903f48c9154a66e70383ef72b706c2d38 (patch)
tree60354c5ac6dd9f21f9ffaaef9869070af23763be /net-p2p/bitcoin-cli
parentnet-p2p/bitcoin-qt: fix build w/ gcc 13 (diff)
downloadgentoo-cc8c224903f48c9154a66e70383ef72b706c2d38.tar.gz
gentoo-cc8c224903f48c9154a66e70383ef72b706c2d38.tar.bz2
gentoo-cc8c224903f48c9154a66e70383ef72b706c2d38.zip
net-p2p/bitcoin-cli: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895814 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p/bitcoin-cli')
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-24.0.1-r1.ebuild1
-rw-r--r--net-p2p/bitcoin-cli/files/24.0.1-gcc13.patch39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-24.0.1-r1.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-24.0.1-r1.ebuild
index 61cee04d2c9c..c93ec569cf67 100644
--- a/net-p2p/bitcoin-cli/bitcoin-cli-24.0.1-r1.ebuild
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-24.0.1-r1.ebuild
@@ -29,6 +29,7 @@ DOCS=( doc/release-notes.md )
PATCHES=(
"${FILESDIR}"/24.0.1-syslibs.patch
+ "${FILESDIR}"/24.0.1-gcc13.patch
)
pkg_pretend() {
diff --git a/net-p2p/bitcoin-cli/files/24.0.1-gcc13.patch b/net-p2p/bitcoin-cli/files/24.0.1-gcc13.patch
new file mode 100644
index 000000000000..39cf81b14953
--- /dev/null
+++ b/net-p2p/bitcoin-cli/files/24.0.1-gcc13.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/903781
+https://bugs.gentoo.org/900246
+https://bugs.gentoo.org/895814
+https://bugs.gentoo.org/894734
+https://github.com/bitcoin/bitcoin/commit/fadeb6b103cb441e0e91ef506ef29febabb10715
+
+From fadeb6b103cb441e0e91ef506ef29febabb10715 Mon Sep 17 00:00:00 2001
+From: MarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>
+Date: Thu, 19 Jan 2023 19:35:43 +0100
+Subject: [PATCH] Add missing includes to fix gcc-13 compile error
+
+--- a/src/support/lockedpool.cpp
++++ b/src/support/lockedpool.cpp
+@@ -19,6 +19,9 @@
+ #endif
+
+ #include <algorithm>
++#include <limits>
++#include <stdexcept>
++#include <utility>
+ #ifdef ARENA_DEBUG
+ #include <iomanip>
+ #include <iostream>
+--- a/src/support/lockedpool.h
++++ b/src/support/lockedpool.h
+@@ -5,11 +5,11 @@
+ #ifndef BITCOIN_SUPPORT_LOCKEDPOOL_H
+ #define BITCOIN_SUPPORT_LOCKEDPOOL_H
+
+-#include <stdint.h>
++#include <cstddef>
+ #include <list>
+ #include <map>
+-#include <mutex>
+ #include <memory>
++#include <mutex>
+ #include <unordered_map>
+
+ /**