summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 04:26:48 +0000
committerSam James <sam@gentoo.org>2024-02-29 04:26:48 +0000
commit537bc0566761a253e5e755ced66110c41b12388a (patch)
tree18dbddb2bb1b170e78b12291fc4badb689909a35 /net-misc/whois
parentsys-apps/pciutils: add 3.11.1 (diff)
downloadgentoo-537bc0566761a253e5e755ced66110c41b12388a.tar.gz
gentoo-537bc0566761a253e5e755ced66110c41b12388a.tar.bz2
gentoo-537bc0566761a253e5e755ced66110c41b12388a.zip
net-misc/whois: add 5.5.21
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/Manifest1
-rw-r--r--net-misc/whois/whois-5.5.21.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-misc/whois/Manifest b/net-misc/whois/Manifest
index b95054a11941..b12bcc0f261d 100644
--- a/net-misc/whois/Manifest
+++ b/net-misc/whois/Manifest
@@ -1 +1,2 @@
DIST whois-5.5.20.tar.gz 109648 BLAKE2B 17b6a795ac517a81cde44530df3e835cccc020a1750ab28d50551a7bd08d132aa10768ff146b0a7943a8348cc7f3f3f7096262caf1d91fbb2d3610ae9f6473e8 SHA512 1d602ec817411a36b3d175e34f166c06186639f4eeea145751decc45372953df40fc76b57c7589d93c49ab0be1276459dffc6424a4344ddbca23f35a9f492fc7
+DIST whois-5.5.21.tar.gz 109621 BLAKE2B b1cf42f1a60e5009e5882f154432d5974f45c1bf89d8b36b73f6e5f55ff2dba02e8ca7900926d2824200f5422d5e9f00abde524d4e2d8a25ba37376cc2e8d04a SHA512 4f3ffbd875df89e910aa9d20616f2d04e773d3e5cd0c5d0262dca481fd6228214033b854ac4eebe078cfde14ab90429d826f24ce6c21ec14cfe8ad56e78ae6e9
diff --git a/net-misc/whois/whois-5.5.21.ebuild b/net-misc/whois/whois-5.5.21.ebuild
new file mode 100644
index 000000000000..afbc87e1ae4d
--- /dev/null
+++ b/net-misc/whois/whois-5.5.21.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Improved Whois Client"
+HOMEPAGE="https://github.com/rfc1036/whois"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rfc1036/whois.git"
+else
+ #SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
+ SRC_URI="https://github.com/rfc1036/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ #S="${WORKDIR}"/${PN}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="iconv idn nls xcrypt"
+
+RDEPEND="
+ iconv? ( virtual/libiconv )
+ idn? ( net-dns/libidn2:= )
+ nls? ( virtual/libintl )
+ xcrypt? ( >=sys-libs/libxcrypt-4.1:= )
+ !xcrypt? ( virtual/libcrypt:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ >=dev-lang/perl-5
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+ "${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+ "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
+)
+
+src_prepare() {
+ default
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile || die
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h || die
+
+ # don't generate po files when nls is disabled (bug #419889)
+ sed -i -e '/^all:/s/ pos//' \
+ -e '/^install:/s/ install-pos//' Makefile || die
+ fi
+}
+
+src_configure() { :; } # expected no-op
+
+src_compile() {
+ unset HAVE_ICONV HAVE_LIBIDN
+
+ use iconv && export HAVE_ICONV=1
+ use idn && export HAVE_LIBIDN=1
+ use xcrypt && export HAVE_XCRYPT=1
+
+ tc-export CC
+
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" BASHCOMPDIR="$(get_bashcompdir)" install
+
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+}