summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-09-16 12:55:34 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-16 12:57:53 +0200
commitae1766daedf1ac9b767fc682495a9e2ce123e800 (patch)
treeb757d526aaf4a0d62249cce6e46a0dfc4fdbfe3c /net-misc/spiped
parentdev-lang/crystal: add llvm-5 support, bug #630634 (diff)
downloadgentoo-ae1766daedf1ac9b767fc682495a9e2ce123e800.tar.gz
gentoo-ae1766daedf1ac9b767fc682495a9e2ce123e800.tar.bz2
gentoo-ae1766daedf1ac9b767fc682495a9e2ce123e800.zip
net-misc/spiped: update initd script and avoid privilege escalation.
Gentoo-Bug: https://bugs.gentoo.org/631022 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-misc/spiped')
-rw-r--r--net-misc/spiped/files/spiped.initd39
-rw-r--r--net-misc/spiped/spiped-1.6.0-r1.ebuild45
2 files changed, 58 insertions, 26 deletions
diff --git a/net-misc/spiped/files/spiped.initd b/net-misc/spiped/files/spiped.initd
index 0f33ccfa9cdb..ccc95ac80add 100644
--- a/net-misc/spiped/files/spiped.initd
+++ b/net-misc/spiped/files/spiped.initd
@@ -1,13 +1,19 @@
#!/sbin/openrc-run
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-KEYFILE=${KEYFILE:="/etc/spiped/keyfile"}
-SPIPED_USER=${SPIPED_USER:="nobody"}
-PIDFILE="/run/spiped/spiped.pid"
+: ${KEYFILE:="/etc/spiped/keyfile"}
+: ${SPIPED_USER:="nobody"}
-command="spiped"
-command_args="${OPTS} -s [${SRCHOST}]:${SRCPORT} -t ${TARGETHOST}:${TARGETPORT} -k ${KEYFILE} -p ${PIDFILE}"
+command="/usr/sbin/spiped"
+command_args="${OPTS}
+ -s [${SRCHOST}]:${SRCPORT}
+ -t ${TARGETHOST}:${TARGETPORT}
+ -k ${KEYFILE}
+ -F"
+command_background="true"
+command_user="${SPIPED_USER}"
+pidfile="/run/${RC_SVCNAME}.pid"
depend() {
use net
@@ -21,25 +27,6 @@ checkconfig() {
fi
}
-start() {
+start_pre() {
checkconfig || return 1
-
- ebegin "Starting ${SVCNAME}"
- checkpath -d -o "${SPIPED_USER}" -m750 "$(dirname "${PIDFILE}")"
-
- start-stop-daemon --start \
- --user ${SPIPED_USER} \
- --pidfile ${PIDFILE} \
- --exec $command -- $command_args
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
-
- start-stop-daemon --stop \
- --pidfile ${PIDFILE}
-
- eend $?
}
diff --git a/net-misc/spiped/spiped-1.6.0-r1.ebuild b/net-misc/spiped/spiped-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..ed4c445cb511
--- /dev/null
+++ b/net-misc/spiped/spiped-1.6.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+MY_PN="${PN/d/}"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+
+# Blocker added due to #548126
+RDEPEND="
+ ${DEPEND}
+ !net-mail/qlogtools"
+
+src_install() {
+ dobin "${MY_PN}/${MY_PN}"
+ dosbin "${PN}/${PN}"
+
+ doman "${MY_PN}/${MY_PN}.1" "${PN}/${PN}.1"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir "etc/${PN}"
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}