summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-10 16:45:25 +0000
committerMarek Szuba <marecki@gentoo.org>2021-11-10 16:49:15 +0000
commit0fe174ba9bf8ab790501dd496eef63a787d39796 (patch)
treea7ddc476eb933135b94f2ae99dbe9aee24c74459 /net-misc/oidc-agent
parentdev-ruby/localhost: fix WhitespaceFound (diff)
downloadgentoo-0fe174ba9bf8ab790501dd496eef63a787d39796.tar.gz
gentoo-0fe174ba9bf8ab790501dd496eef63a787d39796.tar.bz2
gentoo-0fe174ba9bf8ab790501dd496eef63a787d39796.zip
net-misc/oidc-agent: add 4.2.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-misc/oidc-agent')
-rw-r--r--net-misc/oidc-agent/Manifest1
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-4.2.2_makefile-toolchain-vars.patch43
-rw-r--r--net-misc/oidc-agent/oidc-agent-4.2.2.ebuild78
3 files changed, 122 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/Manifest b/net-misc/oidc-agent/Manifest
index fcd02ee8f700..a8b32fc55119 100644
--- a/net-misc/oidc-agent/Manifest
+++ b/net-misc/oidc-agent/Manifest
@@ -1,2 +1,3 @@
DIST oidc-agent-4.0.2.tar.gz 802872 BLAKE2B bbee872f0b029f4289a4805d1a5f8fe2fe2b8c297a918cf7821aec6bf4dbe634882425c888cb0e784778b56754af1c8b5a34d5282f84090cccf6315897ccb461 SHA512 fef440cd4b72055d8175f9f33c735235bb87bfca38b53bc4e049b1644f74f6a683d312297efa04cbacfe55190c5d6b588fa37475e5a55acff540909865389037
DIST oidc-agent-4.1.1.tar.gz 801103 BLAKE2B dcb82a537787ae6ced577843c67acdd4e3fa315d017222067b2914837dfffccae27ddbdeeeaf4e8ca70c7e2744e03df5964d3ba318efd4460c73252bfd3f8e95 SHA512 e383e054623dc3b8fe73ec02df44faa05d4b69aaed47c7925f6f92d25cbc5301173fbc607b6198bc70f99e634e582fbae7c5570812086a8e5694d40ce6d2c2d1
+DIST oidc-agent-4.2.2.tar.gz 823169 BLAKE2B 5ce071c1ac6e65ab7de869e9963884e60142dc1c93e8eb3eb00c144527754199867238eb45ca2cba814dedf7e55b2aedf66f45e613697ebc3262598fca0312e5 SHA512 852eb5c6c071aafa58366e5e867f95908cac2fa0c3b6924e021cc81825b0bba0549e74742eff0ef5a9bbb16173e21c94ba7b618150a42b585968b4cd4663409e
diff --git a/net-misc/oidc-agent/files/oidc-agent-4.2.2_makefile-toolchain-vars.patch b/net-misc/oidc-agent/files/oidc-agent-4.2.2_makefile-toolchain-vars.patch
new file mode 100644
index 000000000000..2df3afce8e68
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-4.2.2_makefile-toolchain-vars.patch
@@ -0,0 +1,43 @@
+--- a/Makefile
++++ b/Makefile
+@@ -92,9 +92,9 @@
+ endif
+
+ # Compiler options
+-CC = gcc
++CC := $(CC)
+ # compiling flags here
+-CFLAGS = -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra -fno-common
++CFLAGS := $(CFLAGS) -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra -fno-common
+ ifndef MAC_OS
+ ifndef NODPKG
+ CFLAGS +=$(shell dpkg-buildflags --get CPPFLAGS)
+@@ -106,11 +106,11 @@
+ TEST_CFLAGS = $(CFLAGS) -I.
+
+ # Linker options
+-LINKER = gcc
++LINKER := $(CC)
+ ifdef MAC_OS
+ LFLAGS = $(LSODIUM) $(LARGP)
+ else
+-LFLAGS = $(LSODIUM) $(LSECCOMP) -fno-common
++LFLAGS := $(LDFLAGS) $(LSODIUM) $(LSECCOMP) -fno-common
+ ifndef NODPKG
+ LFLAGS +=$(shell dpkg-buildflags --get LDFLAGS)
+ endif
+@@ -130,12 +130,12 @@
+ ifdef MAC_OS
+ CLIENT_LFLAGS = -L$(APILIB) $(LARGP) $(LAGENT) $(LSODIUM)
+ else
+-CLIENT_LFLAGS = -L$(APILIB) $(LAGENT) $(LSODIUM) $(LSECCOMP)
++CLIENT_LFLAGS := $(LDFLAGS) -L$(APILIB) $(LAGENT) $(LSODIUM) $(LSECCOMP)
+ ifndef NODPKG
+ CLIENT_LFLAGS += $(shell dpkg-buildflags --get LDFLAGS)
+ endif
+ endif
+-LIB_LFLAGS = -lc $(LSODIUM)
++LIB_LFLAGS := $(LDFLAGS) -lc $(LSODIUM)
+ ifndef MAC_OS
+ ifndef NODPKG
+ LIB_LFLAGS += $(shell dpkg-buildflags --get LDFLAGS)
diff --git a/net-misc/oidc-agent/oidc-agent-4.2.2.ebuild b/net-misc/oidc-agent/oidc-agent-4.2.2.ebuild
new file mode 100644
index 000000000000..53f713528866
--- /dev/null
+++ b/net-misc/oidc-agent/oidc-agent-4.2.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Agent and tools for managing OpenID Connect tokens on the command line"
+HOMEPAGE="https://github.com/indigo-dc/oidc-agent"
+SRC_URI="https://github.com/indigo-dc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="test"
+
+DEPEND="app-crypt/libsecret
+ dev-libs/libsodium:=
+ media-gfx/qrencode
+ net-libs/libmicrohttpd:=
+ sys-libs/libseccomp"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-libs/check )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.2_makefile-liblist-automagic.patch
+ "${FILESDIR}"/${PN}-4.1.0_install-perms.patch
+ "${FILESDIR}"/${PN}-4.2.2_makefile-toolchain-vars.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e 's|^\(\s\+\)@|\1|' Makefile || die "Failed to increase verbosity in Makefile"
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}" \
+ BIN_AFTER_INST_PATH="/usr" \
+ INCLUDE_PATH="${ED}"/usr/include \
+ LIB_PATH="${ED}"/usr/$(get_libdir) \
+ install
+
+ # This file is not compatible with Gentoo and in any case, we generally
+ # let the users load such agents themselves.
+ rm -f "${ED}"/etc/X11/Xsession.d/91${PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog
+ elog "You should use oidc-gen to initially generate your account configuration"
+ elog "before it can be loaded into oidc-agent using oidc-add. For details, please"
+ elog "consult the man page of oidc-gen, or full documentation at"
+ elog " https://indigo-dc.gitbooks.io/oidc-agent/"
+ elog
+ else
+ local new_major_ver old_ver
+ new_major_ver=$(ver_cut 1)
+ for old_ver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${old_ver}) != ${new_major_ver} ]]; then
+ ewarn
+ ewarn "You are upgrading from a different major version. Please restart any running instances of ${PN}"
+ ewarn "to make sure they are compatible with the updated clients."
+ ewarn
+ break
+ fi
+ done
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}