summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-01-30 12:50:48 +0000
committerYixun Lan <dlan@gentoo.org>2024-01-30 12:52:36 +0000
commita9c3a1138e8433399d5a8e33faac161af513f1e4 (patch)
tree8565093dd25bcb0c33503ce1a1e350e584cfb3c3 /net-misc/ofono
parentdev-python/pydantic: Bump to 2.6.0 (diff)
downloadgentoo-a9c3a1138e8433399d5a8e33faac161af513f1e4.tar.gz
gentoo-a9c3a1138e8433399d5a8e33faac161af513f1e4.tar.bz2
gentoo-a9c3a1138e8433399d5a8e33faac161af513f1e4.zip
net-misc/ofono: add 2.3
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-misc/ofono')
-rw-r--r--net-misc/ofono/Manifest1
-rw-r--r--net-misc/ofono/ofono-2.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/ofono/Manifest b/net-misc/ofono/Manifest
index 1e20cd5b72cf..b402a97bcd6f 100644
--- a/net-misc/ofono/Manifest
+++ b/net-misc/ofono/Manifest
@@ -2,3 +2,4 @@ DIST ofono-1.33.tar.xz 1060408 BLAKE2B 646a96c0926ea032fef0357aabe6a4be6da88f4cc
DIST ofono-1.34.tar.xz 1060828 BLAKE2B be0d3787ca9226763fb2bff46f1c3cec813d702730d6231986ec5aa43e2d96e08385fa3f64ccff97cf15844e41a33d6c37d1d35c8b0c5fcf3765848e258e3372 SHA512 79ebf0bc795288f07b58eeaa1a0aa3309b4afecae3abdd26c0749e22a4c2e74b65e93cbcfdfd1738dbcb2d0cfb8c687d182d706696a7c1cd5b4ed3bcec059489
DIST ofono-2.0.tar.xz 1096856 BLAKE2B 28b29577cdd70129fd8f7346bd82e03078452b03bb4baf152c4e406cfc17a5eeac11312999592acad85d7c61c4595403d266482068576573fd1d75a15e610d80 SHA512 3b29845d06784bfec8e60f6590237b77baa0826b1366f7ed8491d41622da19c72290ff8508a4625e5d7d5f68a03237524aa2ef1936b26dbc035fb3e7fa747f23
DIST ofono-2.1.tar.xz 1097624 BLAKE2B 574293a73061470eec322df7fa62d581e8e8d2c5b81e896bff52173a986733f448686186bc0400ccf256fb931e26a1fef6a664dafa8f64935f936c9347e4a054 SHA512 7227939c488c2a62f640d5a8279e0698935aa1df5a2a349e195df9a8d9d9123c73a7f1177aae022b4c805d266c24a9770784193100adffa45f6c36a3ed847bb1
+DIST ofono-2.3.tar.xz 1216872 BLAKE2B e32ea09dbc8f0aa2ca3f322ffc34d9f9d06d862792b05a0f96ddba4ebe4038199ab40a4065582d68a35d2a5725646626bc36c8f9e83d89a42be8d76271144751 SHA512 0c53c2c441d28f89140192fe808769b3b27ef1ebf75e9ee9f9bfa53d0d102a47d11fcb364077ca88cdc598e8368924f477024b44a2adf795efe40b52ffe92dce
diff --git a/net-misc/ofono/ofono-2.3.ebuild b/net-misc/ofono/ofono-2.3.ebuild
new file mode 100644
index 000000000000..10655da4f763
--- /dev/null
+++ b/net-misc/ofono/ofono-2.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="https://git.kernel.org/pub/scm/network/ofono/ofono.git"
+SRC_URI="https://mirrors.edge.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+atmodem bluetooth +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.6
+ >=dev-libs/glib-2.68
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable provision) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-provider-name \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}