summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-01-05 12:54:31 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-01-05 13:00:42 +0100
commit8bf14f5c7c237482d39c437c2449e1dae53a632b (patch)
tree2606fa409582ff1596f46ea7f0f7aa4a602736e3 /net-misc/nextcloud-client
parentdev-python/protobuf-python: Remove old (diff)
downloadgentoo-8bf14f5c7c237482d39c437c2449e1dae53a632b.tar.gz
gentoo-8bf14f5c7c237482d39c437c2449e1dae53a632b.tar.bz2
gentoo-8bf14f5c7c237482d39c437c2449e1dae53a632b.zip
net-misc/nextcloud-client: do not import legacy QtQuick.Dialogs module
Closes: https://bugs.gentoo.org/889772 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-misc/nextcloud-client')
-rw-r--r--net-misc/nextcloud-client/files/nextcloud-client-3.6.4-drop-dependency-on-Qt-Quick-Controls-1.patch59
-rw-r--r--net-misc/nextcloud-client/nextcloud-client-3.6.4-r2.ebuild (renamed from net-misc/nextcloud-client/nextcloud-client-3.6.4-r1.ebuild)13
2 files changed, 66 insertions, 6 deletions
diff --git a/net-misc/nextcloud-client/files/nextcloud-client-3.6.4-drop-dependency-on-Qt-Quick-Controls-1.patch b/net-misc/nextcloud-client/files/nextcloud-client-3.6.4-drop-dependency-on-Qt-Quick-Controls-1.patch
new file mode 100644
index 000000000000..e1bb0a11e13f
--- /dev/null
+++ b/net-misc/nextcloud-client/files/nextcloud-client-3.6.4-drop-dependency-on-Qt-Quick-Controls-1.patch
@@ -0,0 +1,59 @@
+From 600ad8f6003daee635093ad713f3f90cb7cc7485 Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@geekplace.eu>
+Date: Thu, 5 Jan 2023 11:58:08 +0100
+Subject: [PATCH] Drop dependency on Qt Quick Controls 1
+
+Qt Quick Controls 1 where deprecated with Qt 5.11 [1]. Nextcloud still
+depends on Quick Controls 1 by importing QtQuick.Dialogs. Removing
+those imports will cause the QMl script to use the according API from
+Quick Controls 2, which are, fortunately largely API-comptible.
+
+This helps distribution to deprecate and remove Quick Controls 1 [2].
+
+1: https://doc.qt.io/qt-6/qtquickcontrols-changes-qt6.html#migrating-from-qt-quick-controls-1
+2: https://bugs.gentoo.org/889772
+
+Signed-off-by: Florian Schmaus <flo@geekplace.eu>
+--- a/src/gui/BasicComboBox.qml
++++ b/src/gui/BasicComboBox.qml
+@@ -13,7 +13,6 @@
+ */
+
+ import QtQuick 2.15
+-import QtQuick.Dialogs 1.3
+ import QtQuick.Layouts 1.15
+ import QtQuick.Controls 2.15
+ import QtGraphicalEffects 1.0
+--- a/src/gui/PredefinedStatusButton.qml
++++ b/src/gui/PredefinedStatusButton.qml
+@@ -13,7 +13,6 @@
+ */
+
+ import QtQuick 2.15
+-import QtQuick.Dialogs 1.3
+ import QtQuick.Layouts 1.15
+ import QtQuick.Controls 2.15
+
+--- a/src/gui/UserStatusSelector.qml
++++ b/src/gui/UserStatusSelector.qml
+@@ -13,7 +13,6 @@
+ */
+
+ import QtQuick 2.6
+-import QtQuick.Dialogs 1.3
+ import QtQuick.Layouts 1.15
+ import QtQuick.Controls 2.15
+ import QtQuick.Window 2.15
+--- a/src/gui/UserStatusSelectorButton.qml
++++ b/src/gui/UserStatusSelectorButton.qml
+@@ -13,7 +13,6 @@
+ */
+
+ import QtQuick 2.6
+-import QtQuick.Dialogs 1.3
+ import QtQuick.Layouts 1.15
+ import QtQuick.Controls 2.15
+
+--
+2.38.2
+
diff --git a/net-misc/nextcloud-client/nextcloud-client-3.6.4-r1.ebuild b/net-misc/nextcloud-client/nextcloud-client-3.6.4-r2.ebuild
index e2dbf57830dc..ab1e5c884f28 100644
--- a/net-misc/nextcloud-client/nextcloud-client-3.6.4-r1.ebuild
+++ b/net-misc/nextcloud-client/nextcloud-client-3.6.4-r2.ebuild
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc dolphin nautilus test webengine"
RESTRICT="!test? ( test )"
-COMMON_DEPEND="
+RDEPEND="
>=dev-db/sqlite-3.34:3
>=dev-libs/openssl-1.1.0:0=
dev-libs/qtkeychain:=[qt5(+)]
@@ -38,12 +38,8 @@ COMMON_DEPEND="
nautilus? ( dev-python/nautilus-python )
webengine? ( dev-qt/qtwebengine:5[widgets] )
"
-RDEPEND="
- ${COMMON_DEPEND}
- dev-qt/qtquickcontrols2:5
-"
DEPEND="
- ${COMMON_DEPEND}
+ ${R_DEPEND}
dev-qt/qtconcurrent:5
dev-qt/qtxml:5
|| ( gnome-base/librsvg media-gfx/inkscape )
@@ -63,6 +59,11 @@ BDEPEND="
dolphin? ( kde-frameworks/extra-cmake-modules )
"
+PATCHES=(
+ # https://github.com/nextcloud/desktop/pull/5309
+ "${FILESDIR}"/${PN}-3.6.4-drop-dependency-on-Qt-Quick-Controls-1.patch
+)
+
src_prepare() {
# Keep tests in ${T}
sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die