summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/igmpproxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/igmpproxy')
-rw-r--r--net-misc/igmpproxy/Manifest1
-rw-r--r--net-misc/igmpproxy/files/igmpproxy-conf.d6
-rw-r--r--net-misc/igmpproxy/files/igmpproxy-init.d25
-rw-r--r--net-misc/igmpproxy/files/igmpproxy.service9
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.1-r1.ebuild25
-rw-r--r--net-misc/igmpproxy/metadata.xml14
6 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/Manifest b/net-misc/igmpproxy/Manifest
new file mode 100644
index 000000000000..71829c4c8b6b
--- /dev/null
+++ b/net-misc/igmpproxy/Manifest
@@ -0,0 +1 @@
+DIST igmpproxy-0.1.tar.gz 140159 SHA256 ee18ff3d8c3ae3a29dccb7e5eedf332337330020168bd95a11cece8d7d7ee6ae SHA512 1a569814d8984610402313d8c4adb78ff362f82ae28c968a8ba0fb411e12a704d1b51b387111b51517ab8fb2e86952bbd196f27eccd311c11ce288fc6fa25ad4 WHIRLPOOL b7e446c4c3a9c318d65cc51a54df4900ea334c521e8a8adfa487dc48c80ea81f4d17097b4bbd52eee9d7d76c5d45aca74d194ed31e002837b308e2bbcd95dea4
diff --git a/net-misc/igmpproxy/files/igmpproxy-conf.d b/net-misc/igmpproxy/files/igmpproxy-conf.d
new file mode 100644
index 000000000000..a7a2b348d2a5
--- /dev/null
+++ b/net-misc/igmpproxy/files/igmpproxy-conf.d
@@ -0,0 +1,6 @@
+# Specify a configuration file
+IGMPPROXY_CONFIG="/etc/igmpproxy.conf"
+
+# Additional command line options.
+# See igmpproxy(8) for more information.
+IGMPPROXY_OPTS=""
diff --git a/net-misc/igmpproxy/files/igmpproxy-init.d b/net-misc/igmpproxy/files/igmpproxy-init.d
new file mode 100644
index 000000000000..0b138c3b5c41
--- /dev/null
+++ b/net-misc/igmpproxy/files/igmpproxy-init.d
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ ebegin "Starting IGMPproxy"
+ start-stop-daemon --start --background \
+ --make-pidfile --pidfile /var/run/igmpproxy.pid \
+ --exec /usr/sbin/igmpproxy -- \
+ ${IGMPPROXY_OPTS} "${IGMPPROXY_CONFIG:-/etc/igmpproxy.conf}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping IGMPproxy"
+ start-stop-daemon --stop --pidfile /var/run/igmpproxy.pid
+ eend $?
+}
+
diff --git a/net-misc/igmpproxy/files/igmpproxy.service b/net-misc/igmpproxy/files/igmpproxy.service
new file mode 100644
index 000000000000..a682bed09e0a
--- /dev/null
+++ b/net-misc/igmpproxy/files/igmpproxy.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=IGMP proxy
+After=network.target
+
+[Service]
+ExecStart=/usr/sbin/igmpproxy /etc/igmpproxy.conf
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/igmpproxy/igmpproxy-0.1-r1.ebuild b/net-misc/igmpproxy/igmpproxy-0.1-r1.ebuild
new file mode 100644
index 000000000000..508ca613cc52
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit linux-info systemd
+
+DESCRIPTION="Multicast Routing Daemon using only IGMP signalling (Internet Group Management Protocol)"
+HOMEPAGE="http://sourceforge.net/projects/igmpproxy"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 Stanford"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}/${PN}-init.d" ${PN}
+ newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}
diff --git a/net-misc/igmpproxy/metadata.xml b/net-misc/igmpproxy/metadata.xml
new file mode 100644
index 000000000000..a05381eb1e7f
--- /dev/null
+++ b/net-misc/igmpproxy/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ IGMPproxy is a simple dynamic Multicast Routing Daemon using only IGMP signalling.
+ It's intended for simple forwarding of Multicast traffic between networks.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">igmpproxy</remote-id>
+ </upstream>
+</pkgmetadata>