summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-13 21:12:53 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-13 22:55:03 +0200
commitf0b21f32d0517d81adb55f6627089713d4bc3a00 (patch)
treeb28ef85928b503978b4e0bd802674eecafae6ff6 /net-misc/ices
parentmedia-sound/timidity++: drop old version (diff)
downloadgentoo-f0b21f32d0517d81adb55f6627089713d4bc3a00.tar.gz
gentoo-f0b21f32d0517d81adb55f6627089713d4bc3a00.tar.bz2
gentoo-f0b21f32d0517d81adb55f6627089713d4bc3a00.zip
net-misc/ices: migrate to GLEP 81
Bug: https://bugs.gentoo.org/781419 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/ices')
-rw-r--r--net-misc/ices/ices-2.0.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/ices/ices-2.0.2-r1.ebuild b/net-misc/ices/ices-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..001620dd1b72
--- /dev/null
+++ b/net-misc/ices/ices-2.0.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Icecast OGG streaming client, supports on the fly re-encoding"
+HOMEPAGE="https://icecast.org/ices/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ppc64 sparc x86"
+
+RDEPEND="
+ acct-group/ices
+ acct-user/ices
+ dev-libs/libxml2
+ >=media-libs/libshout-2
+ >=media-libs/libvorbis-1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf --sysconfdir=/etc/ices2
+}
+
+src_install() {
+ default
+ insinto /etc/ices2
+ doins conf/*.xml
+ docinto html
+ dodoc doc/*.{html,css}
+ newinitd "${FILESDIR}"/ices.initd-r1 ices
+ keepdir /var/log/ices
+ fperms 660 /var/log/ices
+ fowners ices:ices /var/log/ices
+ rm -rf "${D}"/usr/share/ices
+}