summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-10 22:16:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-10 22:17:58 +0300
commit79890df2626dc05446998145113ae12c5ef0d43a (patch)
treec5d6704fb5a84ccefa108f7129391a9e34f0dac3 /net-misc/babeld
parentsys-kernel/gentoo-kernel-bin: Bump to 6.6.26 (diff)
downloadgentoo-79890df2626dc05446998145113ae12c5ef0d43a.tar.gz
gentoo-79890df2626dc05446998145113ae12c5ef0d43a.tar.bz2
gentoo-79890df2626dc05446998145113ae12c5ef0d43a.zip
net-misc/babeld: add 1.13.1
Bug: https://bugs.gentoo.org/913496 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-misc/babeld')
-rw-r--r--net-misc/babeld/Manifest3
-rw-r--r--net-misc/babeld/babeld-1.13.1.ebuild40
2 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/babeld/Manifest b/net-misc/babeld/Manifest
index 22dd4987aa40..25aea5342b23 100644
--- a/net-misc/babeld/Manifest
+++ b/net-misc/babeld/Manifest
@@ -1 +1,4 @@
+DIST babeld-1.13.1.tar.gz 94890 BLAKE2B 78a58ca9b8c4d915e742081d90e210a14c1718c882d56a42926f29d1c99c53ea06ac8bc2c88f11e0af47a2f657d7649b41ccfcec79e4195c542cf5953e7c6d39 SHA512 c1733fbe115c1e07cc2455b1e0a5f61a53d50b1f2e81f24a82b04c988f1d8c6076e215005aae7e4e97f2497965d8459d0ac024fce016a22d8b416929a8569b13
DIST babeld-1.9.1.tar.gz 94668 BLAKE2B 169932e8d37d683bfa7e945e313d17c3ee633d11031d940ef3f5be3e0a9fbaffb28d47cf9f6d6ef6b25130af9a485ac4a629d0009485021d6f2fe19ec5382788 SHA512 433a9a2da02c56e93f5fc5f9399320f7f4dbac8d87eff9a539300d5740269eeda6be1302a2cf4a4b9c524780b286d9eb7898585fc530129a1f84341faf1e6fd0
+DIST babeld-BLAKE2-320c325437539ae91091ce62efec1913cd8093c2.tar.gz 895554 BLAKE2B eecc9cfebba1a9b0ccf64f2aab9bab4db96987cd3d75cffa40e7ba3bb6014f056c00fb6f5dc50477f38e4264625dd1702f2994e93dc8c3f8c1ba933d7e397188 SHA512 db668b6fad82c82a9431db0bad5982d9ba7ea3aeb3ede0a5335702a44fd19d23f2b89207940c060dba992009e1de7d8d892f6719cd8ffdeaed26303bdc7a7a6f
+DIST babeld-rfc6234-285c8b86c0c6b8e9ffe1c420c5b09fa229629a30.tar.gz 93167 BLAKE2B 64d6a43ca3e1bac434d21a2df5c8449cd3b8eef821ef7af731a4242fc14131b284ad72c11062cd9b5c1f03bff37578931f464165f288589a8a22911b6b4fcd71 SHA512 0adb4a891042fde32451368b93f861015614858e8fe42bb9b7b377e9cbb0b06fa3903dd9e901f93b7b12fd2428df621208295cd0a11ff55fbc6382e15aff8079
diff --git a/net-misc/babeld/babeld-1.13.1.ebuild b/net-misc/babeld/babeld-1.13.1.ebuild
new file mode 100644
index 000000000000..c4d5c377a8e8
--- /dev/null
+++ b/net-misc/babeld/babeld-1.13.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+BLAKE2_COMMIT=320c325437539ae91091ce62efec1913cd8093c2
+RFC6234_COMMIT=285c8b86c0c6b8e9ffe1c420c5b09fa229629a30
+
+DESCRIPTION="a loop-free distance-vector routing protocol"
+HOMEPAGE="https://github.com/jech/babeld"
+SRC_URI="
+ https://github.com/jech/babeld/archive/${P}.tar.gz
+ https://github.com/BLAKE2/BLAKE2/archive/${BLAKE2_COMMIT}.tar.gz
+ -> ${PN}-BLAKE2-${BLAKE2_COMMIT}.tar.gz
+ https://github.com/massar/rfc6234/archive/${RFC6234_COMMIT}.tar.gz
+ -> ${PN}-rfc6234-${RFC6234_COMMIT}.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ default
+ cd "${S}"
+ rm -r BLAKE2 rfc6234 || die
+ ln -s ../BLAKE2-${BLAKE2_COMMIT} BLAKE2 || die
+ ln -s ../rfc6234-${RFC6234_COMMIT} rfc6234 || die
+}
+
+src_compile() {
+ emake CDEBUGFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake TARGET="${ED}" PREFIX="/usr" install
+ dodoc CHANGES README
+ doinitd "${FILESDIR}"/${PN}
+}