summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-11-13 09:03:17 +0000
committerSam James <sam@gentoo.org>2021-11-13 11:07:42 +0000
commit5ff93eeb72a1764152276aef557671d912620fae (patch)
tree0e411e48820a55b093a4db2a7f6531ffcbe46a88 /net-mail
parentdev-util/btyacc: update patch, remove static linking (diff)
downloadgentoo-5ff93eeb72a1764152276aef557671d912620fae.tar.gz
gentoo-5ff93eeb72a1764152276aef557671d912620fae.tar.bz2
gentoo-5ff93eeb72a1764152276aef557671d912620fae.zip
net-mail/mu: Bump to 1.6.10
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/22927 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/mu-1.6.10.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index eaa030a32091..1c0c20f747df 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,3 +1,4 @@
+DIST mu-1.6.10.tar.xz 867008 BLAKE2B 6cce22f18691c3ad6dda1ec012d72c398df2ba4d1beca70fc6f88d87aa9b749e2aa4c03f5c0e0d70f4f9978e2beb60ea02642b8ff71e86e0668df726e5923b52 SHA512 a51847b338afeff9c9fa88c4698df4b85289d017063cb5e3410eb967c605d8779618dcbd988e2d923a92291c1e0738ec84afecf017c76a63776149619d134887
DIST mu-1.6.6.tar.xz 866724 BLAKE2B 3417d4b3e5bfae943558fbc936ca0207be912f9548621b1599437484e94f3b49271aa1e97e7cc2b5b6027b8e0cf97d3b96d2052772f7783d897b4fa0dcf03184 SHA512 07daf9864bfd1ff4278aee98a0ae9c4fc3be94468e3b2022ae801f048f339b5becdb9ad8ebb2e12b9131e0e6dfcfb541bdca8288657dc19d47b0e510831f54eb
DIST mu-1.6.7.tar.xz 867136 BLAKE2B 12b19d15c01a7101e3a936b12ee87fa5519c0e047e354f2fd1d481939dd5dffa34a94a5e7f3fda20e27771377e78524065cf5f93f7a2f818e202cdc93090ebff SHA512 ceae7b4508fc607dcda0fc20e9fb92b3533b1ba7ef94823cba2cd3a6ad3f18ccd3d2ea7da20e4c190e53f2d00ccdd3e1d25e12b89a08bf5233f5656be90b3c14
DIST mu-1.6.9.tar.xz 867188 BLAKE2B 526f67acd505a1d02cc12841d7d5f99e4b91a8aa3923cc1bccf045faf3a89bef99827c7461e78d000aefa48634a38fcf263346c14f275e3053c9774e2f8219c9 SHA512 c0ba5fc984fa445c44f89b84f911952c4a3aebf9484c60df75bd6a144cad3e68e1b2de98d8bbf5faae51d81ed99adb85280e4c1a40e7b0d587a00e0d80937495
diff --git a/net-mail/mu/mu-1.6.10.ebuild b/net-mail/mu/mu-1.6.10.ebuild
new file mode 100644
index 000000000000..10dba93b30d6
--- /dev/null
+++ b/net-mail/mu/mu-1.6.10.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="https://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/releases/download/${PV}/mu-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="emacs guile readline"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gmime:3.0
+ >=dev-libs/xapian-1.4:=
+ emacs? ( >=app-editors/emacs-25.3:* )
+ guile? ( >=dev-scheme/guile-2.2:* )
+ readline? ( sys-libs/readline:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo-autoload.el"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable emacs mu4e)
+ $(use_enable guile)
+ $(use_enable readline)
+ --disable-gtk
+ --disable-webkit
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_preinst() {
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "After upgrading from an old major version, you should"
+ elog "rebuild your mail index."
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "https://www.djcbsoftware.nl/code/mu/mu4e/"
+
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}