summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 07:48:32 +0000
committerSam James <sam@gentoo.org>2023-02-17 08:11:56 +0000
commit55fe28a25e0a3a00df562984cd461114023e29e0 (patch)
tree5bbf82bcc7456a2ec8c95cdbb6a17e71529ee80a /net-mail
parentnet-im/mattermost-desktop-bin: add 5.3.0_rc1 (diff)
downloadgentoo-55fe28a25e0a3a00df562984cd461114023e29e0.tar.gz
gentoo-55fe28a25e0a3a00df562984cd461114023e29e0.tar.bz2
gentoo-55fe28a25e0a3a00df562984cd461114023e29e0.zip
net-mail/automx2: use eunittest
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/automx2/automx2-2022.0.ebuild4
-rw-r--r--net-mail/automx2/automx2-2022.1.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-mail/automx2/automx2-2022.0.ebuild b/net-mail/automx2/automx2-2022.0.ebuild
index fa5d5d4da29b..99981f324453 100644
--- a/net-mail/automx2/automx2-2022.0.ebuild
+++ b/net-mail/automx2/automx2-2022.0.ebuild
@@ -30,8 +30,8 @@ python_prepare_all() {
}
python_test() {
- export AUTOMX2_CONF="tests/unittest.conf"
- ${EPYTHON} -m unittest discover tests/ || die "Tests failed with ${EPYTHON}"
+ local -x AUTOMX2_CONF="tests/unittest.conf"
+ eunittest tests/
}
python_install_all() {
diff --git a/net-mail/automx2/automx2-2022.1.ebuild b/net-mail/automx2/automx2-2022.1.ebuild
index 7cd6766fdd89..0251dd9052a9 100644
--- a/net-mail/automx2/automx2-2022.1.ebuild
+++ b/net-mail/automx2/automx2-2022.1.ebuild
@@ -31,8 +31,8 @@ python_prepare_all() {
}
python_test() {
- export AUTOMX2_CONF="tests/unittest.conf"
- ${EPYTHON} -m unittest discover tests/ || die "Tests failed with ${EPYTHON}"
+ local -x AUTOMX2_CONF="tests/unittest.conf"
+ eunittest tests/
}
python_install_all() {