summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-04-24 07:38:04 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-04-24 07:50:57 -0400
commit519711be122585cb9b990eebddf97781c318cd86 (patch)
treeb8dd86fc9a2abbdae79ddcc59bedfd80545d0e0f /net-mail
parentprofiles: Unmask dev-python/pypy-exe-bin on ppc64le (diff)
downloadgentoo-519711be122585cb9b990eebddf97781c318cd86.tar.gz
gentoo-519711be122585cb9b990eebddf97781c318cd86.tar.bz2
gentoo-519711be122585cb9b990eebddf97781c318cd86.zip
net-mail/list-remote-forwards: add 0.0.4, fix deps
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/list-remote-forwards/Manifest1
-rw-r--r--net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/list-remote-forwards/Manifest b/net-mail/list-remote-forwards/Manifest
index 8070a53751a5..e897585db06b 100644
--- a/net-mail/list-remote-forwards/Manifest
+++ b/net-mail/list-remote-forwards/Manifest
@@ -1 +1,2 @@
DIST list-remote-forwards-0.0.3.tar.gz 26495 BLAKE2B 7bc0a02133dfabe0f27c7ed861bbb994757eadb4d55d369fdd143da7ef03fcadf7d1f11bb034fc8ade7dc879d4b615a3ae5ed44a1ed5af3e10f1aaffcd79210a SHA512 833bb0a3fda76b43d0004d7906c54aa21920f1db8ff50fc2c0d1da6f98dd49310041fa7101050108cb6cb803084fff0673316a1ce86224d35ba09e8060864a9d
+DIST list-remote-forwards-0.0.4.tar.gz 26653 BLAKE2B 743b35456698473184ef5c4ac9184b71e7cee821ab75df2267b3d60df67050231dc98b63dacb4fe4620d018524f3d739ecf026a31752494457b8dcc4a1656b67 SHA512 8df7e252ee186fa8569efe2e92fdc2e7db7b6044f9a7be97c42c152381129e9591d1ace91da8e5fcd2a70dda4976bae6c129d457641ee43bf3efaa5bcb8168dc
diff --git a/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild b/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild
new file mode 100644
index 000000000000..ac047250e4b3
--- /dev/null
+++ b/net-mail/list-remote-forwards/list-remote-forwards-0.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="List all remote forwards for mail accounts stored in a database"
+HOMEPAGE="https://michael.orlitzky.com/code/list-remote-forwards.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+# dev-haskell/dns and dev-haskell/resolv conflict
+# https://github.com/sol/doctest/issues/119
+RESTRICT=test
+
+RDEPEND=">=dev-haskell/cmdargs-0.10
+ >=dev-haskell/configurator-0.2
+ >=dev-haskell/dns-1.4
+ >=dev-haskell/hdbc-2.4
+ >=dev-haskell/hdbc-postgresql-2.3
+ >=dev-haskell/hdbc-sqlite3-2.3
+ >=dev-haskell/missingh-1.2
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-lang/ghc-9.0.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )
+"
+
+src_install() {
+ haskell-cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}