summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/dbmail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/dbmail')
-rw-r--r--net-mail/dbmail/Manifest2
-rw-r--r--net-mail/dbmail/dbmail-3.2.2.ebuild141
-rw-r--r--net-mail/dbmail/dbmail-3.2.3.ebuild141
-rw-r--r--net-mail/dbmail/files/dbmail-imapd.initd68
-rw-r--r--net-mail/dbmail/files/dbmail-lmtpd.initd68
-rw-r--r--net-mail/dbmail/files/dbmail-pop3d.initd68
-rw-r--r--net-mail/dbmail/files/dbmail-timsieved.initd68
-rw-r--r--net-mail/dbmail/metadata.xml13
8 files changed, 569 insertions, 0 deletions
diff --git a/net-mail/dbmail/Manifest b/net-mail/dbmail/Manifest
new file mode 100644
index 000000000000..76336fed07b6
--- /dev/null
+++ b/net-mail/dbmail/Manifest
@@ -0,0 +1,2 @@
+DIST dbmail-3.2.2.tar.gz 2444241 SHA256 77d2fcf343cc1312fca565a9eeef3927b257b55910be2b198562516334a2c62a SHA512 a2125ea3b9d0ec387135d87854510f36ef0fe87b70f33d54f8af89f22a83802e5838979ba94d6ba66ef986f6f67b08aa6d5e2bfc2f1f2bc44edf03a9f51afb37 WHIRLPOOL 8fa60754e55b56e293a187cd10922586e1c38c0079e8f6eb98b8aaba503705046cf7b6954f677bb295ea799f9261ef62c8589433657a0ad2775dd2cfa1d1ee15
+DIST dbmail-3.2.3.tar.gz 2444227 SHA256 fd4d90e3e5ddb0c3fbdaa766d19d2464b5027a8c8d0b0df614418a3aac811832 SHA512 29cc89830278f2ff28a4221fc81d4ff13cc371fbca7fb51d5376e9243234220b552cb4b6ec035c150e6cfa178435c4f36b9ce132fc02334bc6cdeb1a41c8ed85 WHIRLPOOL 05284ae622078584e35583ba5a6b340d9500c46dcf820b851810a2bbf6ac39ee57080d9e23ee82c6b64af3f76de6ef6eb0ec925a9615d4a4dc2e19e5f06e9a5d
diff --git a/net-mail/dbmail/dbmail-3.2.2.ebuild b/net-mail/dbmail/dbmail-3.2.2.ebuild
new file mode 100644
index 000000000000..0865f451ba4a
--- /dev/null
+++ b/net-mail/dbmail/dbmail-3.2.2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils multilib versionator user
+
+DESCRIPTION="DBMail is an open-source project that enables storage of mail messages in a relational database"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ldap sieve +sqlite ssl static"
+
+DEPEND="dev-db/libzdb
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ app-text/asciidoc
+ app-text/xmlto
+ app-crypt/mhash
+ sys-libs/zlib
+ dev-libs/gmime:2.6
+ >=dev-libs/glib-2.16
+ dev-libs/libevent
+ ssl? ( dev-libs/openssl )"
+#asciidoc and xmlto needed?
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_configure() {
+ local myconf=""
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ $(use_enable static) \
+ $(use_with sieve) \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS ChangeLog README* INSTALL NEWS THANKS UPGRADING
+
+ docompress -x /usr/share/doc/${PF}/sql
+ dodoc -r sql
+ dodoc -r test-scripts
+ dodoc -r contrib
+ ## TODO: install other contrib stuff
+
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ sed -i -e "s:/var/run:/var/run/dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ # change config path to our default and use the conf.d and init.d files from the contrib dir
+ sed -i -e "s:/etc/dbmail.conf:/etc/dbmail/dbmail.conf:" contrib/startup-scripts/gentoo/init.d-dbmail
+ #sed -i -e "s:exit 0:return 1:" contrib/startup-scripts/gentoo/init.d-dbmail
+ #sed -i -e "s:/var/run:/var/run/dbmail:" contrib/startup-scripts/gentoo/init.d-dbmail
+ #newconfd contrib/startup-scripts/gentoo/conf.d-dbmail dbmail
+ #newinitd contrib/startup-scripts/gentoo/init.d-dbmail dbmail
+ # use custom init scripts until updated in upstream contrib
+ newinitd "${FILESDIR}/dbmail-imapd.initd" dbmail-imapd
+ newinitd "${FILESDIR}/dbmail-lmtpd.initd" dbmail-lmtpd
+ newinitd "${FILESDIR}/dbmail-pop3d.initd" dbmail-pop3d
+ newinitd "${FILESDIR}/dbmail-timsieved.initd" dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+ #doman man/*.{1,5,8}
+
+ # ldap schema
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${S}/dbmail.schema"
+ fi
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+ fowners dbmail:dbmail /var/lib/dbmail
+ # create this through init-scripts instead of at installt ime (bug #455002)
+ #keepdir /var/run/dbmail
+ #fowners dbmail:dbmail /var/run/dbmail
+}
+
+pkg_postinst() {
+ elog "Please read the INSTALL file in /usr/share/doc/${PF}/"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "DBMail requires either SQLite, PostgreSQL or MySQL."
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+ echo
+ elog "We are now using the init script from upstream."
+ elog "Please edit /etc/conf.d/dbmail to set which services to start"
+ elog "and delete /etc/init.d/dbmail-* when you are done. (don't"
+ elog "forget to rc-update del dbmail-* first)"
+ echo
+ elog "Changed pid directory to /var/run/dbmail (see"
+ elog "http://www.dbmail.org/mantis/view.php?id=949 for details)"
+ echo
+ ewarn "The database config has changed to support libzdb db URI"
+ ewarn "Please check the documentation (or Bug #479664)"
+ echo
+ ewarn "The database schema has changed since 3.0.x make sure"
+ ewarn "to run the migration script"
+ echo
+ ewarn "Please be aware, that the single init-script for all services"
+ ewarn "has been replaced with seperate init scripts for the individual services."
+ ewarn "Make sure to add dbmail-(imapd|lmtpd|pop3d|timsieved) using rc-update"
+ ewarn "and remove dbmail if you want to take advantage of this change."
+ echo
+}
diff --git a/net-mail/dbmail/dbmail-3.2.3.ebuild b/net-mail/dbmail/dbmail-3.2.3.ebuild
new file mode 100644
index 000000000000..4ca2a2804896
--- /dev/null
+++ b/net-mail/dbmail/dbmail-3.2.3.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils multilib versionator user
+
+DESCRIPTION="DBMail is an open-source project that enables storage of mail messages in a relational database"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap sieve +sqlite ssl static"
+
+DEPEND="dev-db/libzdb
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ app-text/asciidoc
+ app-text/xmlto
+ app-crypt/mhash
+ sys-libs/zlib
+ dev-libs/gmime:2.6
+ >=dev-libs/glib-2.16
+ dev-libs/libevent
+ ssl? ( dev-libs/openssl )"
+#asciidoc and xmlto needed?
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_configure() {
+ local myconf=""
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ $(use_enable static) \
+ $(use_with sieve) \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS ChangeLog README* INSTALL NEWS THANKS UPGRADING
+
+ docompress -x /usr/share/doc/${PF}/sql
+ dodoc -r sql
+ dodoc -r test-scripts
+ dodoc -r contrib
+ ## TODO: install other contrib stuff
+
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ sed -i -e "s:/var/run:/var/run/dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ # change config path to our default and use the conf.d and init.d files from the contrib dir
+ sed -i -e "s:/etc/dbmail.conf:/etc/dbmail/dbmail.conf:" contrib/startup-scripts/gentoo/init.d-dbmail
+ #sed -i -e "s:exit 0:return 1:" contrib/startup-scripts/gentoo/init.d-dbmail
+ #sed -i -e "s:/var/run:/var/run/dbmail:" contrib/startup-scripts/gentoo/init.d-dbmail
+ #newconfd contrib/startup-scripts/gentoo/conf.d-dbmail dbmail
+ #newinitd contrib/startup-scripts/gentoo/init.d-dbmail dbmail
+ # use custom init scripts until updated in upstream contrib
+ newinitd "${FILESDIR}/dbmail-imapd.initd" dbmail-imapd
+ newinitd "${FILESDIR}/dbmail-lmtpd.initd" dbmail-lmtpd
+ newinitd "${FILESDIR}/dbmail-pop3d.initd" dbmail-pop3d
+ newinitd "${FILESDIR}/dbmail-timsieved.initd" dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+ #doman man/*.{1,5,8}
+
+ # ldap schema
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${S}/dbmail.schema"
+ fi
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+ fowners dbmail:dbmail /var/lib/dbmail
+ # create this through init-scripts instead of at installt ime (bug #455002)
+ #keepdir /var/run/dbmail
+ #fowners dbmail:dbmail /var/run/dbmail
+}
+
+pkg_postinst() {
+ elog "Please read the INSTALL file in /usr/share/doc/${PF}/"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "DBMail requires either SQLite, PostgreSQL or MySQL."
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+ echo
+ elog "We are now using the init script from upstream."
+ elog "Please edit /etc/conf.d/dbmail to set which services to start"
+ elog "and delete /etc/init.d/dbmail-* when you are done. (don't"
+ elog "forget to rc-update del dbmail-* first)"
+ echo
+ elog "Changed pid directory to /var/run/dbmail (see"
+ elog "http://www.dbmail.org/mantis/view.php?id=949 for details)"
+ echo
+ ewarn "The database config has changed to support libzdb db URI"
+ ewarn "Please check the documentation (or Bug #479664)"
+ echo
+ ewarn "The database schema has changed since 3.0.x make sure"
+ ewarn "to run the migration script"
+ echo
+ ewarn "Please be aware, that the single init-script for all services"
+ ewarn "has been replaced with seperate init scripts for the individual services."
+ ewarn "Make sure to add dbmail-(imapd|lmtpd|pop3d|timsieved) using rc-update"
+ ewarn "and remove dbmail if you want to take advantage of this change."
+ echo
+}
diff --git a/net-mail/dbmail/files/dbmail-imapd.initd b/net-mail/dbmail/files/dbmail-imapd.initd
new file mode 100644
index 000000000000..d0ede5aba2f2
--- /dev/null
+++ b/net-mail/dbmail/files/dbmail-imapd.initd
@@ -0,0 +1,68 @@
+#!/sbin/runscript
+#
+# chkconfig: - 91 35
+# description: Starts and stops dbmail-impad
+#
+
+
+PROGRAM=dbmail-imapd
+
+BIN_DIR=/usr/sbin
+PID_DIR=/var/run/dbmail
+PID=pid
+
+# Where is the dbmail.conf file located?
+CONFIG=/etc/dbmail/dbmail.conf
+
+## not in 3.1.x yet
+#extra_started_commands="reload"
+
+depend() {
+ need net
+ # This won't cause a hard failure if neither is installed, however.
+ use mysql
+ use pgsql
+ after mta
+}
+
+initService() {
+ # Avoid using root's TMPDIR
+ unset TMPDIR
+
+ # Check that config file exists.
+ if [ ! -e $CONFIG ]; then
+ eerror "Config file not found ($CONFIG)"
+ eerror "An example config can be found in /etc/dbmail/dbmail.conf.dist"
+ return 1
+ fi
+
+ checkpath -d $PID_DIR -m 750 -o dbmail:dbmail
+
+ RETVAL=0
+}
+
+start() {
+ initService
+ ebegin "Starting DBMail IMAP daemon ($PROGRAM)"
+ start-stop-daemon --start --quiet \
+ --pidfile $PID_DIR/$PROGRAM.$PID \
+ --exec $BIN_DIR/$PROGRAM \
+ --name $PROGRAM \
+ -- -f $CONFIG -p $PID_DIR/$PROGRAM.$PID 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping DBMail IMAP daemon ($PROGRAM)"
+ start-stop-daemon --stop --quiet --retry 15 \
+ --pidfile $PID_DIR/$PROGRAM.$PID
+ eend $?
+}
+
+## not in 3.1.x yet
+#reload() {#
+# ebegin "Reloading DBMail IMAP daemon ($PROGRAM)"
+# start-stop-daemon --quiet --signal HUP \
+# --pidfile $PID_DIR/$PROGRAM.$PID
+# eend $?
+#}
diff --git a/net-mail/dbmail/files/dbmail-lmtpd.initd b/net-mail/dbmail/files/dbmail-lmtpd.initd
new file mode 100644
index 000000000000..0495ba722d22
--- /dev/null
+++ b/net-mail/dbmail/files/dbmail-lmtpd.initd
@@ -0,0 +1,68 @@
+#!/sbin/runscript
+#
+# chkconfig: - 91 35
+# description: Starts and stops dbmail-lmtpd
+#
+
+
+PROGRAM=dbmail-lmtpd
+
+BIN_DIR=/usr/sbin
+PID_DIR=/var/run/dbmail
+PID=pid
+
+# Where is the dbmail.conf file located?
+CONFIG=/etc/dbmail/dbmail.conf
+
+## not in 3.1.x yet
+#extra_started_commands="reload"
+
+depend() {
+ need net
+ # This won't cause a hard failure if neither is installed, however.
+ use mysql
+ use pgsql
+ after mta
+}
+
+initService() {
+ # Avoid using root's TMPDIR
+ unset TMPDIR
+
+ # Check that config file exists.
+ if [ ! -e $CONFIG ]; then
+ eerror "Config file not found ($CONFIG)"
+ eerror "An example config can be found in /etc/dbmail/dbmail.conf.dist"
+ return 1
+ fi
+
+ checkpath -d $PID_DIR -m 750 -o dbmail:dbmail
+
+ RETVAL=0
+}
+
+start() {
+ initService
+ ebegin "Starting DBMail LMTP daemon ($PROGRAM)"
+ start-stop-daemon --start --quiet \
+ --pidfile $PID_DIR/$PROGRAM.$PID \
+ --exec $BIN_DIR/$PROGRAM \
+ --name $PROGRAM \
+ -- -f $CONFIG -p $PID_DIR/$PROGRAM.$PID 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping DBMail LMTP daemon ($PROGRAM)"
+ start-stop-daemon --stop --quiet --retry 15 \
+ --pidfile $PID_DIR/$PROGRAM.$PID
+ eend $?
+}
+
+## not in 3.1.x yet
+#reload() {#
+# ebegin "Reloading DBMail LMTP daemon ($PROGRAM)"
+# start-stop-daemon --quiet --signal HUP \
+# --pidfile $PID_DIR/$PROGRAM.$PID
+# eend $?
+#}
diff --git a/net-mail/dbmail/files/dbmail-pop3d.initd b/net-mail/dbmail/files/dbmail-pop3d.initd
new file mode 100644
index 000000000000..5f39bb211957
--- /dev/null
+++ b/net-mail/dbmail/files/dbmail-pop3d.initd
@@ -0,0 +1,68 @@
+#!/sbin/runscript
+#
+# chkconfig: - 91 35
+# description: Starts and stops dbmail-pop3d
+#
+
+
+PROGRAM=dbmail-pop3d
+
+BIN_DIR=/usr/sbin
+PID_DIR=/var/run/dbmail
+PID=pid
+
+# Where is the dbmail.conf file located?
+CONFIG=/etc/dbmail/dbmail.conf
+
+## not in 3.1.x yet
+#extra_started_commands="reload"
+
+depend() {
+ need net
+ # This won't cause a hard failure if neither is installed, however.
+ use mysql
+ use pgsql
+ after mta
+}
+
+initService() {
+ # Avoid using root's TMPDIR
+ unset TMPDIR
+
+ # Check that config file exists.
+ if [ ! -e $CONFIG ]; then
+ eerror "Config file not found ($CONFIG)"
+ eerror "An example config can be found in /etc/dbmail/dbmail.conf.dist"
+ return 1
+ fi
+
+ checkpath -d $PID_DIR -m 750 -o dbmail:dbmail
+
+ RETVAL=0
+}
+
+start() {
+ initService
+ ebegin "Starting DBMail POP3 daemon ($PROGRAM)"
+ start-stop-daemon --start --quiet \
+ --pidfile $PID_DIR/$PROGRAM.$PID \
+ --exec $BIN_DIR/$PROGRAM \
+ --name $PROGRAM \
+ -- -f $CONFIG -p $PID_DIR/$PROGRAM.$PID 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping DBMail POP3 daemon ($PROGRAM)"
+ start-stop-daemon --stop --quiet --retry 15 \
+ --pidfile $PID_DIR/$PROGRAM.$PID
+ eend $?
+}
+
+## not in 3.1.x yet
+#reload() {#
+# ebegin "Reloading DBMail POP3 daemon ($PROGRAM)"
+# start-stop-daemon --quiet --signal HUP \
+# --pidfile $PID_DIR/$PROGRAM.$PID
+# eend $?
+#}
diff --git a/net-mail/dbmail/files/dbmail-timsieved.initd b/net-mail/dbmail/files/dbmail-timsieved.initd
new file mode 100644
index 000000000000..83674b8f2767
--- /dev/null
+++ b/net-mail/dbmail/files/dbmail-timsieved.initd
@@ -0,0 +1,68 @@
+#!/sbin/runscript
+#
+# chkconfig: - 91 35
+# description: Starts and stops dbmail-timsieved
+#
+
+
+PROGRAM=dbmail-timsieved
+
+BIN_DIR=/usr/sbin
+PID_DIR=/var/run/dbmail
+PID=pid
+
+# Where is the dbmail.conf file located?
+CONFIG=/etc/dbmail/dbmail.conf
+
+## not in 3.1.x yet
+#extra_started_commands="reload"
+
+depend() {
+ need net
+ # This won't cause a hard failure if neither is installed, however.
+ use mysql
+ use pgsql
+ after mta
+}
+
+initService() {
+ # Avoid using root's TMPDIR
+ unset TMPDIR
+
+ # Check that config file exists.
+ if [ ! -e $CONFIG ]; then
+ eerror "Config file not found ($CONFIG)"
+ eerror "An example config can be found in /etc/dbmail/dbmail.conf.dist"
+ return 1
+ fi
+
+ checkpath -d $PID_DIR -m 750 -o dbmail:dbmail
+
+ RETVAL=0
+}
+
+start() {
+ initService
+ ebegin "Starting DBMail SIEVE daemon ($PROGRAM)"
+ start-stop-daemon --start --quiet \
+ --pidfile $PID_DIR/$PROGRAM.$PID \
+ --exec $BIN_DIR/$PROGRAM \
+ --name $PROGRAM \
+ -- -f $CONFIG -p $PID_DIR/$PROGRAM.$PID 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping DBMail SIEVE daemon ($PROGRAM)"
+ start-stop-daemon --stop --quiet --retry 15 \
+ --pidfile $PID_DIR/$PROGRAM.$PID
+ eend $?
+}
+
+## not in 3.1.x yet
+#reload() {#
+# ebegin "Reloading DBMail SIEVE daemon ($PROGRAM)"
+# start-stop-daemon --quiet --signal HUP \
+# --pidfile $PID_DIR/$PROGRAM.$PID
+# eend $?
+#}
diff --git a/net-mail/dbmail/metadata.xml b/net-mail/dbmail/metadata.xml
new file mode 100644
index 000000000000..9353ac561705
--- /dev/null
+++ b/net-mail/dbmail/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>lordvan@gentoo.org</email>
+ <name>Thomas Raschbacher</name>
+ </maintainer>
+ <longdescription>Dbmail is the name of a group of programs that enable the possiblilty of storing and retrieving mail messages from a database. Currently MySQL, PostgreSQL and SQLite can be used as database backends.</longdescription>
+ <use>
+ <flag name="sieve">Enable sieve filter support</flag>
+ </use>
+</pkgmetadata>