summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-27 17:24:58 +0000
committerSam James <sam@gentoo.org>2024-12-27 17:25:04 +0000
commitc28a1ae77ec6fa6196316da755a37224f69a899a (patch)
tree461d798b04b53bd488cb687a2d062b08196d54cb /net-libs
parentx11-terms/ghostty: require gui-libs/gtk[X] for gtk backend (diff)
downloadgentoo-c28a1ae77ec6fa6196316da755a37224f69a899a.tar.gz
gentoo-c28a1ae77ec6fa6196316da755a37224f69a899a.tar.bz2
gentoo-c28a1ae77ec6fa6196316da755a37224f69a899a.zip
net-libs/libntlm: add 1.8
Closes: https://bugs.gentoo.org/879731 Closes: https://bugs.gentoo.org/944130 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libntlm/Manifest1
-rw-r--r--net-libs/libntlm/libntlm-1.8.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/libntlm/Manifest b/net-libs/libntlm/Manifest
index b404dee88d0a..219415d8f177 100644
--- a/net-libs/libntlm/Manifest
+++ b/net-libs/libntlm/Manifest
@@ -1 +1,2 @@
DIST libntlm-1.6.tar.gz 688608 BLAKE2B 8e545619b1fb00d778bbebf6ab9748005928a2669dab8c3d9c6285127b551c1bf039e1748a710e5eb551e7cbcb1a8775b57c21b163ca2a0206a4b9948b11df8a SHA512 d68bc6b5cd7f5f70385ba78275a810fa46e60f761f0949f2262eef35ae052661739ef17ce3fc4ab75f7e8cfc788b1ccd7766d4ff0ee78db08ea4de3e224653f2
+DIST libntlm-1.8.tar.gz 617062 BLAKE2B c352fd9c96489264efbe1bdf41f8317442a81fff23c0bcc505f70be241a2ecdf662f40f2dbcc13ef1cf878e626cc5abf29eb378bae0a3f06447d9377cf1b716b SHA512 8d1563608b725008abcf948146d1ffce2d9cceab8264196d349be7faded51c61bcaf45ddb92b5c7dca2948fca554856a20198bb2e3bda0f93c8259335e14c377
diff --git a/net-libs/libntlm/libntlm-1.8.ebuild b/net-libs/libntlm/libntlm-1.8.ebuild
new file mode 100644
index 000000000000..48bfd8a7f1a5
--- /dev/null
+++ b/net-libs/libntlm/libntlm-1.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Microsoft's NTLM authentication (libntlm) library"
+HOMEPAGE="https://www.nongnu.org/libntlm/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+src_configure() {
+ econf \
+ --disable-gcc-warnings \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}