summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-29 23:01:24 -0400
committerMatt Turner <mattst88@gentoo.org>2023-03-30 12:54:37 -0400
commit405d30f7b2c6ce873951491c6c4cb050b48db3b5 (patch)
tree49837bfc0093bc8be087cf97b159a60a6b6cff18 /net-libs
parentdev-python/peewee: Remove old (diff)
downloadgentoo-405d30f7b2c6ce873951491c6c4cb050b48db3b5.tar.gz
gentoo-405d30f7b2c6ce873951491c6c4cb050b48db3b5.tar.bz2
gentoo-405d30f7b2c6ce873951491c6c4cb050b48db3b5.zip
net-libs/libdmapsharing: Version bump to 3.9.12
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libdmapsharing/Manifest1
-rw-r--r--net-libs/libdmapsharing/libdmapsharing-3.9.12.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libdmapsharing/Manifest b/net-libs/libdmapsharing/Manifest
index 95a327031877..8550788c69e5 100644
--- a/net-libs/libdmapsharing/Manifest
+++ b/net-libs/libdmapsharing/Manifest
@@ -1 +1,2 @@
DIST libdmapsharing-2.9.41.tar.gz 765880 BLAKE2B d64245ef6ffefb7a3f8b6c994e385427afe9b1aa22882da3f2fad82457fda6c48bea61314c6f4b8e82888284e98f4202338582dab2fd412c5e5cc96d7ff5f145 SHA512 304ba87428a39d2b9fd6d4cdc196f59e1aaf2ce3bb15f30acc2c9ca51ec8f86c9b499cf46cf938231e3088808475daba4fc55c44bcbef693be1b500dae4ab028
+DIST libdmapsharing-3.9.12.tar.gz 801055 BLAKE2B 121437f448e90a655fd6e999c9e1696c8377f10c41d3f8f59d4bad1af9ed29051523d799bc259a20305a976aa98aa0b10b5c8e761a2a55c023374282d4e0abe1 SHA512 c75667640371cdfe77088d10f77b668b4bb841aeef5ff9e1a08ce9903bd9a29f1d3184d790da9f87b78967636eedf00bb3299ff675acc82b9316eaca3c0ac41f
diff --git a/net-libs/libdmapsharing/libdmapsharing-3.9.12.ebuild b/net-libs/libdmapsharing/libdmapsharing-3.9.12.ebuild
new file mode 100644
index 000000000000..5c0d72ba5425
--- /dev/null
+++ b/net-libs/libdmapsharing/libdmapsharing-3.9.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="A library that implements the DMAP family of protocols"
+HOMEPAGE="https://www.flyn.org/projects/libdmapsharing/"
+SRC_URI="https://www.flyn.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="4.0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection test"
+RESTRICT="!test? ( test ) test" # TODO: Tests require Avahi mDNS to be running
+
+# Vala/libgee/gtk+:2 is only used when maintainer-mode is enabled
+# Doesn't seem to be used for anything...
+RDEPEND="
+ >=dev-libs/glib-2.66:2
+ x11-libs/gdk-pixbuf:2
+ >=net-dns/avahi-0.6[dbus]
+ net-libs/libsoup:3.0
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( >=dev-libs/check-0.9.4 )
+"
+
+src_prepare() {
+ # Remove useless CFLAGS alteration in configure
+ sed -e 's/CFLAGS -O2/CFLAGS/' -i configure || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --with-mdns=avahi \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}