summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-27 19:42:45 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-27 19:57:00 +0200
commit02a112a1802387c1b40d059b79e4f3067f581f51 (patch)
tree655c6b4701b9c332c2069f1ec2ec269d4633a343 /net-libs/uhttpmock
parentnet-im/empathy: version bump 3.12.12 → 3.12.14 (diff)
downloadgentoo-02a112a1802387c1b40d059b79e4f3067f581f51.tar.gz
gentoo-02a112a1802387c1b40d059b79e4f3067f581f51.tar.bz2
gentoo-02a112a1802387c1b40d059b79e4f3067f581f51.zip
net-libs/uhttpmock: version bump 0.5.0 → 0.5.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-libs/uhttpmock')
-rw-r--r--net-libs/uhttpmock/Manifest1
-rw-r--r--net-libs/uhttpmock/uhttpmock-0.5.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/uhttpmock/Manifest b/net-libs/uhttpmock/Manifest
index 56218729a9ae..80d680618856 100644
--- a/net-libs/uhttpmock/Manifest
+++ b/net-libs/uhttpmock/Manifest
@@ -1,2 +1,3 @@
DIST uhttpmock-0.4.0.tar.xz 295392 SHA256 0d9a75ac66070879a14caabddfaa7bd4e888e2abb03f9ac73610921ed341b571 SHA512 0f98db886aa02a911fc94c957a371651f9be5784602ea0492d04798dcf12c4a519a292ede9d37b25a965832e5d96ca9da7ce0ca8127af74d3986c4ef74e1f527 WHIRLPOOL 2d5a00407ed9c5022cb86773ee87580b6e8573c451beee9eeec535cbfb0b8e8d7847d6ec7f35914b9d4f3a3744d608383db181779dbc2ca2cb86667545b5f4f4
DIST uhttpmock-0.5.0.tar.xz 296908 SHA256 26da182a2db2579c5ba4dad9096d52099e0766228c295cfbaed6de4046f7d16e SHA512 952b618f3a12d7190f3812bc0bd53dd655a83d27f29bb749e62b36a08492bf535b85db7f5ff66f15c72bf5574696149f00476041f225ca6039ad87b221f5a1c6 WHIRLPOOL 8b85b70b18f47195726298dea99e8b3546d1a62bb15fc84839a152dfe050e5f599246a31394f9c542b8d3c5ff10ac9f403a9c467f95f2a2e2e112ad72abb250b
+DIST uhttpmock-0.5.1.tar.xz 310976 SHA256 a6a34a011db142a98473b492039c84468d575f416689484f1f82a84927f17798 SHA512 99135c0983be78eaaf962e5b182eaaf921e1d6ed30f98691d8766e9d4a9e07188965ce3f546a13a8c32b148bad305083cc3cfdf48d9a8b91efffaec5a46d8006 WHIRLPOOL 06d4bc6155f3e063521e10fe57b371c7a16e6c7b7f13c49f9684a8d8e8a0314e217ca4add24525fa27eb5a1d1bae8a5367909b95dc72ac02658867d188ed3d0c
diff --git a/net-libs/uhttpmock/uhttpmock-0.5.1.ebuild b/net-libs/uhttpmock/uhttpmock-0.5.1.ebuild
new file mode 100644
index 000000000000..ddbb936d67a7
--- /dev/null
+++ b/net-libs/uhttpmock/uhttpmock-0.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GCONF_DEBUG="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="HTTP web service mocking library"
+HOMEPAGE="https://gitlab.com/uhttpmock/uhttpmock"
+SRC_URI="http://tecnocode.co.uk/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.36.0:2
+ >=net-libs/libsoup-2.37.91:2.4
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}