summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-12 22:39:29 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-12 22:51:50 -0500
commit32b4dcb119600276279116c7b3e17815d5972257 (patch)
treed5ffa1ee02cb559061c80227b8adce82991e5fb4 /net-libs/telepathy-glib
parentmedia-gfx/eog: Version bump to 3.38.2 (diff)
downloadgentoo-32b4dcb119600276279116c7b3e17815d5972257.tar.gz
gentoo-32b4dcb119600276279116c7b3e17815d5972257.tar.bz2
gentoo-32b4dcb119600276279116c7b3e17815d5972257.zip
net-libs/telepathy-glib: Version bump to 0.24.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/Manifest1
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.24.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-libs/telepathy-glib/Manifest b/net-libs/telepathy-glib/Manifest
index a6fa7018495f..47c6ff1dda29 100644
--- a/net-libs/telepathy-glib/Manifest
+++ b/net-libs/telepathy-glib/Manifest
@@ -1 +1,2 @@
DIST telepathy-glib-0.24.1.tar.gz 3898149 BLAKE2B a4bc704b5b98c9e6df656833eec38b5f69a0b5d2621a6816ffa6c7da64f2c512cb992ffadd2ec2ac89a1b8cf6581c28aedad6b4019b3d16d9165c7d874370eb6 SHA512 2fed94f76a19d6069f671cdd45d2fd8a4b4ad27c4601aff66041ca205456be397c76a86f92cc9bf20fa4eb6d4c15a67ed8196644c143c37e945f382229a63335
+DIST telepathy-glib-0.24.2.tar.gz 3855853 BLAKE2B b98701e4897da5f1e1791af1d36f0f8e98fc0a043406a2e1e6c56437acfc7ed83701163a8c30d1ec2506cea4ca9a64827fca96ea0c3ea1566d38519b63a3a201 SHA512 736590c299b6522c41153e01e80d9bfdac1d4cbec646b28c9fba67a07429426ff2c8e38818f2cddd7ccdc38a061d210906f6e551f7a6059c34c4dd08b789b501
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.24.2.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.24.2.ebuild
new file mode 100644
index 000000000000..3d51fb532d10
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.24.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="https://telepathy.freedesktop.org/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="debug +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# Broken for a long time and upstream doesn't care
+# https://bugs.freedesktop.org/show_bug.cgi?id=63212
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/dbus-glib-0.90
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+"
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+# See bug 504744 for reference
+PDEPEND="
+ net-im/telepathy-mission-control
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-installed-tests \
+ $(use_enable debug backtrace) \
+ $(use_enable debug debug-cache) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Needs dbus for tests (auto-launched)
+ virtx emake -j1 check
+}