summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-04-23 23:45:46 +0300
committerMart Raudsepp <leio@gentoo.org>2017-04-24 01:38:46 +0300
commit268327764eac740079c59a5dfe864f34fbe45990 (patch)
tree790fbe66f2e29c97c044cd079cb7ab04c481c43c /net-libs/phodav
parentprofiles: Add phodav-2.2 to GNOME 3.24 mask (diff)
downloadgentoo-268327764eac740079c59a5dfe864f34fbe45990.tar.gz
gentoo-268327764eac740079c59a5dfe864f34fbe45990.tar.bz2
gentoo-268327764eac740079c59a5dfe864f34fbe45990.zip
net-libs/phodav: bump to 2.2 for glib-2.52 compatibility
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-libs/phodav')
-rw-r--r--net-libs/phodav/Manifest1
-rw-r--r--net-libs/phodav/phodav-2.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-libs/phodav/Manifest b/net-libs/phodav/Manifest
index 4ed4e95a2385..9bfd5a12dcf2 100644
--- a/net-libs/phodav/Manifest
+++ b/net-libs/phodav/Manifest
@@ -1 +1,2 @@
DIST phodav-2.1.tar.xz 293128 SHA256 da6073440b4cfd63f4d65b17e1a2a35ff501c7c940591da4533a03c2233ab898 SHA512 e43bd4c9ed97b7454e8452246c37211905b4cff430e91f3d2d36182736e1b8924d6ad477f58f110c98b85f02c085cd12c099020a0bea8abb19e65a9d52e1f4a8 WHIRLPOOL 4091fb0ac23b6a57c385054afa66a61eb038a37593167d888755dad38894898b45d7fcab6fa6d7582e4e2c5f0879e1ac782df2efc03e7e4372ac0a3341a4b10d
+DIST phodav-2.2.tar.xz 294216 SHA256 080305dc9e804562f200ffc8c7d345c76754fce9cb01489dddb1b2c52c0557c1 SHA512 1d16716c1bda674a6695b651e9b1bcb4b7cfefd9b60291ed3f5691f4f6f45f68a970d99fc4820bed0484cf0a43c1bf32e4d208fcc239ac0c0b7a75bf779e8913 WHIRLPOOL 6f5dd0ab04a48d307254f8aa0e0e02440b3f2e39a750f7da3fee24cd463a76dfe06e07779c789c7f2ca30093511ee774740b4ab19662fca27c5aff8af556d885
diff --git a/net-libs/phodav/phodav-2.2.ebuild b/net-libs/phodav/phodav-2.2.ebuild
new file mode 100644
index 000000000000..cb299868916a
--- /dev/null
+++ b/net-libs/phodav/phodav-2.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 systemd udev
+
+DESCRIPTION="WebDav server implementation using libsoup"
+HOMEPAGE="https://wiki.gnome.org/phodav"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="spice systemd zeroconf"
+
+# It included g_uuid_* symbols of its own from an unapplied patch to glib; now that they
+# were merged, it conflicts and crashes. Ensure glib versions from >2.51 are used, so it
+# doesn't break badly when phodav-2.2 is upgraded to before glib to 2.52
+RDEPEND="
+ >=dev-libs/glib-2.51:2
+ >=net-libs/libsoup-2.48:2.4
+ dev-libs/libxml2
+ zeroconf? ( net-dns/avahi )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --program-suffix=-${SLOT} \
+ $(use_with zeroconf avahi) \
+ --with-udevdir=$(get_udevdir) \
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+
+ if ! use zeroconf ; then
+ sed -i -e 's|avahi-daemon.service||' data/spice-webdavd.service || die
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use spice ; then
+ if ! use systemd ; then
+ newinitd "${FILESDIR}/spice-webdavd.initd" spice-webdavd
+ udev_dorules "${FILESDIR}/70-spice-webdavd.rules"
+ rm -r "${D}$(systemd_get_systemunitdir)" || die
+ fi
+ else
+ rm -r "${D}"{/usr/sbin,$(get_udevdir),$(systemd_get_systemunitdir)} || die
+ fi
+}