summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-29 03:02:15 +0100
committerSam James <sam@gentoo.org>2024-08-29 03:02:15 +0100
commit5116fd5283b330e37411d482f5da72eb9fc37884 (patch)
tree8ef45e55f7f9aa135eed589cc25fcfb845891102 /net-libs/ntirpc
parentnet-fs/nfs-utils: add 2.7.1 (diff)
downloadgentoo-5116fd5283b330e37411d482f5da72eb9fc37884.tar.gz
gentoo-5116fd5283b330e37411d482f5da72eb9fc37884.tar.bz2
gentoo-5116fd5283b330e37411d482f5da72eb9fc37884.zip
net-libs/ntirpc: add 6.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/ntirpc')
-rw-r--r--net-libs/ntirpc/Manifest1
-rw-r--r--net-libs/ntirpc/ntirpc-6.0.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index bf7aedc80f98..bdd981dad087 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1 +1,2 @@
DIST ntirpc-5.0.tar.gz 390950 BLAKE2B b97265eb0af7964b9810f2b4e285531bdd467c9b7385cfcdc75987a6c275e5675d2044e05f560e27a6d5cd4af80b6b27e484ce7cd333878dedf6d1d5fa1e434e SHA512 f73a1bf8a7188bd3fb50ce735ebd18dead63cb93ea8c347aef267082673c40580402b0381d1ed6c7fdecf7752718c059e406dff3051a739632ed8097eccc6646
+DIST ntirpc-6.0.1.tar.gz 438965 BLAKE2B 393a9d45127c52930a845db638de6cb4f370452075e085cd40a6a59daec27ab1bd4291a713685b344b2c829d08f186425cd6383951d1bae66e49c1e70676980a SHA512 7145f1b620309517a2c1c51f2deba15cc5651eee8010aea2d9b667e281c4ac82855f5222a54b701775472e3466b69b7d6aa2e53d05d6553f9200870491de7af5
diff --git a/net-libs/ntirpc/ntirpc-6.0.1.ebuild b/net-libs/ntirpc/ntirpc-6.0.1.ebuild
new file mode 100644
index 000000000000..351ef70b92d0
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-6.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS=$(usex gssapi)
+ -DUSE_RPC_RDMA=$(usex rdma)
+ )
+ cmake_src_configure
+}