summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2015-10-18 20:14:01 -0400
committerAnthony Ryan <anthonyryan1@gmail.com>2015-10-26 14:02:45 -0400
commit68094515e99d372640000f147c958f3e6470322c (patch)
treeb788d8fe72dfb2c89280a85d7272ecb004ca434e /net-libs/libtorrent
parentgames-strategy/0ad: rm old (diff)
downloadgentoo-68094515e99d372640000f147c958f3e6470322c.tar.gz
gentoo-68094515e99d372640000f147c958f3e6470322c.tar.bz2
gentoo-68094515e99d372640000f147c958f3e6470322c.zip
net-p2p/rtorrent: version bump 0.9.6
* Bumped net-libs/libtorrent (required bump by dependency) * Updated the HOMEPAGE and SRC_URI due to changes upstream * [Repoman] Bumped EAPI, copyright and added slot operators * Added additional metadata and fixed indentation of metadata.xml * Added missing test dependency for libtorrent * Removed posix_falloc test override (resolved upstream) * Initial LibreSSL support Fixes https://bugs.gentoo.org/562830
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/Manifest1
-rw-r--r--net-libs/libtorrent/files/download_constructor.diff21
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.6.ebuild53
-rw-r--r--net-libs/libtorrent/metadata.xml5
4 files changed, 58 insertions, 22 deletions
diff --git a/net-libs/libtorrent/Manifest b/net-libs/libtorrent/Manifest
index 588fdf9c1dab..5a4d1117df87 100644
--- a/net-libs/libtorrent/Manifest
+++ b/net-libs/libtorrent/Manifest
@@ -1,2 +1,3 @@
DIST libtorrent-0.13.3.tar.gz 732847 SHA256 34317d6783b7f8d0805274c9467475b5432a246c0de8e28fc16e3b0b43f35677 SHA512 40f504db26d52b0c65fc1008c7b1465bde0e316c776028c5448bf15c6fd38389fad780b0c200933e51f63974a43942603e0103d45a98a3dd57f23f01a306ef25 WHIRLPOOL 7ed5c4903413c9a1587a561a9ec4bedf86f1ed78c8f81c0d0ebe7bf7de9f45187cb41520d3187d62d3718c2fb379857fac255311618b42bfcf77794ee8636ff2
DIST libtorrent-0.13.4.tar.gz 768382 SHA256 704e097119dc89e2ee4630396b25de1cd64b0549841347ea75b9ef9217084955 SHA512 6a5ea944c1193d1160563828c5901f0cf557f38c4de61153d505344f3c3c8509c765e01b6cc5e3a53ec2bb184a9e8db32ed4ec154e93a93822804210f0fa45d0 WHIRLPOOL dc3361a1fed59d64e8b6c2fed46d8e20134cd7f0c3b1cad2a1776375a4a3ff796a63fdfb027fa3f81fbb0b409db76592985444702ddf5e034e7c6384b602c4d4
+DIST libtorrent-0.13.6.tar.gz 781253 SHA256 2838a08c96edfd936aff8fbf99ecbb930c2bfca3337dd1482eb5fccdb80d5a04 SHA512 b8aea4060357a8a40d15d42f1f698ef6f3ebdc885000bfbfa5bf9c81af8c88b5503a107e05c214e3e8489126928d336356c5e7e0eaf836b6b84a3cf74633b050 WHIRLPOOL 9bfc9444efef33dce9792b7dc50fd150ebf7462ea656f82ed7cf1b9c3873eb94742c1e3ecdea6d1c382383ca6ebd4ac1e1ea4169328534d056944fb26c2aa4fd
diff --git a/net-libs/libtorrent/files/download_constructor.diff b/net-libs/libtorrent/files/download_constructor.diff
deleted file mode 100644
index e806cabb64b2..000000000000
--- a/net-libs/libtorrent/files/download_constructor.diff
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/download/download_constructor.cc 2011-03-08 17:48:43.000000000 +0300
-+++ src/download/download_constructor.cc.new 2011-03-08 17:36:42.000000000 +0300
-@@ -97,7 +97,17 @@
-
- parse_name(b.get_key("info"));
- parse_info(b.get_key("info"));
--
-+
-+ // hack, quick fix for #2505
-+ if (b.has_key_list("announce-list"))
-+ if (b.get_key_list("announce-list").empty()) {
-+ b.erase_key("announce-list");
-+ } else {
-+ Object::list_type & l = b.get_key_list("announce-list");
-+ if (l.size() == 1 && !l.begin()->is_list()) {
-+ b.erase_key("announce-list");
-+ }
-+ }
- parse_tracker(b);
- }
-
diff --git a/net-libs/libtorrent/libtorrent-0.13.6.ebuild b/net-libs/libtorrent/libtorrent-0.13.6.ebuild
new file mode 100644
index 000000000000..42e1ba69d7de
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+# The README says that the library ABI is not yet stable and dependencies on
+# the library should be an explicit, syncronized version until the library
+# has had more time to mature. Until it matures we should not include a soname
+# subslot.
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="debug ipv6 libressl ssl test"
+
+RDEPEND="
+ sys-libs/zlib
+ >=dev-libs/libsigc++-2.2.2:2
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ --with-posix-fallocate
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/net-libs/libtorrent/metadata.xml b/net-libs/libtorrent/metadata.xml
index aa0f3664825f..50a5b2c6c3fb 100644
--- a/net-libs/libtorrent/metadata.xml
+++ b/net-libs/libtorrent/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-p2p</herd>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="github">rakshasa/libtorrent</remote-id>
+ </upstream>
</pkgmetadata>