summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-24 12:46:30 +0100
committerSam James <sam@gentoo.org>2022-10-24 12:46:30 +0100
commit9af247930416e012b38b8fbc8f8fbc2805162945 (patch)
tree56b9b94cf64f48fa0f23f4aa7a4fc16aa18a93d5 /net-libs/libtorrent-rasterbar
parentnet-libs/libtorrent-rasterbar: add 1.2.18 (diff)
downloadgentoo-9af247930416e012b38b8fbc8f8fbc2805162945.tar.gz
gentoo-9af247930416e012b38b8fbc8f8fbc2805162945.tar.bz2
gentoo-9af247930416e012b38b8fbc8f8fbc2805162945.zip
net-libs/libtorrent-rasterbar: add 2.0.8
Closes: https://bugs.gentoo.org/854603 Closes: https://bugs.gentoo.org/850898 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libtorrent-rasterbar')
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.8.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index 216e1cb238da..858fef4dd0c1 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -3,3 +3,4 @@ DIST libtorrent-rasterbar-1.2.17.tar.gz 4167440 BLAKE2B 06e785e7ffa0e4f506b3f56f
DIST libtorrent-rasterbar-1.2.18.tar.gz 4178407 BLAKE2B ccf8d891e4c34d101a8d822149d14b46cebf57dd893c00e2481e55c0cb35f6931b02e4b6f8877140316bb3bf1840a54eb04943aa1fd190d29708ae64a5c93604 SHA512 4ac7ad6357a612bdc537d4dbce40935a43c32295773870e490d1acffab9841b2bb3052e476a91f702b7b5eb2ab3e6282792f53593cdcb06ddbd6f1d5a3097ee7
DIST libtorrent-rasterbar-2.0.6.tar.gz 4431174 BLAKE2B 4951a102b68a5a7ba9a98d771ca638e8438b2aeaa95f5d7bf616542c7a02d28e184ee1bf5b7a55cd91a068cd2d4e9756c479e4ddb5eabe89d8aa833d70aa7502 SHA512 4a5d710706040ef6193967dbb13998cb0ddebe7e95c3bf8aec0812876027c68c32b001fd3f07cd4ff1b819660a8d46ae8c7077e72caf92572288a51cdec7daea
DIST libtorrent-rasterbar-2.0.7.tar.gz 4453469 BLAKE2B b04884c55cb96031f6bfcef786ea101d18bb9310ec2e1ed528e27d8f625712855726575beae127f24c007144bb85e1eba293da748ad06794c58ebd9b38ec5aac SHA512 30e558245a261ccf3f23815a037477ae6da1a02da0b7b3aa40383058c5782a341a11ae684f959efc1c9b39e31475ec31451b9ff4b2db3c0bfccc4d42bd6d69c1
+DIST libtorrent-rasterbar-2.0.8.tar.gz 4562750 BLAKE2B 6ea5855bd2e2d2ef56191ffea7bfc08a88ef43ffee177c1de12dbb62dc9167789abc5fcf2608856d5b23d5dc461fdc8d3f30c01286ce2ba9a11cb4d24fed477c SHA512 697988feae149876745097bedfbfb4cceae00ffe1cd4ba2063dcb93a8eee9e99344f772b8364e3df1986a50105e386e56b75fe362707d58ba3272139d9beb98f
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.8.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.8.ebuild
new file mode 100644
index 000000000000..037c1e088ca0
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="https://libtorrent.org/ https://github.com/arvidn/libtorrent"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+dht debug gnutls python ssl test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/boost:=
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ ')
+ )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="python? (
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+ )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=17
+ -DBUILD_SHARED_LIBS=ON
+ -Dbuild_examples=OFF
+ -Ddht=$(usex dht ON OFF)
+ -Dencryption=$(usex ssl ON OFF)
+ -Dgnutls=$(usex gnutls ON OFF)
+ -Dlogging=$(usex debug ON OFF)
+ -Dpython-bindings=$(usex python ON OFF)
+ -Dbuild_tests=$(usex test ON OFF)
+ )
+
+ # We need to drop the . from the Python version to satisfy Boost's
+ # FindBoost.cmake module, bug #793038.
+ use python && mycmakeargs+=( -Dboost-python-module-name="${EPYTHON/./}" )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # test_upnp: needs running UPnP server
+ # test_create_torrent: known failure which needs investigation (bug #850898)
+ -E "(test_upnp|test_create_torrent)"
+ )
+
+ # Checked out Fedora's test workarounds for inspiration
+ # https://src.fedoraproject.org/rpms/rb_libtorrent/blob/rawhide/f/rb_libtorrent.spec#_120
+ # -j1 for https://bugs.gentoo.org/854603#c1
+ LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" cmake_src_test -j1
+}