summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-09 13:53:45 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-09 14:39:04 +0100
commitce7ef2269c36d8f07ae4f578b84dda2454dee5e4 (patch)
tree6446056eb23c698a740fe08f5044cb7b8e8725a9 /net-libs/libpcap/libpcap-9999.ebuild
parentwww-servers/h2o: add libh2o USE flag (diff)
downloadgentoo-ce7ef2269c36d8f07ae4f578b84dda2454dee5e4.tar.gz
gentoo-ce7ef2269c36d8f07ae4f578b84dda2454dee5e4.tar.bz2
gentoo-ce7ef2269c36d8f07ae4f578b84dda2454dee5e4.zip
net-libs/libpcap: USE=remote, EAPI=7, strip pcap-config -L/usr/lib
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/libpcap/libpcap-9999.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index f240ac606d96..1a75013c5b77 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools git-r3 multilib-minimal ltprune
+EAPI=7
+inherit autotools git-r3 multilib-minimal
DESCRIPTION="A system-independent library for user-level network packet capture"
EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
@@ -13,7 +13,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-IUSE="bluetooth dbus netlink static-libs usb"
+IUSE="bluetooth dbus netlink -remote static-libs usb"
KEYWORDS=""
RDEPEND="
@@ -45,6 +45,7 @@ multilib_src_configure() {
econf \
$(use_enable bluetooth) \
$(use_enable dbus) \
+ $(use_enable remote) \
$(use_enable usb) \
$(use_with netlink libnl)
}
@@ -60,7 +61,8 @@ multilib_src_install_all() {
if ! use static-libs; then
find "${ED}" -name '*.a' -exec rm {} + || die
fi
- prune_libtool_files
+
+ find "${ED}" -name '*.la' -delete || die
# We need this to build pppd on G/FBSD systems
if [[ "${USERLAND}" == "BSD" ]]; then