summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libosmocore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libosmocore')
-rw-r--r--net-libs/libosmocore/Manifest2
-rw-r--r--net-libs/libosmocore/files/libosmocore-0.6.0-automake-1.13.patch11
-rw-r--r--net-libs/libosmocore/libosmocore-0.6.6.ebuild38
-rw-r--r--net-libs/libosmocore/libosmocore-0.8.0.ebuild48
-rw-r--r--net-libs/libosmocore/libosmocore-9999.ebuild48
-rw-r--r--net-libs/libosmocore/metadata.xml10
6 files changed, 157 insertions, 0 deletions
diff --git a/net-libs/libosmocore/Manifest b/net-libs/libosmocore/Manifest
new file mode 100644
index 000000000000..508d858c3f3a
--- /dev/null
+++ b/net-libs/libosmocore/Manifest
@@ -0,0 +1,2 @@
+DIST libosmocore-0.6.6.tar.bz2 396707 SHA256 c0ea2cdb1bdfe9cd815f7abf1abbf3f9ae4f7d5fc73d2820a02038da565ec83d SHA512 d0b2a4f0efb8c364a3c3da8cd888a30eb19f193ae13e9ecbb7126b33dd18c2c23a19672866efc365cdc49b0a971ce87d828ec3fbf7e0df4f4d6ff5f3e32a9c17 WHIRLPOOL 7d01aee748b8866bb2f0117ba00d152de56994d7e9cabe27d07ac760b7e07c9c09cd0b983cf5044757190e3cd84632ffc2000fa84b46506574618c9babd56b2e
+DIST libosmocore-0.8.0.tar.bz2 439320 SHA256 7a757b20855a030bc402d6b03411bc6a2d717b2f2cc97ee891cb13661825aefb SHA512 4ffd5943807440f80f70e381e477631a592fef41a3485819d94e7ce9523785e20057759aec6cac7abe57ba21b7d48e38164b7272c5bcd89882a3a8e213d89361 WHIRLPOOL e9e3c82d0d64a85d6915dedc9070f224e49b86a85239a1649751b85ddf2eda537ca9f90a578c42da6df13e77203aaa4dcf069d434f140313439a91686647aee6
diff --git a/net-libs/libosmocore/files/libosmocore-0.6.0-automake-1.13.patch b/net-libs/libosmocore/files/libosmocore-0.6.0-automake-1.13.patch
new file mode 100644
index 000000000000..c61ecac1f336
--- /dev/null
+++ b/net-libs/libosmocore/files/libosmocore-0.6.0-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- libosmocore-0.6.0/configure.ac
++++ libosmocore-0.6.0/configure.ac
+@@ -77,7 +77,7 @@
+ CHECK_TM_INCLUDES_TM_GMTOFF
+
+ dnl Generate the output
+-AC_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ AC_ARG_ENABLE(talloc,
+ [AS_HELP_STRING(
diff --git a/net-libs/libosmocore/libosmocore-0.6.6.ebuild b/net-libs/libosmocore/libosmocore-0.6.6.ebuild
new file mode 100644
index 000000000000..22d18e9990fe
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-0.6.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="embedded"
+
+RDEPEND="embedded? ( sys-libs/talloc )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
+
+ epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable embedded)
+}
+
+src_install() {
+ default
+ # install to correct documentation directory
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+}
diff --git a/net-libs/libosmocore/libosmocore-0.8.0.ebuild b/net-libs/libosmocore/libosmocore-0.8.0.ebuild
new file mode 100644
index 000000000000..4f9f02bc6293
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-0.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+IUSE="embedded pcsc-lite"
+
+RDEPEND="embedded? ( sys-libs/talloc )
+ pcsc-lite? ( sys-apps/pcsc-lite )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
+
+ epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable embedded) \
+ $(use_enable pcsc-lite pcsc)
+}
+
+src_install() {
+ default
+ # install to correct documentation directory
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+}
diff --git a/net-libs/libosmocore/libosmocore-9999.ebuild b/net-libs/libosmocore/libosmocore-9999.ebuild
new file mode 100644
index 000000000000..4f9f02bc6293
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+IUSE="embedded pcsc-lite"
+
+RDEPEND="embedded? ( sys-libs/talloc )
+ pcsc-lite? ( sys-apps/pcsc-lite )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
+
+ epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable embedded) \
+ $(use_enable pcsc-lite pcsc)
+}
+
+src_install() {
+ default
+ # install to correct documentation directory
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+}
diff --git a/net-libs/libosmocore/metadata.xml b/net-libs/libosmocore/metadata.xml
new file mode 100644
index 000000000000..a3b7887f7df3
--- /dev/null
+++ b/net-libs/libosmocore/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>radio</herd>
+ <use>
+ <flag name='embedded'>Build for embedded use and disable unsupported features</flag>
+ <flag name='pcsc-lite'>Enable smartcard support with <pkg>sys-apps/pcsc-lite</pkg></flag>
+ </use>
+</pkgmetadata>
+