summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2022-09-30 09:51:51 -0400
committerRick Farina <zerochaos@gentoo.org>2022-09-30 09:53:22 -0400
commit47d312a25cc0d8c6917787a41a37c4e73d7d0eab (patch)
treefc4278ce6dc7a1a57cc6d51d3d6e452f2c12d30a /net-libs/libhackrf
parentnet-libs/libssh: drop 0.9.6 (diff)
downloadgentoo-47d312a25cc0d8c6917787a41a37c4e73d7d0eab.tar.gz
gentoo-47d312a25cc0d8c6917787a41a37c4e73d7d0eab.tar.bz2
gentoo-47d312a25cc0d8c6917787a41a37c4e73d7d0eab.zip
net-libs/libhackrf: build only shared lib (no-op)
So, this actually does nothing, because the applied patch ALSO builds only shared libs. That said, it's the first step toward not needing the patch and I don't want to forget later when/if upstream fixes their bug which won't allow install for only shared libs. Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-libs/libhackrf')
-rw-r--r--net-libs/libhackrf/libhackrf-2022.09.1.ebuild4
-rw-r--r--net-libs/libhackrf/libhackrf-9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/net-libs/libhackrf/libhackrf-2022.09.1.ebuild b/net-libs/libhackrf/libhackrf-2022.09.1.ebuild
index 586e9f4bd1ec..126023d3e828 100644
--- a/net-libs/libhackrf/libhackrf-2022.09.1.ebuild
+++ b/net-libs/libhackrf/libhackrf-2022.09.1.ebuild
@@ -42,6 +42,10 @@ src_configure() {
cmake_src_configure
}
+src_compile() {
+ cmake_build hackrf
+}
+
pkg_postinst() {
if use udev; then
einfo "Users in the usb group can use hackrf."
diff --git a/net-libs/libhackrf/libhackrf-9999.ebuild b/net-libs/libhackrf/libhackrf-9999.ebuild
index 586e9f4bd1ec..126023d3e828 100644
--- a/net-libs/libhackrf/libhackrf-9999.ebuild
+++ b/net-libs/libhackrf/libhackrf-9999.ebuild
@@ -42,6 +42,10 @@ src_configure() {
cmake_src_configure
}
+src_compile() {
+ cmake_build hackrf
+}
+
pkg_postinst() {
if use udev; then
einfo "Users in the usb group can use hackrf."