summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-07 07:13:19 +0000
committerSam James <sam@gentoo.org>2021-06-07 07:13:57 +0000
commit090649fefe0e649082041ec7c4a89a040a8fada4 (patch)
tree9cfb05166ac42b00cfb3936248592c802a4355ba /net-libs/libesmtp
parentnet-mail/isync: add 1.4.2 (diff)
downloadgentoo-090649fefe0e649082041ec7c4a89a040a8fada4.tar.gz
gentoo-090649fefe0e649082041ec7c4a89a040a8fada4.tar.bz2
gentoo-090649fefe0e649082041ec7c4a89a040a8fada4.zip
net-libs/libesmtp: add 1.1.0
Bug: https://bugs.gentoo.org/782532 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libesmtp')
-rw-r--r--net-libs/libesmtp/Manifest1
-rw-r--r--net-libs/libesmtp/libesmtp-1.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libesmtp/Manifest b/net-libs/libesmtp/Manifest
index 05b0c516e94b..6a1d82e58c91 100644
--- a/net-libs/libesmtp/Manifest
+++ b/net-libs/libesmtp/Manifest
@@ -1,2 +1,3 @@
DIST libesmtp-1.0.6.tar.bz2 365506 BLAKE2B 9ce8c9f210e6c41c95bba55a7aec79c176c4582f5dafc1aba4fbf9adb411b75ab89d400ac7a12b7d5d24ede414cb8e2ca306299a2e156515e611d074142cf5e8 SHA512 c122fc5995b76771cce2db58c9e59597cc3a76d273feb6fc26b869f118e91bdf98a5721ee2d1de8175c376af018b5806b0379bbeba2f5da95108916028fd8dda
DIST libesmtp-1.0.6_p20200824.tar.gz 156674 BLAKE2B a78dece0cceb252ca7505b5457a9137c6e3f45c544b9774ab683fb1defed6458ed0d94604aa16df540d3e397738fbe00e1c3b3c649f34b73421e494c35cf2fc1 SHA512 bd0868aa8fb10bd81c18d473acaf1ef94ab2278a6619e5d348a59857f459d2d47a22583d7d533a983518ece436853914420b7189c305d9dab5c399bf26f8a5c0
+DIST libesmtp-1.1.0.tar.gz 169134 BLAKE2B 94ef87c65101557f6d60a6bcd7a8b0de638c24d46536ddf602da05c09858780b0a50f9fd8dae1e54a5e9a7826d45fa6da10bad751a9be50475a8f441c94ad455 SHA512 fc2a9d9922a1807cce8c8cee627ea8fd3a79c33f0987c5a487080b1a1659fd504bc45da2f919d30eced33ab3e950105383a46ecf3365493134adc1183eb99e53
diff --git a/net-libs/libesmtp/libesmtp-1.1.0.ebuild b/net-libs/libesmtp/libesmtp-1.1.0.ebuild
new file mode 100644
index 000000000000..c117af101c94
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Lib that implements the client side of the SMTP protocol"
+HOMEPAGE="https://libesmtp.github.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libesmtp/libESMTP.git"
+else
+ SRC_URI="https://github.com/libesmtp/libESMTP/archive/v${PV/_}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/libESMTP-${PV}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0/7"
+IUSE="ssl static-libs threads"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-1.1.0:0= )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/{authors,bugreport,ChangeLog,faq,NEWS}.md README.md )
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ $(meson_feature ssl tls)
+ $(meson_feature threads pthreads)
+ )
+ meson_src_configure
+}