summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-12-17 03:19:33 +0100
committerLouis Sautier <sbraz@gentoo.org>2022-12-17 03:25:28 +0100
commit6d8a8346bebf1a5ff0053790fd6085db5d88e34a (patch)
treeef01a4a7082e57147b0a71c06d9673030d6ee91a /net-irc
parentdev-python/jc: add 1.22.3 (diff)
downloadgentoo-6d8a8346bebf1a5ff0053790fd6085db5d88e34a.tar.gz
gentoo-6d8a8346bebf1a5ff0053790fd6085db5d88e34a.tar.bz2
gentoo-6d8a8346bebf1a5ff0053790fd6085db5d88e34a.zip
net-irc/eggdrop: add 1.9.4, remove ipv6 USE flag
Enabling IPv6 unconditionally is recommended to avoid the "UseFlagWithoutDeps" pkgcheck warning. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/eggdrop/Manifest1
-rw-r--r--net-irc/eggdrop/eggdrop-1.9.4.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-irc/eggdrop/Manifest b/net-irc/eggdrop/Manifest
index e07b2f3fb04d..10ec366bdba7 100644
--- a/net-irc/eggdrop/Manifest
+++ b/net-irc/eggdrop/Manifest
@@ -1,3 +1,4 @@
DIST eggdrop-1.9.1.tar.gz 2271120 BLAKE2B 73fadeddcebeba5de42328f6f02c05e850e47c19812bc1a868da09f55fd1d297e3596c5a4b167806237554966e7dfbebadcee6215932c56a76b3e67a77d5ee47 SHA512 d8907d265f7e22f3bcd3e28b256c5788d5959ad11cc1425d59eb4411ebbc172fe8d90c31fd9f033369ab80cd29a36a5856f6bd32bc6c9cdfedea1d6509ea7f3b
DIST eggdrop-1.9.2.tar.gz 2296300 BLAKE2B ed409896718e45daab2b21c25e7f1a5a2664ef8afec7127943abb3018ce963413e714618ee730ef2c49e4542c6e87377cff405ee36ce91448335adf6c7ab5a8a SHA512 67c8053a79ab5c4c418164e4e12f89a6e111b06b4e6dfdc69c52913b2f3b9a58b065a7601165112071c9ca2a778269aeb95c749a9da787c1932e6471a23146ce
DIST eggdrop-1.9.3.tar.gz 2046726 BLAKE2B 979190536c3c0718ef4b030d8f6df817b8ee823854c104b7d6f9009c10a7f8394d59afca40fc5c9778f130788fac7e14458d62d30a55413dea4653ca00c83f0a SHA512 67d6d0f798222e54e09acb319aa4926181c34b6e4cdc2cbb4fc7a8433915a7d6281904fd190fe2ee92bcc2cb99943e3fb5b9d99831cc0bfd930205e63e33d1a1
+DIST eggdrop-1.9.4.tar.gz 2065217 BLAKE2B f9d1e6c0491d6c7959e3b67e8186082d074d648497cd66f244dfb4c919a566d81fdce83d034f0cc1e5247bc924022faf56004cdd8a6cc174fe8d0f44af5e2a9a SHA512 ed3145411a1832d1a6d4f191c6ff30e64aa45f803df00585c1c69f6bbc8a16d07e9608c57e31fb723f7a9c66a24422e5080aab7746e562ac5b6a678a08c7b2a4
diff --git a/net-irc/eggdrop/eggdrop-1.9.4.ebuild b/net-irc/eggdrop/eggdrop-1.9.4.ebuild
new file mode 100644
index 000000000000..0e23b091183d
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.9.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+MY_P="${PN}-${PV/_rc/rc}"
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="https://www.eggheads.org/"
+SRC_URI="https://ftp.eggheads.org/pub/eggdrop/source/${PV:0:3}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~riscv ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug doc ssl static"
+
+DEPEND="
+ dev-lang/tcl:0=
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="
+ sys-apps/gentoo-functions
+ ${DEPEND}
+"
+
+DOCS=( AUTHORS FEATURES INSTALL NEWS README THANKS UPGRADING )
+
+src_configure() {
+ econf --enable-ipv6 \
+ $(use_enable ssl tls)
+
+ emake config
+}
+
+src_compile() {
+ local target
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ emake DEST="${D}"/opt/eggdrop install
+
+ use doc && HTML_DOCS=( doc/html/. )
+ rm -r "${D}"/opt/eggdrop/doc/html || die
+ DOC_CONTENTS="
+ Additional documentation can be found
+ in ${EPREFIX}/opt/eggdrop/doc
+ "
+ readme.gentoo_create_doc
+ einstalldocs
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ # Only display this for new installs
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please run ${EPREFIX}/usr/bin/eggdrop-installer to install your eggdrop bot."
+ fi
+}