summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2022-01-30 16:06:18 -0800
committerSam James <sam@gentoo.org>2022-01-31 01:00:58 +0000
commitf264f80b9f955dd7ef8e10d0a0dddcb79ee0dca4 (patch)
treef2870055f952bca7eceb7f4bfe17ccaa13d5b314 /net-irc/atheme-services
parentmail-filter/amavisd-new: Bump to version 2.12.2 (diff)
downloadgentoo-f264f80b9f955dd7ef8e10d0a0dddcb79ee0dca4.tar.gz
gentoo-f264f80b9f955dd7ef8e10d0a0dddcb79ee0dca4.tar.bz2
gentoo-f264f80b9f955dd7ef8e10d0a0dddcb79ee0dca4.zip
net-irc/atheme-services: Add 7.2.12
Bug: https://bugs.gentoo.org/832400 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/24026 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc/atheme-services')
-rw-r--r--net-irc/atheme-services/Manifest1
-rw-r--r--net-irc/atheme-services/atheme-services-7.2.12.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/net-irc/atheme-services/Manifest b/net-irc/atheme-services/Manifest
index 77a13813677c..42b0fc67c057 100644
--- a/net-irc/atheme-services/Manifest
+++ b/net-irc/atheme-services/Manifest
@@ -1 +1,2 @@
DIST atheme-services-7.2.11.tar.xz 1051436 BLAKE2B 99624c21adf820c8ef8e33aa9ae9036c701c4a9218e225e7871717c86010fbed56d00da43cd2ffb79a46074a5602260fabbbaf769407a00175b5127c18913c1c SHA512 adcc189b61efe295997a7456022a7595df5b14b55c2139794d380e57fe77efd42221316558391b5440f077fd951143905454b0e9893deec89108fa671b44ef2f
+DIST atheme-services-7.2.12.tar.xz 1072992 BLAKE2B f9e1cb175c1e2f38b5d53eba8f3d391e421baaff7eb76f38b10ba02b258472ccf9b69a7a278ff05c4f620b6fe6e48362618c02d245ed5d9c5acd4bede91ac093 SHA512 0d276b9a0c96f72a739090c5b2c732ab6c000f801cbb86347b5670def56f36fb82d70fb4cb68a1d942b9765c054bc136a6b0cecc0573cf8f59076f8b91fc6bf6
diff --git a/net-irc/atheme-services/atheme-services-7.2.12.ebuild b/net-irc/atheme-services/atheme-services-7.2.12.ebuild
new file mode 100644
index 000000000000..b81b81d9a106
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-7.2.12.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic perl-functions
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="https://github.com/atheme/atheme"
+SRC_URI="https://github.com/atheme/atheme/releases/download/v${PV}/${PN}-v${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
+S="${WORKDIR}/${PN}-v${PV}"
+
+RDEPEND="
+ acct-group/atheme-services
+ acct-user/atheme-services
+ >=dev-libs/libmowgli-2.1.0:2
+ virtual/libcrypt:=
+ cracklib? ( sys-libs/cracklib )
+ ldap? ( net-nds/openldap )
+ perl? ( dev-lang/perl:= )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+# 'dev-vcs/git' required as per bug #665802
+BDEPEND="
+ dev-vcs/git
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.2.10_p2-configure-logdir.patch)
+
+src_configure() {
+ # perl scriping module support is also broken in 7.0.0. Yay for QA failures.
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --disable-warnings \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with cracklib) \
+ $(use_with ldap) \
+ $(use_enable nls) \
+ $(use_enable profile) \
+ $(use_with pcre) \
+ $(use_with perl) \
+ $(use_enable ssl)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ local confdest=${conf##*/}
+ newins ${conf} ${confdest%.example}
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ mv "${ED}"/usr/bin/{,atheme-}dbverify || die
+
+ # contributed scripts and such:
+ docinto contrib
+ dodoc contrib/*.{c,pl,php,py,rb}
+
+ use perl && perl_domodule -r contrib/Atheme{,.pm}
+
+ rm "${ED}/usr/share/doc/${PF}/WINDOWS" || die
+
+ # Bug #454840 #520490
+ rm -rf "${ED}/var/run" || die
+}