summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-28 12:15:15 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-28 12:15:15 +0200
commit92f21a15729321069c11c483e47bd32bfd1ac0c1 (patch)
treec7937a4df21e2884057125269c400edccf69df4e /net-ftp
parentnet-libs/libetpan: Support libressl (#565266 by Marek Behun) (diff)
downloadgentoo-92f21a15729321069c11c483e47bd32bfd1ac0c1.tar.gz
gentoo-92f21a15729321069c11c483e47bd32bfd1ac0c1.tar.bz2
gentoo-92f21a15729321069c11c483e47bd32bfd1ac0c1.zip
net-ftp/gftp: Support libressl (#565380 by Marek Behun), fix .desktop file (#530800 by Kévin Bernard-Allies).
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/gftp/files/gftp-2.0.19-desktop.patch26
-rw-r--r--net-ftp/gftp/gftp-2.0.19-r3.ebuild49
2 files changed, 75 insertions, 0 deletions
diff --git a/net-ftp/gftp/files/gftp-2.0.19-desktop.patch b/net-ftp/gftp/files/gftp-2.0.19-desktop.patch
new file mode 100644
index 000000000000..878a77b5bf72
--- /dev/null
+++ b/net-ftp/gftp/files/gftp-2.0.19-desktop.patch
@@ -0,0 +1,26 @@
+@@ -, +, @@
+ <kevin.bernard.allies@gmail.com>
+ * the Encoding key is now deprecated, and UTF-8 is the default value.
+ * As the value of Icon is not an absolute path, there should be no extension.
+ * The Application category is deprecated.
+ docs/gftp.desktop | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+--- a/docs/gftp.desktop
++++ a/docs/gftp.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=gFTP
+ Comment=Download and upload files using multiple file transfer protocols
+ Comment[fr]=Télécharge des fichiers en utilisant le protocole FTP
+@@ -8,8 +7,8 @@ Exec=gftp %u
+ Terminal=false
+ X-MultipleArgs=false
+ Type=Application
+-Icon=gftp.png
+-Categories=Application;Network;
++Icon=gftp
++Categories=Network;
+ X-GNOME-Bugzilla-Bugzilla=GNOME
+ X-GNOME-Bugzilla-Product=gftp
+ X-GNOME-Bugzilla-Component=general
diff --git a/net-ftp/gftp/gftp-2.0.19-r3.ebuild b/net-ftp/gftp/gftp-2.0.19-r3.ebuild
new file mode 100644
index 000000000000..904c1c4a1fc3
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.0.19-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Gnome based FTP Client"
+SRC_URI="http://www.gftp.org/${P}.tar.bz2"
+HOMEPAGE="http://www.gftp.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk libressl ssl"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-devel/gettext
+ sys-libs/ncurses:0=
+ sys-libs/readline:0
+ gtk? ( x11-libs/gtk+:2 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= ) )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Fix SIGSEGV for gftp_expand_path function
+ "${FILESDIR}/${P}-${PN}-expand-path-sigsegv.patch"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=740785
+ "${FILESDIR}/${P}-desktop.patch"
+)
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gtk gtkport) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ gnome2_src_install
+ dodoc docs/USERS-GUIDE
+ rm -f "${ED}"usr/share/gftp/COPYING
+}