summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-11-08 10:42:11 +0800
committerYixun Lan <dlan@gentoo.org>2024-11-08 11:02:56 +0800
commit6bbd66e5032cea1462dfbec80a7c46bbfabd7606 (patch)
tree435b6f4b6d77b7253b027c9b68a1833a79df0bd6 /net-ftp
parentdev-libs/libfilezilla: add 0.49.0 (diff)
downloadgentoo-6bbd66e5032cea1462dfbec80a7c46bbfabd7606.tar.gz
gentoo-6bbd66e5032cea1462dfbec80a7c46bbfabd7606.tar.bz2
gentoo-6bbd66e5032cea1462dfbec80a7c46bbfabd7606.zip
net-ftp/filezilla: add 3.68.1
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.68.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index 63646bce4f47..77d09b3a42be 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -1,2 +1,3 @@
DIST FileZilla_3.67.0_src.tar.xz 4058264 BLAKE2B 28799d60188ed94bc80143ccabf073eced4caa9960daa2b8d7f617252355735647fe4b3776ee38eb179fdb2667fd05536a89b6c17b25d056c72e565585ddef98 SHA512 b2d4cd45f2ed7e70fbb11500a42fe0d0e51919831a35bcfb439455d03af8eb744eb25d7f7b6ea9a94c424065e4d071d9706fcf46019da829d1318c099ab8108c
DIST FileZilla_3.67.1_src.tar.xz 4065540 BLAKE2B e3e286da6c8777df4fe3a66f440b1e0e2c9f99777fbcf75c709e1290b37df6ed2db7e5e9fd73403bec0733a04a04989351005b7455a5d2620f213b1d18c20f36 SHA512 630820a0c67ee8b1d48a8ff4193e066d35bbf9048526c91b8804d786defc28a635dac252b298de518b506506607abd96ce35c455c21a50503844a57c47ea78e7
+DIST FileZilla_3.68.1_src.tar.xz 4105072 BLAKE2B d0e65adae49e68204de035c70d6abea3313dae6f0f3c2d55bfee2b63fb86979b54108d88c36b2c87e978c7caa3268518902966cdd7f9c4b7564ec93fb5f6fcd6 SHA512 b8cd7a524c13753118f8c48b0f4063a3459d119efe2bfd11c0ca40e35573885e2cae85007e7958d6eec4bcbdd557eba76bcaa72a922d3bd4f85385fc06d0df6b
diff --git a/net-ftp/filezilla/filezilla-3.68.1.ebuild b/net-ftp/filezilla/filezilla-3.68.1.ebuild
new file mode 100644
index 000000000000..ca0e779d039d
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.68.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV="${PV/_/-}"
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+# Broken URL behind CDN
+SRC_URI="https://dev.gentoo.org/~dlan/distfiles/${PN}/${MY_P}_src.tar.xz"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="cpu_flags_x86_sse2 dbus nls test"
+RESTRICT="!test? ( test )"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND="
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/boost-1.76.0:=
+ >=dev-libs/libfilezilla-0.49.0:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cppunit-1.13.0 )"
+BDEPEND="
+ virtual/pkgconfig
+ >=dev-build/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+ "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
+ "${FILESDIR}"/${PN}-3.52.2-slibtool.patch
+ "${FILESDIR}"/${PN}-3.60.1-desktop.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if use x86 && ! use cpu_flags_x86_sse2; then
+ append-cppflags -D_FORCE_SOFTWARE_SHA
+ fi
+ setup-wxwidgets
+
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}