summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-08-30 10:38:09 -0400
committerMike Pagano <mpagano@gentoo.org>2024-08-30 10:38:09 -0400
commit4af6e9991a3b5089c3575afd2ddc011c1abcdfa6 (patch)
tree1531e454683495a35c490f4bc5b4e5de826630ba /net-firewall
parentmedia-libs/vigra: Stabilize 1.11.2_p20240505 x86, #938737 (diff)
downloadgentoo-4af6e9991a3b5089c3575afd2ddc011c1abcdfa6.tar.gz
gentoo-4af6e9991a3b5089c3575afd2ddc011c1abcdfa6.tar.bz2
gentoo-4af6e9991a3b5089c3575afd2ddc011c1abcdfa6.zip
net-firewall/ipset: Fix implicit declaration of function basename
Closes: https://bugs.gentoo.org/936926 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipset/files/ipset-7.22-fix-building-on-musl.patch10
-rw-r--r--net-firewall/ipset/ipset-7.22-r2.ebuild121
2 files changed, 131 insertions, 0 deletions
diff --git a/net-firewall/ipset/files/ipset-7.22-fix-building-on-musl.patch b/net-firewall/ipset/files/ipset-7.22-fix-building-on-musl.patch
new file mode 100644
index 000000000000..7a77aa952869
--- /dev/null
+++ b/net-firewall/ipset/files/ipset-7.22-fix-building-on-musl.patch
@@ -0,0 +1,10 @@
+--- a/src/ipset.c 2024-08-30 14:21:19.201863069 +0000
++++ b/src/ipset.c 2024-08-30 14:21:52.525571560 +0000
+@@ -15,6 +15,7 @@
+ #include <config.h>
+ #include <libipset/ipset.h> /* ipset library */
+ #include <libipset/xlate.h> /* translate to nftables */
++#include <libgen.h>
+
+ int
+ main(int argc, char *argv[])
diff --git a/net-firewall/ipset/ipset-7.22-r2.ebuild b/net-firewall/ipset/ipset-7.22-r2.ebuild
new file mode 100644
index 000000000000..5024380e1283
--- /dev/null
+++ b/net-firewall/ipset/ipset-7.22-r2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MODULES_OPTIONAL_IUSE=modules
+inherit autotools bash-completion-r1 linux-mod-r1 systemd
+
+DESCRIPTION="IPset tool for iptables, successor to ippool"
+HOMEPAGE="https://ipset.netfilter.org/ https://git.netfilter.org/ipset/"
+SRC_URI="https://ipset.netfilter.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ net-firewall/iptables
+ net-libs/libmnl:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog INSTALL README UPGRADE )
+
+# configurable from outside, e.g. /etc/portage/make.conf
+IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-bash-completion.patch"
+ "${FILESDIR}/${P}-asan-buffer-overflow.patch"
+ "${FILESDIR}/${P}-argv-bounds.patch"
+ "${FILESDIR}/${P}-fix-building-on-musl.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_setup() {
+ get_version
+ CONFIG_CHECK="NETFILTER"
+ ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
+ CONFIG_CHECK+=" NETFILTER_NETLINK"
+ ERROR_NETFILTER_NETLINK="ipset requires NETFILTER_NETLINK support in your kernel."
+ # It does still build without NET_NS, but it may be needed in future.
+ #CONFIG_CHECK="${CONFIG_CHECK} NET_NS"
+ #ERROR_NET_NS="ipset requires NET_NS (network namespace) support in your kernel."
+ CONFIG_CHECK+=" !PAX_CONSTIFY_PLUGIN"
+ ERROR_PAX_CONSTIFY_PLUGIN="ipset contains constified variables (#614896)"
+
+ build_modules=0
+ if use modules; then
+ if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
+ if linux_chkconfig_present "IP_NF_SET" || \
+ linux_chkconfig_present "IP_SET"; then #274577
+ eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
+ eerror "Please either build ipset with modules USE flag disabled"
+ eerror "or rebuild kernel without IP_SET support and make sure"
+ eerror "there is NO kernel ip_set* modules in /lib/modules/<your_kernel>/... ."
+ die "USE=modules and in-kernel ipset support detected."
+ else
+ einfo "Modular kernel detected. Gonna build kernel modules..."
+ build_modules=1
+ fi
+ else
+ eerror "Nonmodular kernel detected, but USE=modules. Either build"
+ eerror "modular kernel (without IP_SET) or disable USE=modules"
+ die "Nonmodular kernel detected, will not build kernel modules"
+ fi
+ fi
+
+ [[ ${build_modules} -eq 1 ]] && linux-mod-r1_pkg_setup
+}
+
+src_configure() {
+ export bashcompdir="$(get_bashcompdir)"
+
+ econf \
+ --enable-bashcompl \
+ $(use_with modules kmod) \
+ --with-maxsets=${IP_NF_SET_MAX} \
+ --with-ksource="${KV_DIR}" \
+ --with-kbuild="${KV_OUT_DIR}"
+}
+
+src_compile() {
+ einfo "Building userspace"
+
+ local modlist=( xt_set=kernel/net/netfilter/ipset/:"${S}":kernel/net/netfilter/:
+ em_ipset=kernel/net/sched:"${S}":kernel/net/sched/:modules )
+
+ for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,mac,mark,port{,ip,net}},mac,net{,port{,net},iface,net}},_list_set}; do
+ modlist+=( ${i}=kernel/net/netfilter/ipset/:"${S}":kernel/net/netfilter/ipset )
+ done
+
+ emake
+
+ if [[ ${build_modules} -eq 1 ]]; then
+ einfo "Building kernel modules"
+ linux-mod-r1_src_compile
+ fi
+}
+
+src_install() {
+ einfo "Installing userspace"
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/ipset.initd-r7 ${PN}
+ newconfd "${FILESDIR}"/ipset.confd-r1 ${PN}
+ systemd_newunit "${FILESDIR}"/ipset.systemd-r1 ${PN}.service
+ keepdir /var/lib/ipset
+
+ if [[ ${build_modules} -eq 1 ]]; then
+ einfo "Installing kernel modules"
+ linux-mod-r1_src_install
+ fi
+}