summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:56:32 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:02 +0100
commitbd2061f5fbd1f1f5490201fe04d965396750ca24 (patch)
treeb2a8896a6579a1124e9415c9e2f819d8b2a33892 /net-dns
parentnet-dns/getdns: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-bd2061f5fbd1f1f5490201fe04d965396750ca24.tar.gz
gentoo-bd2061f5fbd1f1f5490201fe04d965396750ca24.tar.bz2
gentoo-bd2061f5fbd1f1f5490201fe04d965396750ca24.zip
net-dns/pdnsd: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild11
1 files changed, 1 insertions, 10 deletions
diff --git a/net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild b/net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild
index 8769b15cfd58..209fff4708a5 100644
--- a/net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild
+++ b/net-dns/pdnsd/pdnsd-1.2.9a-r2.ebuild
@@ -94,14 +94,5 @@ pkg_postinst() {
elog ""
elog "Sample config file in /etc/pdnsd/pdnsd.conf.sample"
- # The tmpfiles.d configuration does not come into effect before the
- # next reboot so create the cachedir now.
- local cachedir="${EPREFIX}/var/cache/pdnsd"
- if [[ ! -d "${cachedir}" ]] ; then
- mkdir "${cachedir}" || eerror "Failed to create cache"
- fi
- chown pdnsd:pdnsd "${cachedir}" \
- || eerror "Failed to set ownership for cachedir"
- chmod 0750 "${cachedir}" \
- || eerror "Failed to set permissions for cachedir"
+ tmpfiles_process pdnsd.conf
}