summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2023-04-02 21:41:10 +0200
committerAndreas Schuerch <nativemad@gentoo.org>2023-04-02 21:43:14 +0200
commit5e90ac1c6a2d469f1d4863dc1baf81630e63e088 (patch)
treed40d3bbe4ce3dfae61cda8c07db715587bceeef5 /net-dns
parentnet-print/cups: Stabilize 2.4.2-r7 amd64, #899280 (diff)
downloadgentoo-5e90ac1c6a2d469f1d4863dc1baf81630e63e088.tar.gz
gentoo-5e90ac1c6a2d469f1d4863dc1baf81630e63e088.tar.bz2
gentoo-5e90ac1c6a2d469f1d4863dc1baf81630e63e088.zip
net-dns/dnsdist: add 1.8.0
Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsdist/Manifest1
-rw-r--r--net-dns/dnsdist/dnsdist-1.8.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-dns/dnsdist/Manifest b/net-dns/dnsdist/Manifest
index b7764a5a1b3a..86ad1c28743e 100644
--- a/net-dns/dnsdist/Manifest
+++ b/net-dns/dnsdist/Manifest
@@ -1,3 +1,4 @@
DIST dnsdist-1.5.1.tar.bz2 1068061 BLAKE2B 1c0fdd181b62b96fcd433581715cea9dc204fcdd2f65efd26a5293cc9c17d904e0937b51ba33d2dc01ecc8044f491ba2c6c8720c0816587fa5082da73108783e SHA512 68fe5f55fd081ed80a620933af9f8310be0e21c86ba449a9c557975b5c83f4b64e3002e6032dc002582d081e70e1ec2ff080c5d8389fd46a9896bdafd5a41f9f
DIST dnsdist-1.6.1.tar.bz2 1328069 BLAKE2B a9e9c0cb35ebc2ecd93d7fa0d6d3961b02d711da2df56240335786a5d2e529d4a7e8716f578b6e935edd3bc79dfed767d358b9feaff32dd9cd65993ef0b97b71 SHA512 68e114eeb1a7ae8a4ce52a7de31095c46d0ba8f572676a8ef1e858b97da199c04ec88656c7642160ba07b7db325cc2a49cd91794da8dd2e81a5301d089c34f90
DIST dnsdist-1.7.3.tar.bz2 1379011 BLAKE2B e7d1cb9dba3d3ad1dd696d324697ffac60863112eae83307237639bea339f7ed1c3f320002d3467a44ab38a9ea60ade95fff43645c889d29465760f7f467b996 SHA512 2a39096709db5b41cf3bd21170689bc85ad2cd550896d02ddd85eff7410780ea59d6cf8e08b0a08962ee93b49b7f3228dfa649275453215e23c25098aca40e1a
+DIST dnsdist-1.8.0.tar.bz2 1480500 BLAKE2B 47cfcfe3756cdc4520c1ba1e11b7d60191125ef900ba829ff7437ac2041352b845ab5f7183f53fea9b3aa6f44c5745de3878c2b72f2be048fa57d2c2e9325c0c SHA512 426db3e83729bd2f8a8c8b1c02d719c6618acc0aec09d1f2670c159d441c1cad2fdc85c5ffe919e76d1b1e8e24198bf29133802cb857dfacde2dfed2532001f1
diff --git a/net-dns/dnsdist/dnsdist-1.8.0.ebuild b/net-dns/dnsdist/dnsdist-1.8.0.ebuild
new file mode 100644
index 000000000000..c0ec5088ac0e
--- /dev/null
+++ b/net-dns/dnsdist/dnsdist-1.8.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="A highly DNS-, DoS- and abuse-aware loadbalancer"
+HOMEPAGE="https://dnsdist.org"
+
+SRC_URI="https://downloads.powerdns.com/releases/${P}.tar.bz2"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dnscrypt dnstap doh gnutls +lmdb regex remote-logging snmp +ssl systemd test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ dnscrypt? ( ssl )
+ gnutls? ( ssl )
+ doh? ( ssl !gnutls )"
+
+RDEPEND="acct-group/dnsdist
+ acct-user/dnsdist
+ dev-libs/boost:=
+ dev-libs/libedit:=
+ dev-libs/libsodium:=
+ >=dev-libs/protobuf-3:=
+ dnstap? ( dev-libs/fstrm:= )
+ doh? ( www-servers/h2o:=[libh2o] )
+ lmdb? ( dev-db/lmdb:= )
+ regex? ( dev-libs/re2:= )
+ snmp? ( net-analyzer/net-snmp:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+ systemd? ( sys-apps/systemd:0= )
+ ${LUA_DEPS}
+ net-libs/nghttp2
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ # bug #822855
+ append-lfs-flags
+
+ econf \
+ --sysconfdir=/etc/dnsdist \
+ --with-lua="${ELUA}" \
+ $(use_enable doh dns-over-https) \
+ $(use_enable dnscrypt) \
+ $(use_enable dnstap) \
+ $(use_with lmdb ) \
+ $(use_with regex re2) \
+ $(use_with snmp net-snmp) \
+ $(use ssl && { echo "--enable-dns-over-tls" && use_with gnutls && use_with !gnutls libssl;} || echo "--without-gnutls --without-libssl") \
+ $(use_enable systemd) \
+ $(use_enable test unit-tests)
+ sed 's/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl$libdir'\''/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl\/$libdir'\''/g' \
+ -i "${S}/configure"
+}
+
+src_install() {
+ default
+
+ insinto /etc/dnsdist
+ doins "${FILESDIR}"/dnsdist.conf.example
+
+ newconfd "${FILESDIR}"/dnsdist.confd ${PN}
+ newinitd "${FILESDIR}"/dnsdist.initd ${PN}
+}
+
+pkg_postinst() {
+ elog "dnsdist provides multiple instances support. You can create more instances"
+ elog "by symlinking the dnsdist init script to another name."
+ elog
+ elog "The name must be in the format dnsdist.<suffix> and dnsdist will use the"
+ elog "/etc/dnsdist/dnsdist-<suffix>.conf configuration file instead of the default."
+}