summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-08 17:22:50 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-08 17:22:50 +0100
commitf17e3be4dd1e795353e8cbfe676e62a901cbce9c (patch)
tree1b38c2393a7b4e1fbb358ebafeb420ef0191b6b9 /net-dns/unbound
parentnet-dialup/rp-pppoe: [QA] Fix UnnecessarySlashStrip (diff)
downloadgentoo-f17e3be4dd1e795353e8cbfe676e62a901cbce9c.tar.gz
gentoo-f17e3be4dd1e795353e8cbfe676e62a901cbce9c.tar.bz2
gentoo-f17e3be4dd1e795353e8cbfe676e62a901cbce9c.zip
net-dns/unbound: [QA] Fix UnnecessarySlashStrip
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-dns/unbound')
-rw-r--r--net-dns/unbound/unbound-1.9.4.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/net-dns/unbound/unbound-1.9.4.ebuild b/net-dns/unbound/unbound-1.9.4.ebuild
index 840b23595d5c..e1f4177a4b64 100644
--- a/net-dns/unbound/unbound-1.9.4.ebuild
+++ b/net-dns/unbound/unbound-1.9.4.ebuild
@@ -110,12 +110,12 @@ multilib_src_configure() {
--enable-ipsecmod \
--enable-tfo-client \
--enable-tfo-server \
- --with-libevent="${EPREFIX%/}"/usr \
- $(multilib_native_usex redis --with-libhiredis="${EPREFIX%/}/usr" --without-libhiredis) \
- --with-pidfile="${EPREFIX%/}"/run/unbound.pid \
- --with-rootkey-file="${EPREFIX%/}"/etc/dnssec/root-anchors.txt \
- --with-ssl="${EPREFIX%/}"/usr \
- --with-libexpat="${EPREFIX%/}"/usr
+ --with-libevent="${EPREFIX}"/usr \
+ $(multilib_native_usex redis --with-libhiredis="${EPREFIX}/usr" --without-libhiredis) \
+ --with-pidfile="${EPREFIX}"/run/unbound.pid \
+ --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
+ --with-ssl="${EPREFIX}"/usr \
+ --with-libexpat="${EPREFIX}"/usr
# http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
# $(use_enable debug lock-checks) \
@@ -151,7 +151,7 @@ multilib_src_install_all() {
# ... and point example config to it
sed -i \
-e '/# auto-trust-anchor-file:/s,/etc/dnssec/root-anchors.txt,/etc/unbound/var/root-anchors.txt,' \
- "${ED%/}/etc/unbound/unbound.conf" || \
+ "${ED}/etc/unbound/unbound.conf" || \
die
# Used to store cache data
@@ -167,16 +167,16 @@ multilib_src_install_all() {
pkg_postinst() {
# make var/ writable by unbound
- if [[ -d "${EROOT%/}/etc/unbound/var" ]]; then
- chown --no-dereference --from=root unbound: "${EROOT%/}/etc/unbound/var"
+ if [[ -d "${EROOT}/etc/unbound/var" ]]; then
+ chown --no-dereference --from=root unbound: "${EROOT}/etc/unbound/var"
fi
einfo ""
einfo "If you want unbound to automatically update the root-anchor file for DNSSEC validation"
- einfo "set 'auto-trust-anchor-file: ${EROOT%/}/etc/unbound/var/root-anchors.txt' in ${EROOT%/}/etc/unbound/unbound.conf"
+ einfo "set 'auto-trust-anchor-file: ${EROOT}/etc/unbound/var/root-anchors.txt' in ${EROOT}/etc/unbound/unbound.conf"
einfo "and run"
einfo ""
- einfo " su -s /bin/sh -c '${EROOT%/}/usr/sbin/unbound-anchor -a ${EROOT%/}/etc/unbound/var/root-anchors.txt' unbound"
+ einfo " su -s /bin/sh -c '${EROOT}/usr/sbin/unbound-anchor -a ${EROOT}/etc/unbound/var/root-anchors.txt' unbound"
einfo ""
einfo "as root to create it initially before starting unbound for the first time after enabling this."
einfo ""