summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2023-09-25 12:35:56 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-10-04 09:44:22 +0200
commita330a9d6c663c8af6c9019c1f2fad0073b908eb9 (patch)
treeec56cf3b9ef8752e17db29033f05f2bde215b9e9 /net-analyzer
parentnet-analyzer/gsa: drop 22.5.0, 22.5.3 (diff)
downloadgentoo-a330a9d6c663c8af6c9019c1f2fad0073b908eb9.tar.gz
gentoo-a330a9d6c663c8af6c9019c1f2fad0073b908eb9.tar.bz2
gentoo-a330a9d6c663c8af6c9019c1f2fad0073b908eb9.zip
net-analyzer/gsad: add 22.6.0, drop 22.5.1-r2, fix openrc init script
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33051 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/gsad/Manifest2
-rw-r--r--net-analyzer/gsad/files/gsad-22.init19
-rw-r--r--net-analyzer/gsad/gsad-22.6.0.ebuild (renamed from net-analyzer/gsad/gsad-22.5.1-r2.ebuild)6
3 files changed, 15 insertions, 12 deletions
diff --git a/net-analyzer/gsad/Manifest b/net-analyzer/gsad/Manifest
index d9dbb81e7833..598c9490f54c 100644
--- a/net-analyzer/gsad/Manifest
+++ b/net-analyzer/gsad/Manifest
@@ -1,2 +1,2 @@
DIST gsad-21.4.4.tar.gz 220618 BLAKE2B 276164ce1e03a6ed211d3bdf24c7f9b5ac832c07891b34b467f61ec02c5670d5368ea3219b3cc445e4ef83fef0aee7375c89ce8008746ea7e08abf50da8fb9fd SHA512 092c8187754b3f0503e4ae6fd9c41dbd6917264668a5f8f831d40e88c7b8db6772acd354db62ac66b4af13b7c27e78516d4975f5bfede0d28001007a46c39f75
-DIST gsad-22.5.1.tar.gz 223290 BLAKE2B 24530f085c644895d5153929038d040fbcb0626b4b2df0ce3966d96fc8c756fbb2b78540b2a57affab2f2eb97cf868f09b7ac863f9a314cb1f74a829fbea48cc SHA512 52ec1377d57d90f64e949472f5f6d1f94e9cdce86d7a807451ed9f01ff36e392606d725461e416246b9e706f00aa536cbc5672fb977695b20d0c5957b67447aa
+DIST gsad-22.6.0.tar.gz 223879 BLAKE2B 7e1d55052ef255d92cf8fd3c32f5490e192dc5635e4d9be8804ff0a72677add70081d0fff882673ea7dfc70e97acfb8012e683fefa9e6307661a39697a89eaea SHA512 39393d9190281065978d7fdb4745daa5faa066b6cc97a81b442f989eb8d466be05d6af39585ea4649555b88db819a6ced909b2e3a8e640df4c500e37bb26f05f
diff --git a/net-analyzer/gsad/files/gsad-22.init b/net-analyzer/gsad/files/gsad-22.init
index f416990b19a4..aae78b2e1ab8 100644
--- a/net-analyzer/gsad/files/gsad-22.init
+++ b/net-analyzer/gsad/files/gsad-22.init
@@ -3,20 +3,29 @@
# Distributed under the terms of the GNU General Public License v2
: ${GSAD_USER:=gvm}
-: ${GSAD_GROUP:=$(id -ng ${GSAD_USER})}
: ${GSAD_TIMEOUT:=30}
+: ${GSAD_PIDFILE:="/run/gsad/gsad.pid"}
name="Greenbone Security Assistant (GSA)"
command="/usr/bin/gsad"
-command_user="${GSAD_USER}:${GSAD_GROUP}"
-command_args="${GSAD_OPTIONS} ${GSAD_LISTEN_ADDRESS} ${GSAD_LISTEN_PORT} ${GVMD_LISTEN_ADDRESS} ${GVMD_LISTEN_PORT} ${GSAD_GNUTLS_PRIORITIES}"
+command_args="${GSAD_OPTIONS} ${GSAD_LISTEN_ADDRESS} ${GSAD_LISTEN_PORT} ${GVMD_LISTEN_ADDRESS} ${GVMD_LISTEN_PORT} ${GSAD_GNUTLS_PRIORITIES} --drop-privileges=${GSAD_USER}"
retry="${GSAD_TIMEOUT}"
depend() {
after bootmisc
- need localmount net gvmd
+ need localmount net
+ want gvmd
}
start_pre() {
- checkpath -d --owner ${GSAD_USER} /var/run/gsad
+ checkpath -d --mode 0755 --owner root /run/gsad
}
+
+stop_post() {
+ if [ -f "${GSAD_PIDFILE}" ]; then
+ ebegin "Removing PID file"
+ rm --force "${GSAD_PIDFILE}"
+ eend $?
+ fi
+}
+
diff --git a/net-analyzer/gsad/gsad-22.5.1-r2.ebuild b/net-analyzer/gsad/gsad-22.6.0.ebuild
index 7055f5038584..f8fe3475bfda 100644
--- a/net-analyzer/gsad/gsad-22.5.1-r2.ebuild
+++ b/net-analyzer/gsad/gsad-22.6.0.ebuild
@@ -57,12 +57,6 @@ src_prepare() {
done
fi
fi
-
- # Do not install the empty /run/gsad run dir. https://github.com/greenbone/gsad/pull/54
- sed -i "/^install.*GSAD_RUN_DIR/d" CMakeLists.txt || die
-
- # Drop Group= directive. https://github.com/greenbone/gsad/pull/55
- sed -i "/^Group=/d" config/gsad.service.in || die
}
src_configure() {