summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-18 09:50:20 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-05-25 01:35:13 +0200
commit8a99f51e8092f5dbd7ac69d8a52297b7c70d7c7b (patch)
tree14d7005acd326fdd9a737564abb91db028577363 /net-analyzer
parentnet-analyzer/thc-ipv6: EAPI8 bump (diff)
downloadgentoo-8a99f51e8092f5dbd7ac69d8a52297b7c70d7c7b.tar.gz
gentoo-8a99f51e8092f5dbd7ac69d8a52297b7c70d7c7b.tar.bz2
gentoo-8a99f51e8092f5dbd7ac69d8a52297b7c70d7c7b.zip
net-analyzer/thc-ipv6: add 3.8
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36728 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/thc-ipv6/Manifest1
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-3.8.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/thc-ipv6/Manifest b/net-analyzer/thc-ipv6/Manifest
index 2d19bb77271b..689dcd41d86b 100644
--- a/net-analyzer/thc-ipv6/Manifest
+++ b/net-analyzer/thc-ipv6/Manifest
@@ -1 +1,2 @@
DIST thc-ipv6-3.2.tar.gz 1595453 BLAKE2B f1bb1cdc31f4cf4d067b39997ca3cc2d6d8c15e7a8c585c7c494f03e229fccbcd65677e382a65f0e650d79278f5ede89173db1cdf313ade7c48dff1566856afa SHA512 648db4618ebb83572e2e318cdbb284fe96a86adf335f7dd9b26fd010c76d12e9137ed7367207c66c93c1961c868d3917d706db9f597289ac47ea3f9b83c03441
+DIST thc-ipv6-3.8.tar.gz 705821 BLAKE2B a2b57e13a47aacf1205b87c6f30cbea2468f47aad7232b92190995bf7ffbb64904d4d0cd187657c12584cd41e66cb0e4db3b6d826d41287aa020398de8ca7f91 SHA512 e3d8c80e1383e4825a3db717192446754d01e8e3098deb3075df0d60f79f014cefbd62a16c04379539e42c74513aa0f8bb97fc59221e100563aa7c6398a8b893
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-3.8.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-3.8.ebuild
new file mode 100644
index 000000000000..53f532b0d072
--- /dev/null
+++ b/net-analyzer/thc-ipv6/thc-ipv6-3.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
+HOMEPAGE="https://github.com/vanhauser-thc/thc-ipv6"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
+ EGIT_BRANCH=master
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vanhauser-thc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="AGPL-3 openssl"
+SLOT="0"
+IUSE="ssl"
+
+DEPEND="
+ net-libs/libnetfilter_queue
+ net-libs/libpcap
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e '/^CFLAGS+=-g/s,CFLAGS+=,CFLAGS?=,' \
+ -i Makefile || die
+
+ if ! use ssl; then
+ sed -e '/^HAVE_SSL/s:^:#:' \
+ -i Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" STRIP="true" install
+ dodoc CHANGES HOWTO-INJECT README
+}