summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/tleds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/tleds')
-rw-r--r--net-analyzer/tleds/Manifest2
-rw-r--r--net-analyzer/tleds/files/tleds-1.05_beta11-gentoo.patch53
-rw-r--r--net-analyzer/tleds/files/tleds.conf.d7
-rw-r--r--net-analyzer/tleds/files/tleds.init.d22
-rw-r--r--net-analyzer/tleds/metadata.xml5
-rw-r--r--net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild45
6 files changed, 134 insertions, 0 deletions
diff --git a/net-analyzer/tleds/Manifest b/net-analyzer/tleds/Manifest
new file mode 100644
index 000000000000..774679913cc2
--- /dev/null
+++ b/net-analyzer/tleds/Manifest
@@ -0,0 +1,2 @@
+DIST tleds-1.05beta10.tgz 28640 SHA256 6d139bdaf9ebc0759954d4a5ad061c87c1a3d9c2d9b674886ce93879e803b47b SHA512 661ac8749c85ce20ffc2851a62ee7691e6cddf3700f4a388465bbdf2faa117d8bd6e316541bc5e2fa81d18f74d47bdd78010b8490124f39b6a1c085c4d345d3a WHIRLPOOL 23d8c6d54e2bbae44da0c49b35d6519f96f1fb85afbbf1fa657f0f00fa08538602a6b934ed7d47b382ba1b33479303928823d9575e45970f772a3580da91a340
+DIST tleds-1.05beta11.patch.bz2 5540 SHA256 a7542930e7e5cf537dc08cbbe70808f57db18c110ae998fc5edef206537bbeb5 SHA512 8c6e5b28e055fd546af97244230560cb22d7def65a8c16e0257d9f41b789394f744a056a95bf7d9f6fb9dcf8ab0bcacfc8fce7c91d0e8be798ae2af4817ce1a4 WHIRLPOOL 5046743da828cb9fd417125ff76d9c4f1bef18e452b800cf6892feb480c5c32ad467076d682dbc242d80aed9ac2f6346c9c88fa868991fce244de361df7a5179
diff --git a/net-analyzer/tleds/files/tleds-1.05_beta11-gentoo.patch b/net-analyzer/tleds/files/tleds-1.05_beta11-gentoo.patch
new file mode 100644
index 000000000000..96e6e3d21d45
--- /dev/null
+++ b/net-analyzer/tleds/files/tleds-1.05_beta11-gentoo.patch
@@ -0,0 +1,53 @@
+--- a/Changes
++++ b/Changes
+@@ -1,4 +1,7 @@
+ VERSION DATE WHAT WAS FIXED OR WHAT WAS/IS NEW
++
++ 2 Jul 2002 2.4/2.5 patch
++
+ 1.05b11 7 Mar 2002 Support for multiple interfaces
+
+ 1.05b7 2 Apr 1998 Keeps LEDs deattached also after VT is reset if run
+--- a/tleds.c
++++ b/tleds.c
+@@ -43,16 +43,6 @@
+ #define VERSION "1.05beta11"
+ #define MYNAME "tleds"
+
+-/* Supported kernel version */
+-/* If you want to compile for Linux 2.1.x add -DKERNEL2_1 to gcc options. */
+-/* Currently kernel v2.1.97 is "tested", older v2.1.x kernels may not work */
+-#ifdef KERNEL2_1
+-#undef KERNEL2_1
+-#define KERNEL2_0 0
+-#else
+-#define KERNEL2_0 1
+-#endif
+-
+ /* If you don't want X stuff. */
+ #ifdef NO_X_SUPPORT
+ #define REMOVE_X_CODE 1
+--- a/Makefile
++++ b/Makefile
+@@ -9,18 +9,18 @@
+
+ # For 2.1.x kernels, you have to include -DKERNEL2_1 option for gcc
+
+-GCCOPTS = -D_GNU_SOURCE -O3 -Wall
++GCCOPTS = -D_GNU_SOURCE $(CFLAGS) $(LDFLAGS) -Wall
+
+ # The first one is if you want to include X code
+ xtleds: tleds.c Makefile
+ # Making xtleds
+- gcc $(GCCOPTS) -o xtleds tleds.c -I /usr/X11R6/include/ -L /usr/X11R6/lib/ -lX11
++ $(CC) $(GCCOPTS) -o xtleds tleds.c -I /usr/include/ -L /usr/lib/ -lX11
+
+ # This second one works only when started in VT. Check the REMOVE_X_CODE
+ # in the source code.
+ tleds: tleds.c Makefile
+ # Making tleds
+- gcc -DNO_X_SUPPORT $(GCCOPTS) -o tleds tleds.c
++ $(CC) -DNO_X_SUPPORT $(GCCOPTS) -o tleds tleds.c
+
+ help:
+ # make help - this.
diff --git a/net-analyzer/tleds/files/tleds.conf.d b/net-analyzer/tleds/files/tleds.conf.d
new file mode 100644
index 000000000000..523995204e24
--- /dev/null
+++ b/net-analyzer/tleds/files/tleds.conf.d
@@ -0,0 +1,7 @@
+# Copyright 2003-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IFACE="eth0"
+DELAY=50
+EXTRA_OPTS=""
diff --git a/net-analyzer/tleds/files/tleds.init.d b/net-analyzer/tleds/files/tleds.init.d
new file mode 100644
index 000000000000..9470c2a5b0e0
--- /dev/null
+++ b/net-analyzer/tleds/files/tleds.init.d
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting tleds"
+ /usr/sbin/tleds -d ${DELAY} ${IFACE} ${EXTRA_OPTS} > /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tleds"
+ /usr/sbin/tleds -k > /dev/null
+ eend $?
+}
+
diff --git a/net-analyzer/tleds/metadata.xml b/net-analyzer/tleds/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/tleds/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild b/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild
new file mode 100644
index 000000000000..eb8d01543285
--- /dev/null
+++ b/net-analyzer/tleds/tleds-1.05_beta11-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P/eta11/}"
+DESCRIPTION="Blinks keyboard LEDs indicating outgoing and incoming network packets on selected network interface"
+HOMEPAGE="http://www.hut.fi/~jlohikos/tleds_orig.html"
+SRC_URI="
+ http://www.hut.fi/~jlohikos/tleds/public/${MY_P/11/10}.tgz
+ http://www.hut.fi/~jlohikos/tleds/public/${MY_P}.patch.bz2
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # code patches
+ epatch \
+ "${WORKDIR}"/${MY_P}.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) $(usex X all tleds)
+}
+
+src_install() {
+ dosbin tleds
+ use X && dosbin xtleds
+
+ doman tleds.1
+ dodoc README Changes
+
+ newinitd "${FILESDIR}"/tleds.init.d tleds
+ newconfd "${FILESDIR}"/tleds.conf.d tleds
+}