summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-18 09:17:35 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-05-25 01:35:13 +0200
commitf9a95deafded1b1d62dfc219e108bd9e28b2d7f8 (patch)
tree347e266035cb5f1736d69ecc5fc6c261e14f2003 /net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
parentx11-misc/set_opacity: remove old (diff)
downloadgentoo-f9a95deafded1b1d62dfc219e108bd9e28b2d7f8.tar.gz
gentoo-f9a95deafded1b1d62dfc219e108bd9e28b2d7f8.tar.bz2
gentoo-f9a95deafded1b1d62dfc219e108bd9e28b2d7f8.zip
net-analyzer/thc-ipv6: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild')
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
index b5817554f26c..d1e5d1c4b80d 100644
--- a/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
+++ b/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Complete tool set to attack the inherent protocol weaknesses of IPV6 and ICMP6"
-HOMEPAGE="https://www.thc.org/thc-ipv6/"
+HOMEPAGE="https://github.com/vanhauser-thc/thc-ipv6"
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-ipv6.git"
@@ -28,10 +28,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-3.2-stdint.patch" )
-
src_prepare() {
- sed -e '/^CFLAGS=/s,CFLAGS=,CFLAGS?=,' \
+ sed -e '/^CFLAGS+=-g/s,CFLAGS+=,CFLAGS?=,' \
-i Makefile || die
if ! use ssl; then
@@ -48,5 +46,5 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" PREFIX="/usr" STRIP="true" install
- dodoc CHANGES HOWTO-INJECT README
+ dodoc CHANGES HOWTO-INJECT README.md
}