summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-13 18:21:32 +0000
committerSam James <sam@gentoo.org>2024-11-13 18:25:45 +0000
commitc0b06d10cdc250d0ed2c2661235d239311e11600 (patch)
treec8316433f05027c6bb51bc9c7659d5886e7a556d /net-analyzer/sniffit
parentdev-libs/libclc: Add 20.0.0_pre20241113 snapshot (diff)
downloadgentoo-c0b06d10cdc250d0ed2c2661235d239311e11600.tar.gz
gentoo-c0b06d10cdc250d0ed2c2661235d239311e11600.tar.bz2
gentoo-c0b06d10cdc250d0ed2c2661235d239311e11600.zip
net-analyzer/sniffit: add 0.6_p20240924
Also, add -std=gnu89. I started fixing remaining issues after the ones already fixed in the last release + git but there's way too many others. Closes: https://bugs.gentoo.org/861236 Closes: https://bugs.gentoo.org/877295 Cloess: https://bugs.gentoo.org/919192 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/sniffit')
-rw-r--r--net-analyzer/sniffit/Manifest1
-rw-r--r--net-analyzer/sniffit/files/sniffit-0.6-tinfo.patch12
-rw-r--r--net-analyzer/sniffit/sniffit-0.6_p20240924.ebuild44
3 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/sniffit/Manifest b/net-analyzer/sniffit/Manifest
index 1e4cd2eaede8..605011094631 100644
--- a/net-analyzer/sniffit/Manifest
+++ b/net-analyzer/sniffit/Manifest
@@ -1 +1,2 @@
DIST sniffit-0.5.tar.gz 60074 BLAKE2B 55d2a65da3801cab4e612a8d1a1770c00abfa44555779ee29dc7358d9636e0b2a3f1e291bc64234588089967510bff99f5a9831d8acc01dacb080d7341081372 SHA512 cf6f4a1d396d47e0fa51cb527e8f64cc4f9af5f83121728ce6cbfb6a11509899e52a6c01f0dd20b0d3b92a567991390d9a616151c9496d4f2d764608ef3542bc
+DIST sniffit-0.6_p20240924.tar.gz 59838 BLAKE2B 4cb051e6ec3682652c40dff65238887c8bc29211acaf5934295e0d5393de1e7a7ebb0931ac0506eeb160066f427bd4081d7a82c9f993e1d6caddbe30e8bbf0ef SHA512 b6f7138051fbd13446d77eedbd1ba25f0fbfc098bbebbc27afc3218840713b633c6a7dafc6504e7cb77252c364cc5c49855ac788c1211830042efec01daadcb7
diff --git a/net-analyzer/sniffit/files/sniffit-0.6-tinfo.patch b/net-analyzer/sniffit/files/sniffit-0.6-tinfo.patch
new file mode 100644
index 000000000000..960aaf853013
--- /dev/null
+++ b/net-analyzer/sniffit/files/sniffit-0.6-tinfo.patch
@@ -0,0 +1,12 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,7 +16,8 @@ AC_PROG_CC
+ # not use it because src/sn_config.h does not define INCLUDE_INTERFACE because
+ # other conditions are not met. It would be better to move that logic entirely
+ # to Autoconf and to define (or not) INCLUDE_INTERFACE only here.
+-AC_CHECK_LIB(ncurses, initscr)
++AC_CHECK_LIB(ncurses, initscr, , [AC_MSG_ERROR([Couldn't find libncurses])])
++AC_SEARCH_LIBS(keypad, tinfo, , [AC_MSG_ERROR([Couldn't find libncurses])])
+ AC_CHECK_LIB(pcap, pcap_open_live, , [AC_MSG_ERROR([Couldn't find libpcap])])
+
+ # Checks for header files.
diff --git a/net-analyzer/sniffit/sniffit-0.6_p20240924.ebuild b/net-analyzer/sniffit/sniffit-0.6_p20240924.ebuild
new file mode 100644
index 000000000000..ea532c6a4ed0
--- /dev/null
+++ b/net-analyzer/sniffit/sniffit-0.6_p20240924.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Interactive Packet Sniffer"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/sniffit"
+
+if [[ ${PV} == *_p* ]] ; then
+ SNIFFIT_COMMIT="22ab988654fa113fcc291844029a9b3889e5c84c"
+ SRC_URI="https://github.com/resurrecting-open-source-projects/sniffit/archive/${SNIFFIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${SNIFFIT_COMMIT}
+else
+ SRC_URI="https://github.com/resurrecting-open-source-projects/sniffit/archive/${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${P}
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ net-libs/libpcap
+ >=sys-libs/ncurses-5.2:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # bug #877295
+ append-flags -std=gnu89
+
+ econf
+}