summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2023-09-18 10:25:13 +0000
committerMichael Orlitzky <mjo@gentoo.org>2023-09-23 11:06:50 -0400
commit6225bda18fdbfa4036f815feba794c26df6bf352 (patch)
tree12be33dc4c35cce52b39af0201edfa286b39b7fd /net-analyzer/pnp4nagios
parentnet-analyzer/munin: Stabilize 2.0.73-r3 x86, #914559 (diff)
downloadgentoo-6225bda18fdbfa4036f815feba794c26df6bf352.tar.gz
gentoo-6225bda18fdbfa4036f815feba794c26df6bf352.tar.bz2
gentoo-6225bda18fdbfa4036f815feba794c26df6bf352.zip
net-analyzer/pnp4nagios: change upstream for PHP 8.1+ compatibility
@Consol-Monitoring / Sven Nierlein are well known contributors to the monitoring ecosystem. This fork is compatible with PHP 8.1. The next step will be to explore https://github.com/pnp4nagios/pnp4nagios which may become the unified upstream. Closes: https://bugs.gentoo.org/914270 Closes: https://github.com/gentoo/gentoo/pull/32897 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-analyzer/pnp4nagios')
-rw-r--r--net-analyzer/pnp4nagios/Manifest1
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.6.26_p20230918.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/net-analyzer/pnp4nagios/Manifest b/net-analyzer/pnp4nagios/Manifest
index b4ecca138851..f97b423eb62d 100644
--- a/net-analyzer/pnp4nagios/Manifest
+++ b/net-analyzer/pnp4nagios/Manifest
@@ -1 +1,2 @@
DIST pnp4nagios-0.6.26_p20221106.tar.gz 3029704 BLAKE2B 5866f4dbfef9b1028255eb3e47ac57fa260c1e2caca50fcb1c5ff93a3dc9bee9f14152e3a269ecf12daab59e50e1f4dfcd6513f9ce3dc5da35de50b944c38260 SHA512 cd0c3ad3d4983c43f7e1a100e8a2e6a530b573ca6bed60125c87b22ab33c2486c5ce99c6f52d641cdc7468984925a22a6ee7e1ac330ea2278ec2439acb910d04
+DIST pnp4nagios-0.6.26_p20230918.tar.gz 3036216 BLAKE2B 101b84623bec93cb3c3c2c5f5785a308afeeff6c7a89504ec5e39812be5e0807eaf7dabf720a69e58a3dd7bfd654f124dd26030deab60f5c6e0a31bd665e83e6 SHA512 4b03c5bf3d00339627e22cf14669b21433f926d6e698933833911a40d8b324d5a70dc5187ee5291f48bfcc12e9b51aaba24c8d263d5f25081544f97dce372890
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.6.26_p20230918.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.6.26_p20230918.ebuild
new file mode 100644
index 000000000000..bc1ee5c143cc
--- /dev/null
+++ b/net-analyzer/pnp4nagios/pnp4nagios-0.6.26_p20230918.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A performance data analyzer for nagios"
+HOMEPAGE="http://www.pnp4nagios.org/"
+GH_COMMIT="e52677d3994d35197db68120d7089906a174a3f9"
+SRC_URI="https://github.com/ConSol-Monitoring/pnp/archive/${GH_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/pnp-${GH_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 icinga +nagios"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+REQUIRED_USE="^^ ( icinga nagios )"
+
+# Some things (sync mode, for one) are broken with nagios-4.x, but since
+# nagios-3.x has been end-of-life'd, we don't have much choice here but
+# to accept it.
+DEPEND="net-analyzer/rrdtool[graph,perl]
+ icinga? (
+ acct-group/icinga
+ acct-user/icinga
+ )
+ nagios? (
+ acct-group/nagios
+ acct-user/nagios
+ )"
+
+# A list of modules used in our Apache config file.
+APACHE_MODS="apache2_modules_alias," # "Alias" directive
+APACHE_MODS+="apache2_modules_authz_core," # "Require" directive
+APACHE_MODS+="apache2_modules_rewrite" # "RewriteEngine" and friends
+
+RDEPEND="${DEPEND}
+ dev-lang/php:*[filter,gd,json(+),simplexml,xml,zlib]
+ media-fonts/dejavu
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+ apache2? ( >=www-servers/apache-2.4[${APACHE_MODS}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.14-makefile.patch"
+)
+
+src_configure() {
+ local user_group=nagios
+ use icinga && user_group=icinga
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/pnp
+ --datarootdir="${EPREFIX}"/usr/share/pnp
+ --localstatedir="${EPREFIX}"/var/lib/pnp
+ --with-nagios-user="${user_group}"
+ --with-nagios-group="${user_group}"
+ --with-perfdata-logfile="${EPREFIX}"/var/log/pnp/process_perfdata.log
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # The default target just shows a help
+ emake all
+}
+
+src_install() {
+ # Don't use INSTALL_OPTS because they set insecure permissions on
+ # all of /etc/pnp (https://github.com/lingej/pnp4nagios/issues/140).
+ emake INSTALL_OPTS="" DESTDIR="${D}" install install-config
+ einstalldocs
+ newinitd "${FILESDIR}"/npcd.initd npcd
+ rm "${ED}/usr/share/pnp/install.php" || \
+ die "unable to remove ${ED}/usr/share/pnp/install.php"
+
+ # Fix CVE-2012-3457 (Gentoo bug 430358)
+ fperms o-rwx /etc/pnp/process_perfdata.cfg
+
+ if use apache2 ; then
+ insinto /etc/apache2/modules.d
+ newins "${FILESDIR}"/98_pnp4nagios-2.4.conf 98_pnp4nagios.conf
+ fi
+
+ # The nagios or icinga user needs to write performance data to the
+ # perfdata-dir...
+ local user_group=nagios
+ use icinga && user_group=icinga
+ fowners ":${user_group}" /var/lib/pnp/{,perfdata,spool}
+ fperms g+rwx /var/lib/pnp/{,perfdata,spool}
+
+ # and likewise for its logs...
+ dodir /var/log/pnp
+ fowners ":${user_group}" /var/log/pnp
+ fperms g+rwx /var/log/pnp
+
+ # and its statistics. This one is arguably the responsibility of the
+ # build system, since process_perfdata.cfg refers to this location.
+ dodir /var/lib/pnp/stats
+ fowners ":${user_group}" /var/lib/pnp/stats
+ fperms g+rwx /var/lib/pnp/stats
+}
+
+pkg_postinst() {
+ elog "To enable the pnp4nagios web front-end, please visit"
+ elog "${EROOT}/etc/conf.d/apache2 and add \"-D PNP -D PHP\""
+ elog "to APACHE2_OPTS. Then pnp4nagios will be available at,"
+ elog
+ elog " http://localhost/pnp4nagios"
+ elog
+}