summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2022-06-05 19:55:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-17 19:29:13 +0300
commit5fe467832ed42b523887aa610e8244d468d99c14 (patch)
treed6d19c8c96079b37734e61183cd69f2ee1a9c95b /net-analyzer/nikto
parentnet-firewall/nftables: backport upstream revert (diff)
downloadgentoo-5fe467832ed42b523887aa610e8244d468d99c14.tar.gz
gentoo-5fe467832ed42b523887aa610e8244d468d99c14.tar.bz2
gentoo-5fe467832ed42b523887aa610e8244d468d99c14.zip
net-analyzer/nikto: version bump to 2.1.6_p20220602
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/25769 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/nikto')
-rw-r--r--net-analyzer/nikto/Manifest1
-rw-r--r--net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/nikto/Manifest b/net-analyzer/nikto/Manifest
index 4f81fbf790d9..482137d6f73d 100644
--- a/net-analyzer/nikto/Manifest
+++ b/net-analyzer/nikto/Manifest
@@ -1,2 +1,3 @@
DIST nikto-2.1.6_p20200901.tar.gz 521285 BLAKE2B 243f0baf5835e5586b8270fc9dd1005c08e903f478666359c34bb0d30c0645f5ab9a19109718dbbd2f6015dcb64c3a98b832b5412c9151720dedd102fb1936d1 SHA512 88b9e681ce4588e3473f90c93ea41d46fc99a54b895185465cfe1a28152ad944edbadfcf5cee4540b4ec48eb78ca73a1952637c3da9038e52d837c0de5d0260c
DIST nikto-2.1.6_p20210304.tar.gz 521719 BLAKE2B 66715e109dfb47bb5ed6b64cfff4dbdd0667883e5ce28c26a7325645fe42ccfdcb6f9bcf956adce6f626c51ff363122724955eda86c715d4f8ec4894ebf1ae4a SHA512 d78cedad0b2f96d02964097699d5765fdb895b7ec1a9e196cbf9181888dd19cfca7d912f172a870e4b8bd2b53e4fc41407a60ed129ef24592909ef6111d04a0e
+DIST nikto-2.1.6_p20220602.tar.gz 455528 BLAKE2B 71094c786b274069eb17aac7d367bdc8535c7730afde7c7bf36d40719e2799561eb31ad9cc09ee39c47101880795eee0f1c46ca51c00644cdc23916033cc5f7e SHA512 5c8ce194951c10b8a5f4299e088928022193aa8ae7ed4fb6b9be76bcf03a405d776d6e30274f997ad9eeb95c012c7e09b6dec7cbecbe0ab4049e5d15529ae814
diff --git a/net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild b/net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild
new file mode 100644
index 000000000000..c5fef7c17092
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.1.6_p20220602.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Web server vulnerability scanner"
+HOMEPAGE="https://www.cirt.net/Nikto2"
+COMMIT="dc98b86d3860ea18d82b5a427ab7abcd57e01552"
+MY_P="${PN}-${COMMIT}"
+SRC_URI="https://github.com/sullo/nikto/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# nikto provides its own libwhisker, do no use net-libs/libwhisker[ssl]
+# https://bugs.gentoo.org/533900
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Net-SSLeay
+ net-analyzer/nmap
+ virtual/perl-JSON-PP
+"
+
+S="${WORKDIR}/${MY_P}/program"
+
+src_prepare() {
+ sed -i -e 's:/etc/nikto.conf:/etc/nikto/nikto.conf:' nikto.pl || die
+ sed -i -e 's:# EXECDIR=/opt/nikto:EXECDIR=/usr/share/nikto:' nikto.conf.default || die
+
+ default
+}
+
+src_install() {
+ insinto /etc/nikto
+ newins nikto.conf.default nikto.conf
+
+ dobin nikto.pl replay.pl
+ dosym nikto.pl /usr/bin/nikto
+
+ insinto /usr/share/nikto
+ doins -r plugins templates databases
+
+ dodoc docs/nikto_manual.html
+ dodoc docs/nikto_schema.sql
+ doman docs/nikto.1
+}