summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-20 09:29:53 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-20 09:31:52 +0200
commit3df1fe61a1972cbe325fc4298099897f42420691 (patch)
tree50b56f14c86d5017f566989e221cec3445daed26 /net-analyzer/nethogs/nethogs-0.8.6.ebuild
parentapp-crypt/p11-kit: Version bump (v0.23.21) (diff)
downloadgentoo-3df1fe61a1972cbe325fc4298099897f42420691.tar.gz
gentoo-3df1fe61a1972cbe325fc4298099897f42420691.tar.bz2
gentoo-3df1fe61a1972cbe325fc4298099897f42420691.zip
net-analyzer/nethogs: Version 0.8.6
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Closes: https://bugs.gentoo.org/738078 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/nethogs/nethogs-0.8.6.ebuild')
-rw-r--r--net-analyzer/nethogs/nethogs-0.8.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/nethogs/nethogs-0.8.6.ebuild b/net-analyzer/nethogs/nethogs-0.8.6.ebuild
new file mode 100644
index 000000000000..da998020a028
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.8.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+HOMEPAGE="https://github.com/raboof/nethogs"
+SRC_URI="https://github.com/raboof/nethogs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_compile() {
+ tc-export CC CXX
+ emake NCURSES_LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )" ${PN}
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="/usr" install
+ dodoc DESIGN README.decpcap.txt README.md
+}