summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-09 16:05:19 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-24 18:48:04 +0200
commitd732399786e547de9635cece332e0e425086c52a (patch)
tree42d67f8f9ed7b1d1b491234b1daec1acd6d5677f /net-analyzer/gvm-libs
parentnet-analyzer/gvm-tools: drop 2.0.0-r1, 2.1.0, 21.1.0 (diff)
downloadgentoo-d732399786e547de9635cece332e0e425086c52a.tar.gz
gentoo-d732399786e547de9635cece332e0e425086c52a.tar.bz2
gentoo-d732399786e547de9635cece332e0e425086c52a.zip
net-analyzer/gvm-libs: drop 20.8.1-r1
Signed-off-by: Florian Schmaus <flow@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/25400 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer/gvm-libs')
-rw-r--r--net-analyzer/gvm-libs/Manifest1
-rw-r--r--net-analyzer/gvm-libs/gvm-libs-20.8.1-r1.ebuild112
-rw-r--r--net-analyzer/gvm-libs/metadata.xml5
3 files changed, 1 insertions, 117 deletions
diff --git a/net-analyzer/gvm-libs/Manifest b/net-analyzer/gvm-libs/Manifest
index b6621741287e..fef2a714575a 100644
--- a/net-analyzer/gvm-libs/Manifest
+++ b/net-analyzer/gvm-libs/Manifest
@@ -1,2 +1 @@
-DIST gvm-libs-20.8.1.tar.gz 267872 BLAKE2B ec0979bba5e88692375fcdcdbd1c1b47c2d93e1d1c911884b77e0d81028bd6b587dac5f8aaae7439cbd1f594ec3c5708510bc2e356cadaefee221a11a1982efa SHA512 846b062b849688019715cbff1d6c4f6a1b4dd8c58cfdef78ea08df3cd104810e9091385cca3c49618538a28c42c0fe78a38fb934fbde604aef86e84c4f2dda94
DIST gvm-libs-21.4.4.tar.gz 298551 BLAKE2B 271716d8be2376e2b54218b95069e19d10939c5feda9894220418bf184c4098eeacf61d1faedd49fe3215aa0fbf4a4afcfe2a929ac88450502737eb8af8f8e35 SHA512 6c80820c830cbc2e62865a0823740d857db075f2faa1a1e58af7a8f07e0179e7a78934d7613ec57f144900a5530206d4c07c912a6bbe40ad9d0549f9443bfb12
diff --git a/net-analyzer/gvm-libs/gvm-libs-20.8.1-r1.ebuild b/net-analyzer/gvm-libs/gvm-libs-20.8.1-r1.ebuild
deleted file mode 100644
index 1554c843e226..000000000000
--- a/net-analyzer/gvm-libs/gvm-libs-20.8.1-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake toolchain-funcs
-
-DESCRIPTION="Greenbone vulnerability management libraries, previously named openvas-libraries"
-HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/gvm-libs/"
-SRC_URI="https://github.com/greenbone/gvm-libs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~x86"
-IUSE="extras ldap test radius"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- acct-group/gvm
- acct-user/gvm
- app-crypt/gpgme:=
- dev-libs/glib
- dev-libs/hiredis:=
- dev-libs/libgcrypt:=
- dev-libs/libxml2:=
- dev-perl/UUID
- net-libs/gnutls:=
- net-libs/libssh:=
- net-libs/libpcap:=
- sys-libs/zlib
- ldap? ( net-nds/openldap:= )
- radius? ( net-dialup/freeradius-client )"
-
-RDEPEND="
- ${DEPEND}"
-
-BDEPEND="
- dev-vcs/git
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
- extras? (
- app-doc/doxygen[dot]
- app-doc/xmltoman
- app-text/htmldoc
- dev-perl/CGI
- dev-perl/SQL-Translator
- )
- test? ( dev-libs/cgreen )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-disable-automagic-dep.patch
-)
-
-src_prepare() {
- cmake_src_prepare
- # QA-Fix | Remove doxygen warnings for !CLANG
- if use extras; then
- if ! tc-is-clang; then
- local f
- for f in doc/*.in
- do
- sed -i \
- -e "s*CLANG_ASSISTED_PARSING = NO*#CLANG_ASSISTED_PARSING = NO*g" \
- -e "s*CLANG_OPTIONS*#CLANG_OPTIONS*g" \
- "${f}" || die "couldn't disable CLANG parsing"
- done
- fi
- fi
-
- #Remove tests that doesn't work in the network sandbox
- if use test; then
- sed -i 's/add_test (networking-test networking-test)/ /g' base/CMakeLists.txt || die
- sed -i 's/add_test (util-test util-test)/ /g' boreas/CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- "-DLOCALSTATEDIR=${EPREFIX}/var"
- "-DSYSCONFDIR=${EPREFIX}/etc"
- "-DGVM_PID_DIR=${EPREFIX}/var/lib/gvm"
- "-DBUILD_TESTS=$(usex test)"
- "-DBUILD_WITH_RADIUS=$(usex radius)"
- "-DBUILD_WITH_LDAP=$(usex ldap)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use extras; then
- cmake_build -C "${BUILD_DIR}" doc
- cmake_build doc-full -C "${BUILD_DIR}" doc
- fi
- cmake_build rebuild_cache
- if use test; then
- cmake_build tests
- fi
-}
-
-src_install() {
- if use extras; then
- local HTML_DOCS=( "${BUILD_DIR}"/doc/generated/html/. )
- fi
- cmake_src_install
-
- # Set proper permissions on required files/directories
- keepdir /var/lib/gvm
- fowners -R gvm:gvm /var/lib/gvm
-}
diff --git a/net-analyzer/gvm-libs/metadata.xml b/net-analyzer/gvm-libs/metadata.xml
index aee1e2586edf..dcb5742e94b2 100644
--- a/net-analyzer/gvm-libs/metadata.xml
+++ b/net-analyzer/gvm-libs/metadata.xml
@@ -9,12 +9,9 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
- <use>
- <flag name="extras">Html docs support</flag>
- </use>
<longdescription lang="en">
This is the libraries module for the Greenbone Vulnerability Management Solution.
- It is used for the Greenbone Security Manager appliances and provides various
+ It is used for the Greenbone Security Manager appliances and provides various
functionalities to support the integrated service daemons.
</longdescription>
<upstream>