summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-31 16:10:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-31 16:10:02 +0100
commitef05153988eb8bf522b66dfe16c507cfa6ef1ba1 (patch)
tree899c88d57707ecabe6a5d45d140bb79f325f9e0a /media-video
parentmedia-video/obs-studio: add version 26.1.2 (diff)
downloadgentoo-ef05153988eb8bf522b66dfe16c507cfa6ef1ba1.tar.gz
gentoo-ef05153988eb8bf522b66dfe16c507cfa6ef1ba1.tar.bz2
gentoo-ef05153988eb8bf522b66dfe16c507cfa6ef1ba1.zip
media-video/obs-studio: Drop 25.0.8-r1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/obs-studio/metadata.xml1
-rw-r--r--media-video/obs-studio/obs-studio-25.0.8-r1.ebuild150
2 files changed, 0 insertions, 151 deletions
diff --git a/media-video/obs-studio/metadata.xml b/media-video/obs-studio/metadata.xml
index cd2070e38ea0..603cd8cc27ce 100644
--- a/media-video/obs-studio/metadata.xml
+++ b/media-video/obs-studio/metadata.xml
@@ -14,7 +14,6 @@
<use>
<flag name="fdk">Enable libfdk support for AAC encoding.</flag>
<flag name="imagemagick">Use ImageMagick for image loading instead of FFmpeg.</flag>
- <flag name="luajit">Build support for scripting via Luajit.</flag>
<flag name="nvenc">Enable NVENC encoding for nVidia video cards.</flag>
<flag name="python">Build support for scripting via Python 3.</flag>
<flag name="speex">Enable noise suppression filter support via
diff --git a/media-video/obs-studio/obs-studio-25.0.8-r1.ebuild b/media-video/obs-studio/obs-studio-25.0.8-r1.ebuild
deleted file mode 100644
index 2b2e4ee98621..000000000000
--- a/media-video/obs-studio/obs-studio-25.0.8-r1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
-# Does not work with 3.8+ https://bugs.gentoo.org/754006
-PYTHON_COMPAT=( python3_7 )
-
-inherit cmake-utils python-single-r1 xdg-utils
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/obsproject/obs-studio.git"
- EGIT_SUBMODULES=()
-else
- SRC_URI="https://github.com/obsproject/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
-fi
-
-DESCRIPTION="Software for Recording and Streaming Live Video Content"
-HOMEPAGE="https://obsproject.com"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex +ssl truetype v4l vlc"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-BDEPEND="
- luajit? ( dev-lang/swig )
- python? ( dev-lang/swig )
-"
-DEPEND="
- >=dev-libs/jansson-2.5
- dev-qt/qtcore:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtquickcontrols:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- dev-qt/qtxml:5
- media-libs/x264:=
- media-video/ffmpeg:=[x264]
- net-misc/curl
- sys-apps/dbus
- sys-libs/zlib
- virtual/udev
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXfixes
- x11-libs/libXinerama
- x11-libs/libXrandr
- x11-libs/libxcb
- alsa? ( media-libs/alsa-lib )
- fdk? ( media-libs/fdk-aac:= )
- imagemagick? ( media-gfx/imagemagick:= )
- jack? ( virtual/jack )
- luajit? ( dev-lang/luajit:2 )
- nvenc? ( >=media-video/ffmpeg-4[video_cards_nvidia] )
- pulseaudio? ( media-sound/pulseaudio )
- python? ( ${PYTHON_DEPS} )
- speex? ( media-libs/speexdsp )
- ssl? ( net-libs/mbedtls:= )
- truetype? (
- media-libs/fontconfig
- media-libs/freetype
- )
- v4l? ( media-libs/libv4l )
- vlc? ( media-video/vlc:= )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-25.0.8-gcc-10-build.patch" )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local libdir=$(get_libdir)
- local mycmakeargs=(
- -DDISABLE_ALSA=$(usex !alsa)
- -DDISABLE_FREETYPE=$(usex !truetype)
- -DDISABLE_JACK=$(usex !jack)
- -DDISABLE_LIBFDK=$(usex !fdk)
- -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
- -DDISABLE_SPEEXDSP=$(usex !speex)
- -DDISABLE_V4L2=$(usex !v4l)
- -DDISABLE_VLC=$(usex !vlc)
- -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
- -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
- -DUNIX_STRUCTURE=1
- -DWITH_RTMPS=$(usex ssl)
- )
-
- if [ "${PV}" != "9999" ]; then
- mycmakeargs+=(
- -DOBS_VERSION_OVERRIDE=${PV}
- )
- fi
-
- if use luajit || use python; then
- mycmakeargs+=(
- -DDISABLE_LUA=$(usex !luajit)
- -DDISABLE_PYTHON=$(usex !python)
- -DENABLE_SCRIPTING=yes
- )
- else
- mycmakeargs+=( -DENABLE_SCRIPTING=no )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- #external plugins may need some things not installed by default, install them here
- insinto /usr/include/obs/UI/obs-frontend-api
- doins UI/obs-frontend-api/obs-frontend-api.h
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-
- if ! use alsa && ! use pulseaudio; then
- elog
- elog "For the audio capture features to be available,"
- elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
- elog "be enabled."
- elog
- fi
-
- if ! has_version "sys-apps/dbus"; then
- elog
- elog "The 'sys-apps/dbus' package is not installed, but"
- elog "could be used for disabling hibernating, screensaving,"
- elog "and sleeping. Where it is not installed,"
- elog "'xdg-screensaver reset' is used instead"
- elog "(if 'x11-misc/xdg-utils' is installed)."
- elog
- fi
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}