summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2018-03-04 11:46:36 -0500
committerMichał Górny <mgorny@gentoo.org>2018-03-06 17:57:09 +0100
commite056d18d09b20048a770715d8141b3be5aa9dbc0 (patch)
treedbe1700f6afc7f54c8636c823085ac7c3c5fdcf2 /media-video
parentdev-php/xdebug: Version bump for 2.6.0 (diff)
downloadgentoo-e056d18d09b20048a770715d8141b3be5aa9dbc0.tar.gz
gentoo-e056d18d09b20048a770715d8141b3be5aa9dbc0.tar.bz2
gentoo-e056d18d09b20048a770715d8141b3be5aa9dbc0.zip
media-video/motion: version bump to 4.1.1
This version adds support for the sqlite and webp USE flags. Closes: https://bugs.gentoo.org/639526 Closes: https://github.com/gentoo/gentoo/pull/7359
Diffstat (limited to 'media-video')
-rw-r--r--media-video/motion/Manifest1
-rw-r--r--media-video/motion/motion-4.1.1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/media-video/motion/Manifest b/media-video/motion/Manifest
index 4669a4226d91..3b3e5a98413e 100644
--- a/media-video/motion/Manifest
+++ b/media-video/motion/Manifest
@@ -1 +1,2 @@
DIST release-4.0.1.tar.gz 444779 BLAKE2B e74b193f421e4fe165f36fe251eafe44203bbf8825b0062254bd7e0c9a57b286314c1bbb287c1c768db62649d82b83f4876ef236e446a1f21f7baf90d5ce5b4d SHA512 6ccde3890e6af56f28208321987dd1b9d62a55bbe7cbc3ab5600263602e6e8f47589392c2f3a3a6cb54f927ee76aea94d0e83f26ce8e4047890c891b6c2f8976
+DIST motion-release-4.1.1.tar.gz 447795 BLAKE2B 8c7dfdad89f49ba8ec39689d268b4bc95c6a8bd85d4bd333f66638b2e815b3c59b2e42dd93811601b2ee7870100a0a21eaa789633056f74a5cc9f39f4f92229f SHA512 3b08d464f9243ccfc4b53b16cfc2001d1e0d206bf0295d55d8914914bc14ad0248ce5ac622cb7eb89ed32e1913a9a10add1b56497c4094ba876f7f85d6ad4143
diff --git a/media-video/motion/motion-4.1.1.ebuild b/media-video/motion/motion-4.1.1.ebuild
new file mode 100644
index 000000000000..a99365d405c8
--- /dev/null
+++ b/media-video/motion/motion-4.1.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools readme.gentoo-r1 user systemd
+
+DESCRIPTION="A software motion detector"
+HOMEPAGE="https://motion-project.github.io"
+SRC_URI="https://github.com/Motion-Project/${PN}/archive/release-${PV}.tar.gz -> ${PN}-release-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg libav mmal mysql postgres sqlite webp v4l"
+
+RDEPEND="
+ virtual/jpeg:=
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ mmal? ( media-libs/raspberrypi-userland )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )
+ webp? ( media-libs/libwebp:= )
+"
+DEPEND="${RDEPEND}
+ v4l? ( virtual/os-headers media-libs/libv4l )
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You need to setup /etc/motion/motion.conf before running motion for the
+first time. You can use /etc/motion/motion-dist.conf as a template.
+Please note that the 'daemon' and 'process_id_file' settings are
+overridden by the bundled OpenRC init script and systemd unit where
+appropriate.
+
+To install motion as a service, use:
+rc-update add motion default # with OpenRC
+systemctl enable motion.service # with systemd
+"
+
+S="${WORKDIR}"/${PN}-release-${PV}
+
+pkg_setup() {
+ enewuser ${PN} -1 -1 -1 video
+}
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ffmpeg) \
+ $(use_with mmal) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3) \
+ $(use_with v4l v4l2) \
+ $(use_with webp) \
+ --without-optimizecpu
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ examplesdir=/usr/share/doc/${PF}/examples \
+ install
+
+ newinitd "${FILESDIR}"/${PN}.initd-r3 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-r1 ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}.conf
+
+ keepdir /var/lib/motion
+ fowners motion:video /var/lib/motion
+ fperms 0750 /var/lib/motion
+
+ readme.gentoo_create_doc
+ readme.gentoo_print_elog
+}