summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/subtitleripper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/subtitleripper')
-rw-r--r--media-video/subtitleripper/Manifest1
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch21
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch25
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch28
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch28
-rw-r--r--media-video/subtitleripper/metadata.xml8
-rw-r--r--media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild50
7 files changed, 161 insertions, 0 deletions
diff --git a/media-video/subtitleripper/Manifest b/media-video/subtitleripper/Manifest
new file mode 100644
index 000000000000..2c58f74027eb
--- /dev/null
+++ b/media-video/subtitleripper/Manifest
@@ -0,0 +1 @@
+DIST subtitleripper-0.3-4.tgz 47299 SHA256 8af6c2ebe55361900871c731ea1098b1a03efa723cd29ee1d471435bd21f3ac4 SHA512 6d25a43b5b1bf8a6c69200c8bab995265356d1235a872bb641d30dbf27b765be9280325b4dd8aa625c25a865563bd7525dd277682d5baeff3c54951da7b9a86a WHIRLPOOL fd5f2703cb509cd6cad4158b2883ddcd974996591c9367d18a811ee5f9bf79139e77362067e97b9c691c14af7e94be2093d15fb6248a847be26eee95176347d8
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch
new file mode 100644
index 000000000000..8dc2b24f9f6a
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch
@@ -0,0 +1,21 @@
+diff -Naurp subtitleripper-orig/vobsub.c subtitleripper/vobsub.c
+--- subtitleripper-orig/vobsub.c 2003-12-08 03:28:02.000000000 -0600
++++ subtitleripper/vobsub.c 2009-05-30 19:09:13.266973499 -0600
+@@ -56,7 +56,7 @@ extern ssize_t getline(char **, size_t *
+ /* FIXME This should go into a general purpose library or even a
+ separate file. */
+ static ssize_t
+-getline (char **lineptr, size_t *n, FILE *stream)
++get_line (char **lineptr, size_t *n, FILE *stream)
+ {
+ size_t res = 0;
+ int c;
+@@ -753,7 +753,7 @@ vobsub_parse_one_line(vobsub_t *vob, FIL
+ do {
+ size_t line_reserve = 0;
+ char *line = NULL;
+- line_size = getline(&line, &line_reserve, fd);
++ line_size = get_line(&line, &line_reserve, fd);
+ if (line_size < 0) {
+ if (line)
+ free(line);
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch
new file mode 100644
index 000000000000..e9869b3bd5dd
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch
@@ -0,0 +1,25 @@
+diff -NrU5 subtitleripper.orig/spudec.c subtitleripper/spudec.c
+--- subtitleripper.orig/spudec.c 2009-05-20 03:06:23.000000000 -0600
++++ subtitleripper/spudec.c 2009-05-20 03:07:47.000000000 -0600
+@@ -34,17 +34,18 @@
+
+ #ifdef _HAVE_ZLIB_
+ #include <zlib.h>
+ #endif
+
++#ifdef _HAVE_PNG_
++#include <png.h>
++#endif
++
+ #ifdef _HAVE_LIB_PPM_
+ #include <netpbm/ppm.h>
+ #endif
+
+-#ifdef _HAVE_PNG_
+-#include "png.h"
+-#endif
+
+ static void spudec_handle_rest(spudec_handle_t *this);
+
+ // read a big endian 16 bit value
+ static inline unsigned int get_be16(const unsigned char *p)
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
new file mode 100644
index 000000000000..7efe223460fc
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
@@ -0,0 +1,28 @@
+Index: subtitleripper/Makefile
+===================================================================
+--- subtitleripper.orig/Makefile
++++ subtitleripper/Makefile
+@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
+ # Target
+ subtitle2pgm: subtitle2pgm.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) $^ -o $@
++ @$(CC) $^ -o $@ $(LIBS)
+
+ subtitle2vobsub: subtitle2vobsub.o vobsub.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) $^ -o $@
++ @$(CC) $^ -o $@ $(LIBS)
+
+ srttool: srttool.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) -g $^ -o $@
++ @$(CC) -g $^ -o $@ $(LIBS)
+
+ vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) -g $^ -o $@
++ @$(CC) -g $^ -o $@ $(LIBS)
+
+ .PHONY: clean dist rpm
+ clean:
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch
new file mode 100644
index 000000000000..2af11d257929
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch
@@ -0,0 +1,28 @@
+Index: subtitleripper/Makefile
+===================================================================
+--- subtitleripper.orig/Makefile
++++ subtitleripper/Makefile
+@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
+ # Target
+ subtitle2pgm: subtitle2pgm.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ subtitle2vobsub: subtitle2vobsub.o vobsub.o
+ @echo "Linking $@"
+- @$(CC) $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ srttool: srttool.o
+ @echo "Linking $@"
+- @$(CC) -g $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
+ @echo "Linking $@"
+- @$(CC) -g $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ .PHONY: clean dist rpm
+ clean:
diff --git a/media-video/subtitleripper/metadata.xml b/media-video/subtitleripper/metadata.xml
new file mode 100644
index 000000000000..8eeb88921a30
--- /dev/null
+++ b/media-video/subtitleripper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <upstream>
+ <remote-id type="sourceforge">subtitleripper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild b/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
new file mode 100644
index 000000000000..616bb73638db
--- /dev/null
+++ b/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator eutils toolchain-funcs
+
+MY_PV="$(replace_version_separator 2 "-")"
+
+DESCRIPTION="DVD Subtitle Ripper for Linux"
+HOMEPAGE="http://subtitleripper.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 x86"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tgz"
+SLOT="0"
+IUSE=""
+RDEPEND=">=media-libs/netpbm-10.41.0
+ media-libs/libpng
+ sys-libs/zlib
+ >=app-text/gocr-0.39"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # PPM library is libnetppm
+ sed -i -e "s:ppm:netpbm:g" Makefile
+ # fix for bug 210435
+ sed -i -e "s:#include <ppm.h>:#include <netpbm/ppm.h>:g" spudec.c subtitle2pgm.c
+ # we will install the gocrfilters into /usr/share/subtitleripper
+ sed -i -e 's:~/sourceforge/subtitleripper/src/:/usr/share/subtitleripper:' pgm2txt
+
+ epatch "${FILESDIR}/${P}-linkingorder.patch"
+ epatch "${FILESDIR}"/${P}-libpng.patch
+ epatch "${FILESDIR}"/${P}-glibc210.patch
+ # respect CC and LDFLAGS
+ sed -i -e "s:CC =.*:CC = $(tc-getCC):" \
+ -e "/^CFLAGS/s: = :& ${CFLAGS} :" "${S}"/Makefile
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+}
+
+src_install () {
+ dobin pgm2txt srttool subtitle2pgm subtitle2vobsub vobsub2pgm
+
+ insinto /usr/share/subtitleripper
+ doins gocrfilter_*.sed
+
+ dodoc ChangeLog README*
+}