summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/dvbackup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/dvbackup')
-rw-r--r--media-video/dvbackup/Manifest1
-rw-r--r--media-video/dvbackup/dvbackup-0.0.4-r1.ebuild53
-rw-r--r--media-video/dvbackup/files/dvbackup-0.0.4-gcc4.diff11
-rw-r--r--media-video/dvbackup/metadata.xml11
4 files changed, 76 insertions, 0 deletions
diff --git a/media-video/dvbackup/Manifest b/media-video/dvbackup/Manifest
new file mode 100644
index 000000000000..9305bd080fef
--- /dev/null
+++ b/media-video/dvbackup/Manifest
@@ -0,0 +1 @@
+DIST dvbackup-0.0.4.tar.gz 115303 SHA256 0020cd05d9985f5fcf80d49315373265d6d6a755efb0e18d337254f2aea249e1
diff --git a/media-video/dvbackup/dvbackup-0.0.4-r1.ebuild b/media-video/dvbackup/dvbackup-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..6d691f2052b7
--- /dev/null
+++ b/media-video/dvbackup/dvbackup-0.0.4-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A small utility for creating backups on DV tapes"
+HOMEPAGE="http://dvbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dvbackup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/glibc
+ dev-libs/popt
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ media-libs/libdv"
+
+src_prepare() {
+ local i
+
+ epatch "${FILESDIR}/${P}-gcc4.diff"
+
+ # fix Makefile to respect $LDFLAGS
+ sed -i -e 's:gcc \$(CFLAGS):\$(CC) \$(CFLAGS) \$(LDFLAGS):g' \
+ -e 's:^\(CFLAGS=\):#\1:g' Makefile
+
+ # convert LATIN1 docs to UTF-8
+ for i in ChangeLog ReleaseNotes; do
+ if [ -f "${i}" ]; then
+ echo ">>> Converting ${i} to UTF-8"
+ iconv -f LATIN1 -t UTF8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ fi
+ done
+}
+
+src_compile() {
+ emake dvbackup || die "emake failed"
+}
+
+src_install() {
+ dobin dvbackup
+ insinto /usr/share/${PN}
+ doins underrun-ntsc.dv underrun-pal.dv
+ dodoc AUTHORS ChangeLog ReleaseNotes
+ dohtml dvbackup.html
+}
diff --git a/media-video/dvbackup/files/dvbackup-0.0.4-gcc4.diff b/media-video/dvbackup/files/dvbackup-0.0.4-gcc4.diff
new file mode 100644
index 000000000000..1ab2c4b07eb8
--- /dev/null
+++ b/media-video/dvbackup/files/dvbackup-0.0.4-gcc4.diff
@@ -0,0 +1,11 @@
+diff -Naur dvbackup-0.0.4.orig/dvconnect.c dvbackup-0.0.4/dvconnect.c
+--- dvbackup-0.0.4.orig/dvconnect.c 2002-03-24 20:27:10.000000000 +0100
++++ dvbackup-0.0.4/dvconnect.c 2009-11-05 16:16:10.467442012 +0100
+@@ -9,6 +9,7 @@
+
+ #include <pthread.h>
+ #include <signal.h>
++#include <string.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
diff --git a/media-video/dvbackup/metadata.xml b/media-video/dvbackup/metadata.xml
new file mode 100644
index 000000000000..fd6948928d80
--- /dev/null
+++ b/media-video/dvbackup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">dvbackup</remote-id>
+ </upstream>
+</pkgmetadata>