summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 22:00:54 +0000
committerCraig Andrews <candrews@gentoo.org>2022-12-17 14:38:35 -0500
commitea3f9b515f106ef3b8a48009ddc7057acf5ea7b2 (patch)
tree8c800b09eccd0bf49a9b0742098af8ee9d8fa8aa /media-tv/kodi
parentwww-servers/apache: Stabilize 2.4.54-r6 ppc64, #880701 (diff)
downloadgentoo-ea3f9b515f106ef3b8a48009ddc7057acf5ea7b2.tar.gz
gentoo-ea3f9b515f106ef3b8a48009ddc7057acf5ea7b2.tar.bz2
gentoo-ea3f9b515f106ef3b8a48009ddc7057acf5ea7b2.zip
media-tv/kodi: mesa 22.3.0 compatibility
Closes: https://bugs.gentoo.org/885419 Closes: https://github.com/gentoo/gentoo/pull/28683 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-tv/kodi')
-rw-r--r--media-tv/kodi/files/kodi-19.4-fix-mesa-22.3.0-build.patch12
-rw-r--r--media-tv/kodi/kodi-19.4-r3.ebuild5
-rw-r--r--media-tv/kodi/kodi-19.4-r4.ebuild5
3 files changed, 22 insertions, 0 deletions
diff --git a/media-tv/kodi/files/kodi-19.4-fix-mesa-22.3.0-build.patch b/media-tv/kodi/files/kodi-19.4-fix-mesa-22.3.0-build.patch
new file mode 100644
index 000000000000..e9ff90dfe55d
--- /dev/null
+++ b/media-tv/kodi/files/kodi-19.4-fix-mesa-22.3.0-build.patch
@@ -0,0 +1,12 @@
+--- xbmc/xbmc/windowing/X11/GLContextEGL.h
++++ xbmc/xbmc/windowing/X11/GLContextEGL.h
+@@ -13,7 +13,7 @@
+ #include "threads/CriticalSection.h"
+
+ #include <EGL/eglext.h>
+-#include <EGL/eglextchromium.h>
++#include <EGL/eglext_angle.h>
+ #include <X11/Xutil.h>
+
+ class CGLContextEGL : public CGLContext
+
diff --git a/media-tv/kodi/kodi-19.4-r3.ebuild b/media-tv/kodi/kodi-19.4-r3.ebuild
index caecc50cdfca..cc58afabb027 100644
--- a/media-tv/kodi/kodi-19.4-r3.ebuild
+++ b/media-tv/kodi/kodi-19.4-r3.ebuild
@@ -208,6 +208,11 @@ src_unpack() {
}
src_prepare() {
+ # https://bugs.gentoo.org/885419
+ if has_version ">=media-libs/mesa-22.3.0"; then
+ PATCHES+=( "${FILESDIR}/${P}-fix-mesa-22.3.0-build.patch" )
+ fi
+
cmake_src_prepare
# avoid long delays when powerkit isn't running #348580
diff --git a/media-tv/kodi/kodi-19.4-r4.ebuild b/media-tv/kodi/kodi-19.4-r4.ebuild
index 3fcd9b13f6b0..d295604a6976 100644
--- a/media-tv/kodi/kodi-19.4-r4.ebuild
+++ b/media-tv/kodi/kodi-19.4-r4.ebuild
@@ -209,6 +209,11 @@ src_unpack() {
}
src_prepare() {
+ # https://bugs.gentoo.org/885419
+ if has_version ">=media-libs/mesa-22.3.0"; then
+ PATCHES+=( "${FILESDIR}/${P}-fix-mesa-22.3.0-build.patch" )
+ fi
+
cmake_src_prepare
# avoid long delays when powerkit isn't running #348580