summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-02-23 00:03:53 +0100
committerSam James <sam@gentoo.org>2021-02-26 14:25:10 +0000
commit17cabe3661f26ee1930298def0fc3e43eea354f3 (patch)
tree3ab8c495b47108291e03e4402859429124311dc4 /media-sound/sndio/sndio-1.7.0-r1.ebuild
parentmail-filter/spamassassin: Cleanup old ebuilds (diff)
downloadgentoo-17cabe3661f26ee1930298def0fc3e43eea354f3.tar.gz
gentoo-17cabe3661f26ee1930298def0fc3e43eea354f3.tar.bz2
gentoo-17cabe3661f26ee1930298def0fc3e43eea354f3.zip
media-sound/sndio: Remove errorneous command_user from initd script
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/19608 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/sndio/sndio-1.7.0-r1.ebuild')
-rw-r--r--media-sound/sndio/sndio-1.7.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/sndio/sndio-1.7.0-r1.ebuild b/media-sound/sndio/sndio-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..fcc60e727985
--- /dev/null
+++ b/media-sound/sndio/sndio-1.7.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="small audio and MIDI framework part of the OpenBSD project"
+HOMEPAGE="http://www.sndio.org/"
+SRC_URI="http://www.sndio.org/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/7.0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
+IUSE="alsa"
+
+DEPEND="
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-user/sndiod
+"
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ tc-export CC
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --privsep-user=sndiod \
+ --with-libbsd \
+ $(use_enable alsa) \
+ || die "Configure failed"
+}
+
+src_install() {
+ multilib-minimal_src_install
+
+ doinitd "${FILESDIR}/sndiod"
+}